Rendering PNG sequence error

Contributor ,
Dec 21, 2021 Dec 21, 2021

Copy link to clipboard

Copied

I'm trying to render a PNG sequence as below and I get the following errors:

- AEGP Plugin PNGIO Support: PNGIO library error: known incorrect sRGB profile

01.png

- AEGP Plugin PNGIO Support: unable to create PNGIO02.png

- An unexpeted error occurred while exporting a composition. Error Code: 1

03.png

As a result, it exported just one 0-byte png, which is damaged.

If I open the same project on another machine (again on Windows), it renders without any warning/errors:

04.png

Any help?

 

TOPICS
Error or problem , Import and export

Views

1.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , May 19, 2022 May 19, 2022

Hi all,

 

This issue was fixed in After Effects 22.3.

 

Thanks,

Rameez

Likes

Translate

Translate
Explorer ,
Jan 21, 2022 Jan 21, 2022

Copy link to clipboard

Copied

This is happening for me as well! This only happens to me when I am working in a linerized scene. Never happened before the most recent update. PNG exports will work on unmanaged nonlinear files. Working on windows 10.

 

I do a lot of 3D comp work where exports need to be in PNG format. Please fix this adobe!!

 

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 21, 2022 Jan 21, 2022

Copy link to clipboard

Copied

I feel your pain. I've downgraded to the previous version until this is
resolved.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 24, 2022 Jan 24, 2022

Copy link to clipboard

Copied

This might be relevant. I'm getting these exact errors when using the plugin AEP to Mogrt to batch export comps to mogrt-files. I assume it happens when creating poster images/thumbnails for the templates?

Had this problem with AE 2022 under MacOS Big Sur, still there on version 22.1.1 and MacOS Monterey. Exporting the same comps using the same plugin in AE 2021 works just fine.

MacOS Monterey 12.1 
Retina iMac 5K, 27-inch, 2020

3,8 GHz 8-Core Intel Core i7

64 GB 2667 MHz DDR4

AMD Radeon Pro 5700 XT 16 GB

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 25, 2022 Jan 25, 2022

Copy link to clipboard

Copied

Also having this issue currently. Choosing 'preserve RGB color management' temporarily allows a PNG to render, but won't with 'embed profile' checked.

 

AE 22.1.1 (Build 74)

Running MacOS Monterrey v. 12.1

 

Mac (Retina 5K, 27-inch, 2020)

3.8 GHz 8-Core Intel Core i7

128 GB 2667 MHz DDR4

AMD Radeon Pro 5700 XT 16 GB

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 07, 2022 Feb 07, 2022

Copy link to clipboard

Copied

22.2.1 version doesn't fix this issue 😞

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 08, 2022 Feb 08, 2022

Copy link to clipboard

Copied

Errrrrrrrr same here, is PNG technology new?

 

Cmon Adobe!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2022 Feb 08, 2022

Copy link to clipboard

Copied

That is very disappointing. PNG Seq are a deal-breaker.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 08, 2022 Feb 08, 2022

Copy link to clipboard

Copied

It would be great to get an ETA on a fix for this from Adobe! This issue is a pain in the neck if I want to keep up with current updates.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 13, 2022 Feb 13, 2022

Copy link to clipboard

Copied

An update came through today which has solved the problem for me!  I'm now on 22.2.0 (Build 120).  I hope this solves the problem for everyone!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 13, 2022 Feb 13, 2022

Copy link to clipboard

Copied

Shouldn't the last version be 22.2.1?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 13, 2022 Feb 13, 2022

Copy link to clipboard

Copied

I just verified the updated version I have.  It says 22.2.0 (Build 120).  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 14, 2022 Feb 14, 2022

Copy link to clipboard

Copied

Not for me, still can't export a single or animated PNG file!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 15, 2022 Feb 15, 2022

Copy link to clipboard

Copied

I should also point out I recently updated my NVIDIA graphics drivers to Studio 511.79 because it specifially mentioned improved support for RedShift.  Previously, I was running an older driver because of stability issues.  I wonder if that is related?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 16, 2022 Feb 16, 2022

Copy link to clipboard

Copied

Hi all,

 

I'm really sorry that you're running into this bug!

The After Effects team is aware of it and are working on a fix.

 

Until the bug is fixed, please follow the workaround shared by basg95488575.

I've marked their post as a correct answer (for now) so that other people visiting the discussion can find it easily. When the bug will be fixed, I'll unmark it as the correct answer.


Thanks,

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 08, 2022 Mar 08, 2022

Copy link to clipboard

Copied

Confirmed 22.2.1 still does not address this issue! Just in-case anyone wants to update AE.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 10, 2022 Mar 10, 2022

Copy link to clipboard

Copied

I thought the problem was fixed for me but it is not.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 15, 2022 Mar 15, 2022

Copy link to clipboard

Copied

okay guys, I tried that png export again, newest NVidia Studio Driver (511.65) for my dual 2080Ti Win10 Workstation and AE 22.2.1 (Build 3) running. Bug is still persistent, not able to render out PNG sequences.

The workaround of changing the color profile does not work here, I cannot change my profile as this would change my colors. I need to render exactly the same look I had before.

Please, Adobe, fix this issue!

 

My workaround this time was to render out a PSD sequence instead. I still wonder why, but that worked. Hope that helps somebody that has the issue...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 15, 2022 Mar 15, 2022

Copy link to clipboard

Copied

Exactly Adobe it's not a workaround if you are working with ACES!!! Fix It!!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 19, 2022 May 19, 2022

Copy link to clipboard

Copied

LATEST

Hi all,

 

This issue was fixed in After Effects 22.3.

 

Thanks,

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines