Simple 3D projection is soft / blurry

Community Beginner ,
Aug 12, 2020 Aug 12, 2020

Copy link to clipboard

Copied

I have a photo, I'm animating a small push in. I created a few solids for the ground, a building, and some awnings. The projection is working as expected, but it's noticeably softer and more blurry than the guide layer.

I've tried everything I could find online: No depth of field on the camera, shadow map set to 4000, no shadow diffusion, and it doesn't seem to matter if the projection material is close to either the light or the projection catcher. Camera settings and projector resolution don't help either.

Rick Gerard recommends parallel lights for projections, and while a parallel light does produce a sharper projection, as far as I can tell a parallel light will only project correctly onto a perpendicular surface. My ground plane doesn't receive a projection and my awnings (at a 45 degree angle to the building) are distorted.

I looked at the Cinema 4D renderer, but I can't get any projections out of it; materials don't have the "Transmit Shadows" option.

I'm afraid my answer is "Yeah, projections in AE are a little blurry." Can anyone confirm? Would I have better luck in Flame?

 

Thanks for your time.

TOPICS
Error or problem , How to

Views

1.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Aug 13, 2020 Aug 13, 2020

In case someone finds this in the future, I discovered that the focal length of the camera was the main culprit.

For reasons beyond my understanding, longer focal lengths resulted in a blurrier projection. Ludicrously short (5mm) lenses gave me a much sharper projection. I'd love to know why if someone could provide an explanation.

Likes

Translate

Translate
Adobe Community Professional ,
Aug 12, 2020 Aug 12, 2020

Copy link to clipboard

Copied

And what is the actual resolution of the source files? Comp Settings?

 

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 13, 2020 Aug 13, 2020

Copy link to clipboard

Copied

Yes; everything is 1920x1080.

I even tried a 3k file as the projected image, but same blurry result.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 13, 2020 Aug 13, 2020

Copy link to clipboard

Copied

If you want to use a spotlight you have to make sure that shadow diffusion is set to zero.

 

Using a parallel light is by far the easiest, but Parallel lights are a bit tricky to set up to light a scene.  Add your Parallel light and position it so that it lights up the scene properly. Use the Point of Interest and the position of the light.  Add your Gobo (the image you want to project, make it a 3d layer, and press the 'a' key twice. Set the Gobo to Cast Shadows Only and light transmission to 100%. Hold down the Shift key and Parent the Gobo to the parallel light to snap it to the proper position and orientation. If you don't see any projection select your wall and floor layer, press 'aa', and make sure that Receives shadows is turned on.

 

If the projection needs to be bigger, scale the Gobo layer. If you really want to use a Spot Light, keep the parent of the Gobo layer (remember Shift + Parent), then press P to reveal the position property and grab the Z value, which should be zero, hold down the shift key to move quickly, and increase the Z distance from the Spot Light. Finalize the size of the projection by using the scale.  There is no reason for the projection not to work for either light. 

 

The only way to avoid distortion on the surface receiving the projection is to perfectly line up the Gobo with the surface. It's just like a real projector. Here again, the Parallel light is your friend. Just set it up so it is lighting the scene properly. Shift + parent the Gobo to the surface that you want it to line up with and not be distorted, then manipulate the Z value first to bring the Gobo away from the wall, then drag the X and Y values to move the gobo into the right position and adjust the size with Scale. Here's a comp showing all 4 techniques. This is the simplest one, Shift + Parent a Gobo layer to a Parallel light. It takes about 2 seconds to setup. Adjusting the Point of Interest moves the image and the image is always perpendicular to the light source.

Screenshot_2020-08-13 00.14.41_CQmjYx.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 13, 2020 Aug 13, 2020

Copy link to clipboard

Copied

Thank you for both your reply and the helpful AE project file.

However, none of your suggestions made the projection less blurry.

In your example project, I put my image file at the top of your Gobo comp, and it was still soft in all four cases.

The Parallel comps were a bit sharper than the Spotlight comps. I'm surprised I haven't found anyone but you touting that workflow; I like it and it makes sense. Unfortunately, I think it's better suited to projecting a patch onto a wall, as opposed to recreating parallax from a still image.

If I'm understanding technique #4 correctly (where you parent the Gobo to the surface, instead of the light), you would need one Gobo per surface, right? So a wall and a floor would each have their own Gobo.

As I mentioned in a reply below, I found that short focal lengths greatly reduced the blurriness of the projections, although I don't know why. Any idea?

Thank you again for your time and the project. I would suggest that in your example compositions, the recieving walls should have "Accepts Lights" set to OFF.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 13, 2020 Aug 13, 2020

Copy link to clipboard

Copied

The lights in After Effects work just like lights in the real world. With a spotlight and a point light the light rays start out from a single point and that gives you tapered shadows, and that is what projection is - shadows cast on another surface. That is why the perspective is a little different when you use spotlights or point lights to cast shadows. The Parallel light simulates a light coming from a great distance, like the sun, so shadows cast by the sun have parallel edges and when you use Parallel lights for a gobo you get less distortion. 

 

The biggest cause of diffusion when using AE's lights and a Gobo (image) is the shadow diffusion. With a spotlight or point light, a 1-pixel shadow diffusion when the gobo is 10 pixels from the surface catching the shadow is going to still look pretty sharp, but if you move the gobo back 1000 pixels that 10-pixel blur is going to become a big problem. It's just like a real projector. Shadow Diffusion is actually the same thing as a lens that is out of focus. The farther away from the lens (the gobo), the greater the diffusion is on the projected image. Camera Focal Length should have nothing do to with it. Distance from the shadow catcher (the screen) has everything to do with sharpness. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 20, 2020 Aug 20, 2020

Copy link to clipboard

Copied

I agree that focal length *shouldn't* have anything to do with it, but it definitely *does*.

Like I said in my original post, it didn't make a difference if the gobo was close to the projector or close to the receiving wall.

Don't take my word for it, check for yourself in your example project with a high-detail image.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 13, 2020 Aug 13, 2020

Copy link to clipboard

Copied

In case someone finds this in the future, I discovered that the focal length of the camera was the main culprit.

For reasons beyond my understanding, longer focal lengths resulted in a blurrier projection. Ludicrously short (5mm) lenses gave me a much sharper projection. I'd love to know why if someone could provide an explanation.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 13, 2020 Aug 13, 2020

Copy link to clipboard

Copied

It's probably a bug in the code that effectively doesn't disable depth of field, but only still calculates it with a very small kernel size, resulting in the blurriness. You might want to report your findings on the Adobe User Voice board linked from this forum.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 04, 2021 Aug 04, 2021

Copy link to clipboard

Copied

Increase Shadow Map Resolution to 4000. Not the camera setting

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 04, 2021 Aug 04, 2021

Copy link to clipboard

Copied

In my original post, I specifically stated that I had already set the shadow map to 4000.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 29, 2021 Jul 29, 2021

Copy link to clipboard

Copied

Yes, having the same here. Here you can see that the image is cleared fuzzy at the distance, no DOF turned on, no Motion Blur, no effects, just plain shape layers and a camera.

hypnostudio_0-1627551825311.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 27, 2021 Sep 27, 2021

Copy link to clipboard

Copied

I have the same problem. When ever the camera is close to parallel to the 3d plane, the distance will be blurred. I tried with both .ai, .png and native AE shapes. Solids in AE works like it should. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 04, 2021 Aug 04, 2021

Copy link to clipboard

Copied

You should increase Shadow map Resolution to 4000. This will make all the image sharp. Not the camera, even if DoF is off.

 

Comp Setting> 3D Renderer> Option

Screen Shot 2021-08-04 at 11.53.24 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 04, 2021 Aug 04, 2021

Copy link to clipboard

Copied

Shadow Map Resolution Comp Size:

Screen Shot 2021-08-04 at 11.59.19 PM.png

 

Shadow Map Resolution 4000

Screen Shot 2021-08-04 at 11.59.33 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 04, 2021 Aug 04, 2021

Copy link to clipboard

Copied

Hi, thanks for the answer, but not really.

 

I just tried it, based on your suggestion, but this has nothing to do with the shadow. No lights or shadows in the scene, it's a rendering problem related to shapes.

 

hypnostudio_0-1628097836873.png

 

My solution was to switch the quality to non-antialiased...

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 18, 2022 Feb 18, 2022

Copy link to clipboard

Copied

no lights and shadow? how did you 3D project a scene without a light and shadow? the layer in front of the camera projected 'Cast Shadow only' on to a solid from a light.

 

https://www.youtube.com/watch?v=ldfYFsDUspU

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 15, 2022 Feb 15, 2022

Copy link to clipboard

Copied

For anyone with this issue in the future, I think I have found a valid understanding of the issue, as well as how to fix it.
If you used After Effect's 3D Camera Tracker, After Effects uses an arbitrary unit to determine the scale of your shot. Go back to you camera tracker and see if the bull's eye gizmo that gets drawn is very large. This means that After Effects thinks your shot is very small, and therefore the 3D camera and any 3D solids or nulls you create will be scaled very small. When you create a projection setup, even if you set your shadow map resolution very large, your 3D solids (that are being projected onto) are so small that they take up such a small percentage of the shadow map.

The solution is: Before you create your projection setup, parent your camera and any created 3D solids (from the tracking data) to a new null, scale up the parented null, then un-parent everything from that null (you can then delete the null). The result is that you've evenly scaled up all 3D geometry and your camera to a larger environment.

The only way that After Effects can solve this issue in the future is if you can set some arbitrary scene scale setting within the 3D Camera Tracker effect. You should be able to scale the tracking data up and down from within the effect.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 15, 2022 Feb 15, 2022

Copy link to clipboard

Copied

Upon further review, this technique doesn't actually work..

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 15, 2022 Feb 15, 2022

Copy link to clipboard

Copied

A workaround I've found is to set the shadow map size back to "Comp Size" and then scale your comp up 4x or so, then precomp it and set your new comp back to the original. It'll run a bit slower unfortunately.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 18, 2022 Feb 18, 2022

Copy link to clipboard

Copied

It has nothing to do with camera tracker. I don't use camera tracker for 3D projection comp. What for? the scene already in 3D space

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 18, 2022 Feb 18, 2022

Copy link to clipboard

Copied

LATEST

I used the 3D Tracker in my project which led me to the same issue mentioned here. If you read my comment, Imentioned I thought the issue is with the scene's scale in 3D space, not the 3D Tracker itself. However shortly later I realized that is not the issue. The shadow map resolution being too small is apparent regardless of the scale of the scene (I initially thought the size of layers had an effect on the shadow map resolution as well).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines