Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Sound won't pass through compositions

New Here ,
Sep 07, 2021 Sep 07, 2021

Copy link to clipboard

Copied

I have a project with compositions within compositions.

For example: Final composition < Pre-comp < Character composition

 

I've added sound to the "Character composition", just like I've done a million of times before, on other projects. Now, if I go to any composition that is before that (either "Pre-comp" or "Final composition"), the sound won't play at all. There is no wave form at all, the audio levels are normal and I am sure it's not muted on the timeline.

What's weird about it is that it plays normally on it's own composition. The sound won't render either if I render any of those other pre-compositions.

TOPICS
Audio, Error or problem

Views

52

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 07, 2021 Sep 07, 2021

Copy link to clipboard

Copied

Hi there,

 

This does not sound ideal. Could you confirm the version of Adobe AE? Also, please share a screenshot of the Audio Hardware Preferences.

We're here to help and sort the issue out.

 

Regards,

Shivangi

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

Hi there, sorry for the late reply. I'm on 18.4.1

 

I've noticed that it passes through from the pre-comp to the final comp if I have the sound on pre-comp. But it won't pass through from character comp at all - talking about a copy paste job from the character comp to the pre-comp.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 07, 2021 Sep 07, 2021

Copy link to clipboard

Copied

Please provide a screengrab of each of the three timelines with the audio view expanded on each.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

Hi, so here's two screenshots of two compositions.

The first one is the first composition in which I have the sound (the character composition I have in the example):

AfterFX_dctx6PJgl7.png

The second screenshot is of the second composition. I only have a time remap to keep the last frame (the pre-comp in the example):AfterFX_mEIhqGOVXT.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

Oh I muted that layer just before the screenshot by accident. It still won't play audio if unmuted.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 07, 2021 Sep 07, 2021

Copy link to clipboard

Copied

This sounds like the audio in "Character composition" might be set to be a Guide Layer. Does the layer name have a little turquoise crosshair icon to the left of the name? If so, the idea of guide layers are that they can be used as guides in the current composition you're working in, but they won't pass through to other comps up in the hierarchy and they won't render unless you specifically ask them to in export settings. You can easily enable or disable a layer as a guide by right-clicking the layer and unchecking "Guide Layer." Alternatively, you might not have the speaker icon selected on the pre-comps. It's next to the layer eyeball icon. If you can see this speaker icon, then my bet is on the guide layer. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

Hi, I checked and it's not a guide layer. I even copied and pasted the layer into the middle composition and that one did pass through to the final composition. It's so odd!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

Maybe your audio cache files got messed up. You can delete the file from the Project panel, import it again, then try adding it to to your sequence. An even better test is to try a file (preferably .wav) that you haven't imported to this project at all yet. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

Sorry to dismiss your tip again! I tried that and it didn't work. I basically had to create 5 similar videos on this project. So I duplicated the same compositions 5 times, into 5 folders. In each video I have 5 different audio files, and I didn't work on them all at the same time. So I imported it (not replaced, imported into "project") and dragged it into place every time. The sound works fine from Pre-comp to Final comp IF the file is in the Pre-comp. If it's inside of the character composition, it won't pass through. I think it might be the composition itself that is bugged.

 

It's not happening in my new projects at the moment and I've finished the videos, so I'm just leaving this here as a report now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

Gotcha. Well the last thing I can think of is not that your audio is disabled on your "Character" pre-comp or that the audio inside is a guide layer, but that the Levels parameter on the "Character" comp either has an expression or is manually set to a very low level. It sounds like it might just be easier to create a blank "Character" comp, copy everything into it and drop that in your pre-comp.

 

This doesn't sound like a bug, just something set incorrectly somewhere. If it does happen again, make sure to file detailed steps at UserVoice so the AE team can see them because this is just a user-to-user forum: https://adobe-video.uservoice.com/forums/911311-after-effects

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

I've uploaded two screenshots if it helps, on one of the comments above.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

LATEST

Ah, right. And you said you muted the pre-comp just before the screenshot, so that's not the issue. In that case, the next easiest step, especially if other comps are working properly, is to simply create a new pre-comp and drop the contents of the previous one inside. This will help narrow down the location of the problem.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines