• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Trapcode Particular Physics Time Factor Skipping

Community Beginner ,
Feb 26, 2024 Feb 26, 2024

Copy link to clipboard

Copied

AE 24.1.0

Trapcode 2024.1.0

MacOS 14.3.1

M1 Ultra, 64 GB

 

We are trying to animate the speed of a fluid system. Go from regular speed and then ramp it down to slo motion. Using the Physics Time Factor in the Global Controls seems to be the trick but when I play it back the seems to skip after a few seconds. Anyone else seen this before? 

TOPICS
Performance

Views

192

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 27, 2024 Feb 27, 2024

Copy link to clipboard

Copied

Just out of curiosity what do you mean by skipping? Like dropping frames? Slowing things down in Particular using the Physics Time Factor has always been hit and miss in my experience.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 28, 2024 Feb 28, 2024

Copy link to clipboard

Copied

It did skip frames but all the particles jump. It looked like it would skip back several frames. However I did make a totally new composition and it seemed to work fine. But a few comps later and it was back again.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 28, 2024 Feb 28, 2024

Copy link to clipboard

Copied

Sorry...i meant it didnt drop frames.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 27, 2024 Feb 27, 2024

Copy link to clipboard

Copied

Try this. Create a constant flow at about your slow flow rate, Pre-compose moving all attributes, enable Time Remapping, and add some keyframes. It's pretty easy to visualize the speed changes if you open the graph editor and edit the speed graph.

 

I use Time Remapping all the time. You won't end up with repeated frames and it's much easier than any other way to vary the speed of any particle system.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 28, 2024 Feb 28, 2024

Copy link to clipboard

Copied

Yes I tried that but it does not look smooth enough.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 28, 2024 Feb 28, 2024

Copy link to clipboard

Copied

You have to start by making the particular layer longer than it is going to be in the final composition, then adjust the speed of the particles to the slowest speed you want in your design. Then, Pre-compose, Time Remap, and speed up the particles and slow them down as needed by moving keyframes closer together and keeping the speed graph between 1 second per second and faster.  As long as the slowest speed stays close to 1 second per second, you won't see any jumpy movement. 

 

The Speed Graph editor will look like this:

RickGerard_0-1709194127192.gif

The gif is only 8 FPS, but as you can see, the particles speed up and then move slowly for the last half of the animation. The slow speed was achieved by fiddling with the velocity and air density.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 29, 2024 Feb 29, 2024

Copy link to clipboard

Copied

Thank you! Like I mentioned it does not look smooth enough. I am probably slowing it down way too much. Honestly I was hoping to eliminate the extra step using the Global Controls instead of rendering at full speed to then slow it down in a new comp. But again thank you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 29, 2024 Feb 29, 2024

Copy link to clipboard

Copied

Try increasing the frame rate of the pre-comp to 120 or even 240 fps. 

 

Trying to animate physics and environment and still creating predictable paths and speeds is incredibly time-consuming and frustrating. Setting a higher frame rate in the Pre-comp will give you a lot more flexibility to manipulate time.

 

Adding Pixel Motion Blur or even Force Motion blur to the time remapped pre-comp will also give you control over that aspect of the project.  

 

Take a look at the goofy project I uploaded. The pre-comp is set to 300 FPS, and I slow it down, reverse it, and speed it up again with perfect smoothness.

Particular time remap.gif

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 29, 2024 Feb 29, 2024

Copy link to clipboard

Copied

LATEST

Yes! We rendered everything at 240 fps but didnt look smooth enough. Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines