Vector layer actualisation in AE

Community Beginner ,
Jun 19, 2022 Jun 19, 2022

Copy link to clipboard

Copied

Hey !

 

I have a problem of communication between After Effects and Illustrator.

I'm working on a project with a lot of animated vector layers, coming from two separated Ai files. My aim is to produce a serie of short videos with the exact same animation, but with different designs which will be changed directly in Illustrator.

So, animation in AE but design in Ai, and when I save the Ai file it update the layers in AE and I can export the result.

 

I did that and it worked very well for the first 3/4 designs, and after that it suddently broke.

- First, AE stopped updating the version of the layers. But when I double-clicked on a layer in the project panel, it show me the updated version ... and still won't update it in the different comp (nothing has been renamed, vectorized or pixelized)

- On the comp, when I right click the layer and select "open > modify the original", it opens me the Ai file, with my latest design. So the link is still there.

- Now, and without having touched anything, the layers version won't even update when I double-click them on the project panel. It shows me the previous version, and if I right click and go to "replace > file > select my Ai file > select the layer", it still won't update

 

So it's basically like AE is stuck with a previous version of my Ai file.

> I did try to rasterize the layers in the comps, everything got actualized, but when I updated and saved the Ai design, it still didn't make it to my AE project.

> From time to time, when I turn of AE, make a completely different design in Aim, save it and reopen AE, it will update ... and get stuck again ^^

 

So, I'm really lost on that. I've got a ton of layers and a ton of versions to export, so I really need this feature to work.

Does anybody has ever experienced this problem ?

 

I should specify that my layers are a bit complex (it's an illustration), and I'm working on a M1 Mac

 

TOPICS
Dynamic link , Error or problem , Import and export

Views

52

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Community Professional , Jun 19, 2022 Jun 19, 2022

Try cleaning the cache files of After Effects as follow (it might fix the issue) - 

1. Close any open project

2. Edit > Purge > All memory and Disk Cache...

3. In the Pop select okay. 

 

Now try opening the project and check if it works. 

 

 

Likes

Translate

Translate
Adobe Community Professional , Jun 21, 2022 Jun 21, 2022

Try the update that just came out today. It's got quite a few bug fixes related to Macs. https://community.adobe.com/t5/after-effects-discussions/after-effects-22-5-is-now-live/td-p/13019775

Likes

Translate

Translate
Adobe Community Professional ,
Jun 19, 2022 Jun 19, 2022

Copy link to clipboard

Copied

Try cleaning the cache files of After Effects as follow (it might fix the issue) - 

1. Close any open project

2. Edit > Purge > All memory and Disk Cache...

3. In the Pop select okay. 

 

Now try opening the project and check if it works. 

 

 

Vishu Aggarwal
Adobe Certified Instructor, Professional and Expert

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 20, 2022 Jun 20, 2022

Copy link to clipboard

Copied

Hi,

Thank you for the comment !

I tried and it worked once, but then it got stuck again and redoing the manip multiple times didn't solved it

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 21, 2022 Jun 21, 2022

Copy link to clipboard

Copied

Try the update that just came out today. It's got quite a few bug fixes related to Macs. https://community.adobe.com/t5/after-effects-discussions/after-effects-22-5-is-now-live/td-p/1301977...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 30, 2022 Jun 30, 2022

Copy link to clipboard

Copied

LATEST

Hey !
So, I've updated the AE version and tested it for a fiew days, seems like it was among the bugs that were fixed 🙂

I still have the the layers actualisation issue from time to time after and long use, but the disk cache purge is enough to solve it.

Thank you for the help guys !

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines