Video preview (mercury transit) not working in AE!

Participant ,
Mar 01, 2018 Mar 01, 2018

Copy link to clipboard

Copied

I'm running a new iMac Pro 10c with a USB-C hub with HDMI out.

The HDMI -> DVI cable goes in my 24inch JVC DT-V24L1D broadcast monitor.

Video Preview out is NOT working in AE, while it works perfectly in Premiere Pro !

And I troubleshooted almost everthing I know.

Reconnected the HDMI, because I've read AE sometimes maps video wrong?

Tried other USB-C ports.

Switching live between Premiere Pro and AE, hoping AE picks up the videolink.

Turned on/off mercury and choosing OpenGL/METAL and Software mode.

Nothing seems to work!

I'm very angry and frustrated because I'm a pro motiondesigner and I bought the 5k JVC screen + 2k blackmagic in 2011.

And AE NEVER ever outputted the preview on external monitor in realtime. Previews were always at 15fps!

Now after so many years and the introduction of USB-C -> HMDI I wanted to give it another shot... grrr still buggy as hell.

I hope someone can help me out, so I can finally start using that JVC screen.

My AE setup.

ae.png

My Premiere Pro layout. This works perfectly.

It outputs 1080p to my JVC LCD when scrolling the timeline of the clips.

pp.png

Views

2.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Mar 06, 2018 Mar 06, 2018

Hi,

Try dragging the After Effects window away from the edge of your preview screen. I had the same problem and the reason was that my AE window was too close to the edge so that the screen showed me the Ae interface instead of the video preview.

Likes

Translate

Translate
Participant ,
Mar 05, 2018 Mar 05, 2018

Copy link to clipboard

Copied

Nothing?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 06, 2018 Mar 06, 2018

Copy link to clipboard

Copied

Hi,

Try dragging the After Effects window away from the edge of your preview screen. I had the same problem and the reason was that my AE window was too close to the edge so that the screen showed me the Ae interface instead of the video preview.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 06, 2018 Mar 06, 2018

Copy link to clipboard

Copied

Damn. I removed my screen and setup. Cannot test right now.

But for all I know my AE screen is just perfectly 'full screen' on my main monitor.

YOu have to make it a big smaller?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 14, 2018 Mar 14, 2018

Copy link to clipboard

Copied

So, you're OK now multipasser? Let us know.

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 28, 2018 Jun 28, 2018

Copy link to clipboard

Copied

im having a similar issue.

I have been doing video mapping with aftereffect for couple years now. I had no problem with mercury transmit preview with macbookpro + video projector.

my new msi pc laptop does not seems to work with the same set up. I am wondering if i am missing any step. I am new to world of PC......HELP!!!!!!!

this is my laptop/specs  https://www.amazon.com/MSI-GS65-Stealth-THIN-054-i7-8750H/dp/B07BBJKCYG

im using AE & Premiere CC

thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 25, 2018 Sep 25, 2018

Copy link to clipboard

Copied

polonius  wrote

Hi,

Try dragging the After Effects window away from the edge of your preview screen. I had the same problem and the reason was that my AE window was too close to the edge so that the screen showed me the Ae interface instead of the video preview.

Thanks! Simple fix and it works!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 25, 2021 Oct 25, 2021

Copy link to clipboard

Copied

thanks @polonius 

worked a treat. Be good if Adobe could lock that mercury preview screen down so no AE window could go there. Why would a user want a UI windoe behind a preview screen? And if they did accidently have it so, why would they want the preview to stop working? Makes no sense, except perhaps another example of unfinshed programming by the AE team. They've only been working on this for how many decades now?

Also a quick toggle UI button for murcury on / off would very handy.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

Dragging the edge of the window from the preview screen does not fix the issue for me. The preview screen has nothing on it and the AE windows moved over and yet it still crashes.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jul 20, 2022 Jul 20, 2022

Copy link to clipboard

Copied

LATEST

The solution' that was honored as being a correct answer does not work for me.

Maybe it works in a setup where the HDMI screen is used as an extended desktop.

But what I need is to output Ae the Comp viewer directly to HDMI, without desktops or windows. Just like Premiere does. 

In Premiere it is easy to select the second screen in the Playback Preferences, but in Ae, this looks different, and the second screen does not show up at all.

 

I am on a MacPro 2019 / VegaII / Ae 22.5

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines