Highlighted

After Effects content-aware fill layer generation aborted

Community Beginner ,
Jul 14, 2019

Copy link to clipboard

Copied

After Effects warning: All target frames are completely opaque (no holes to fill). The Content-Aware Fill layer generation for Comp (Atrium_8_36_am) has been aborted.

Has anyone received this error, or know how to avoid it?

The Atrium_8_36_am is the name of my source file.

This error came up on a large file, after a night of After Effects Content-Aware process in "analyzing" mode. The analyzing process went through to 100%, then produced the error message, and started again at 0".

This is with a 5.6 360-degree video file that is about eight minutes long, so it is a big file.

I believe I had all the settings correct.

I'm using an iMac Pro with a Terabyte of storage, so it didn't run out of space.

Any help appreciated, thanks.

Adobe Community Professional
Correct answer by davidarbor | Adobe Community Professional

The error is telling you that there are no holes to fill. Do you have a mask on your video that's set to Subtract? You can create holes in your layer to fill a few different ways, including masks, track mattes, or other effects that would knock out pixels, but you need to see transparent pixels in order for CAF to do its magic. You can show the Transparency Grid in your Comp panel to confirm that everything is set up correctly. If you do have a mask, make sure the mode is set to "Subtract," not "None."

Also, do you really need to be removing something from an eight minute file? Your fill layers will be absolutely massive, and it's generally best practice to only do roto work on the frames that will be in the final shot, plus some necessary handles.

Views

5.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

After Effects content-aware fill layer generation aborted

Community Beginner ,
Jul 14, 2019

Copy link to clipboard

Copied

After Effects warning: All target frames are completely opaque (no holes to fill). The Content-Aware Fill layer generation for Comp (Atrium_8_36_am) has been aborted.

Has anyone received this error, or know how to avoid it?

The Atrium_8_36_am is the name of my source file.

This error came up on a large file, after a night of After Effects Content-Aware process in "analyzing" mode. The analyzing process went through to 100%, then produced the error message, and started again at 0".

This is with a 5.6 360-degree video file that is about eight minutes long, so it is a big file.

I believe I had all the settings correct.

I'm using an iMac Pro with a Terabyte of storage, so it didn't run out of space.

Any help appreciated, thanks.

Adobe Community Professional
Correct answer by davidarbor | Adobe Community Professional

The error is telling you that there are no holes to fill. Do you have a mask on your video that's set to Subtract? You can create holes in your layer to fill a few different ways, including masks, track mattes, or other effects that would knock out pixels, but you need to see transparent pixels in order for CAF to do its magic. You can show the Transparency Grid in your Comp panel to confirm that everything is set up correctly. If you do have a mask, make sure the mode is set to "Subtract," not "None."

Also, do you really need to be removing something from an eight minute file? Your fill layers will be absolutely massive, and it's generally best practice to only do roto work on the frames that will be in the final shot, plus some necessary handles.

Views

5.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 14, 2019 2
Adobe Community Professional ,
Jul 16, 2019

Copy link to clipboard

Copied

The error is telling you that there are no holes to fill. Do you have a mask on your video that's set to Subtract? You can create holes in your layer to fill a few different ways, including masks, track mattes, or other effects that would knock out pixels, but you need to see transparent pixels in order for CAF to do its magic. You can show the Transparency Grid in your Comp panel to confirm that everything is set up correctly. If you do have a mask, make sure the mode is set to "Subtract," not "None."

Also, do you really need to be removing something from an eight minute file? Your fill layers will be absolutely massive, and it's generally best practice to only do roto work on the frames that will be in the final shot, plus some necessary handles.

[Please use the "Reply" button under the FIRST POST to ensure replies sort properly.]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 16, 2019 1
Community Beginner ,
Jul 17, 2019

Copy link to clipboard

Copied

Thanks, David.

It turns out I had deleted the "Fill" files, so AE couldn't find them.

User error, AE operated properly.

I tried removing the content from the whole file as it was shot with a 360 camera mounted below a drone, and I needed the bottom of the drone removed from the entire "flight". I did get AE to properly remove it, although I finally just cropped that part of the image out.

As I noted, AE did work properly. Thanks for your help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 17, 2019 1
Adobe Community Professional ,
Jul 17, 2019

Copy link to clipboard

Copied

Gotcha, glad you got it figured out. There's an option that's not on by default, but in the flyout (hamburger) menu of the CAF panel you can change your settings and have your fills managed automatically. I like this option on because deleting fills from my timeline then saving my project (or maybe it's deleting them from the Project panel then saving) will prompt a message that AE will delete the fills and remove them from your disk. This is great because those fill layers can take up soooo much space, especially if you do end up working on longer clips and can't crop things out.

[Please use the "Reply" button under the FIRST POST to ensure replies sort properly.]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 17, 2019 1
Community Beginner ,
Jul 17, 2019

Copy link to clipboard

Copied

Excellent, thanks.

Here's a directly related question. For all this work, I upgraded from my MacBook Pro to an iMacPro, 32GB RAM, 8-core, 56 graphics card. I've been advised that the "sweet spot" for the iMacPro is 10-core, 64 graphics card. As an AE user doing video context-aware fills, do you have any advice on this difference? I have two weeks to decide to keep what I have or drop another $1K and upgrade, if I do so.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 17, 2019 0
Adobe Community Professional ,
Jul 20, 2019

Copy link to clipboard

Copied

I don't, sorry. While that 10-core is the sweet spot in terms of clock speed and number of cores (going for more cores drops the speed of each core pretty significantly) it depends how the tool works. If it's multi-threaded, then more cores will be better, if it's not fully multi-threaded then it won't make use of all of your resources. If you want to future proof your machine and you plan on having it for a very long time then I might consider upgrading, but it depends what else you'll be doing. After Effects is not currently multi-threaded, but it's something that the AE team has been working on for a very long time. Other older software is being modernized as well. Cinema 4D, for example, has a new core that's been implemented for the last few releases. Many tasks there are still single-threaded, but when that work is complete hopefully we'll all see massive speed boosts on machines with lots of cores.

My guess is that you're not going to see a major speed improvement right now with Content-Aware Fill, but software is only using the GPU more, so the upgrade there will also benefit you, if not now, then likely in the near future.

[Please use the "Reply" button under the FIRST POST to ensure replies sort properly.]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 20, 2019 1
New Here ,
Nov 15, 2019

Copy link to clipboard

Copied

I ran into the same error, but for a different reason. The footage was automatically being interpreted at Trillions of Colors+ (Straight) even though it didn't actually have an alpha channel. I set it to ignore alpha in interpret footage and it solved the problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 15, 2019 0
New Here ,
Apr 19, 2020

Copy link to clipboard

Copied

I had to solo my layer to get this to work before clicking "generate fill layer" to avoid the error message.  Make sure the matte shows through to transparent.  The results were still bad though, and I'll have to resort to a different method anyway.  Using 16.1.2, maybe this has been addressed in future updates.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 19, 2020 1
New Here ,
Jun 09, 2020

Copy link to clipboard

Copied

check that the work area in the timeline is in the area of your layer. It needs to recognize the footage in that specific time, if you move the work area it wont work

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 09, 2020 0
maarrkk LATEST
New Here ,
Jul 30, 2020

Copy link to clipboard

Copied

none of these options helped my issue.  but when i un-eyed / hid the other layers in the workspace, then it started to work....!!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 30, 2020 0