Highlighted

RAM Preview – Not in real-time

Community Beginner ,
Jun 29, 2016

Copy link to clipboard

Copied

Hello.

I'm having a hard time dealing with this new Preview in AE. A lot of times it is not giving me a real-time playback.

It is nice to have the preview continuously playing while making some changes on the comp, but sometimes I would like to have a real-time preview, like the old RAM preview.

Is it possible to generate a real-time RAM preview? I don't mind waiting for AE to render before playing back the animation.

I have tried the Numpad 0 and also spacebar. I've tried to purge all, restart machine, etc...

Thanks in advance.

Best,

Andre Arruda

After Effects 2015.3 (13.8.0.144)

Mac Pro (Late 2013)

3.5 GHz 6-Core Intel Xeon E5

64 GB 1866 MHz DDR3 ECC

Changing the monitor to 60Hz solved the problem here =]

TOPICS
Performance

Views

56.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

RAM Preview – Not in real-time

Community Beginner ,
Jun 29, 2016

Copy link to clipboard

Copied

Hello.

I'm having a hard time dealing with this new Preview in AE. A lot of times it is not giving me a real-time playback.

It is nice to have the preview continuously playing while making some changes on the comp, but sometimes I would like to have a real-time preview, like the old RAM preview.

Is it possible to generate a real-time RAM preview? I don't mind waiting for AE to render before playing back the animation.

I have tried the Numpad 0 and also spacebar. I've tried to purge all, restart machine, etc...

Thanks in advance.

Best,

Andre Arruda

After Effects 2015.3 (13.8.0.144)

Mac Pro (Late 2013)

3.5 GHz 6-Core Intel Xeon E5

64 GB 1866 MHz DDR3 ECC

Changing the monitor to 60Hz solved the problem here =]

TOPICS
Performance

Views

56.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 29, 2016 1
Adobe Community Professional ,
Jun 29, 2016

Copy link to clipboard

Copied

Pull your Preview panel down so you can see all of the options. Switch the preview shortcut dropdown to the Num 0 option and check to make sure it has the Cache before playback option checked. That should make it behave similar to the old RAM preview.

If you have a preview cached and it's not playing those cached frames back in real time, there's a bug.

One thing to try.

Make your timeline smaller. I'm assuming you're working on a 4K or 5K screen. Shrink your timeline panel vertically so it takes up a lot less screen space and try again.

If that doesn't help, try pressing ` to make your comp window fill the screen and try it.

If that doesn't help, try putting another panel (such as the libraries panel) underneath the timeline.

Please let us know your results.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 29, 2016 4
Community Beginner ,
Feb 22, 2018

Copy link to clipboard

Copied

I only have to use After Effects once in a blue moon and just encountered this non-real time audio playback on a fully cached ram preview issue today.  (FWIW I'm on Mac 10.12.6 and AE CC 2018)  I spent quite some time Googling a solution and finally ran across the bit posted here about putting the libraries panel under the timeline.  That fixed it.  Wait. WHAT!?!?!  Are you kidding me that in 2018 After Effects cannot successfully perform a cache to ram and playback with audio in sync without the user having to do something as bizarre are rearranging the user interface?!?!? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 22, 2018 3
Contributor ,
Feb 22, 2018

Copy link to clipboard

Copied

Yes and it is since CC 2015...

Moreover the panel under the timeline doesn't really fix the bug it works sometimes and sometimes not.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 22, 2018 0
Community Beginner ,
Feb 22, 2018

Copy link to clipboard

Copied

Indeed.  I spoke a tad too soon.  I now see that it takes a combination of the libraries panel and minimizing the timeline and neither is 100% reliable.  Absolutely ridiculous.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 22, 2018 2
Contributor ,
Feb 22, 2018

Copy link to clipboard

Copied

The only thing that works 100% is to shrink the AE windows to above 60% of its full screen size and the Ram preview fps becomes sudenly real time all the time.

Or you can tell it this way: to make AE work on a 4k monitor you have to shrink its size to a 2k monitor size... brillant.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 22, 2018 0
New Here ,
Jun 20, 2020

Copy link to clipboard

Copied

This did the trick for me. Pulling the library under the timeline.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 20, 2020 0
Community Beginner ,
Jun 29, 2016

Copy link to clipboard

Copied

Szalam​ thanks for your reply.

It seams to be a bug indeed. The checkbox "cache Before Playback" is checked.

Putting the libraries panel under the timeline did help a lot but I'm still having some playback under real-time (27/28 out of 30fps).

Thanks for ur help!

U28D590 Display
27.5-inch (3840 x 2160)

AMD FirePro D700 6144 MB graphics

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 29, 2016 0
Adobe Community Professional ,
Jun 29, 2016

Copy link to clipboard

Copied

So none of the other two suggestions worked, huh? Interesting.

Please, please, please file a bug report and give them as much information as you can (including what you've tried and what worked). This is one of those really persistent bugs introduced by this new architecture that the Adobe people need more help squashing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 29, 2016 0
Participant ,
Jul 14, 2016

Copy link to clipboard

Copied

I have the same problem here. Video preview was weird. Now that I'm previewing with an audio track I can definitely say that the preview is not realtime. Sometimes it doubles the frame, sometimes goes slower or faster. The audio sounds distorted and jumpy.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 14, 2016 0
Adobe Community Professional ,
Jul 14, 2016

Copy link to clipboard

Copied

Zulkifar2 wrote:

I have the same problem here. 

Did you try any of the things I suggested? If so, which ones and what were the results?

What exact version number of AE are you using?

What version number of your OS?

Please describe your computer hardware.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 14, 2016 0
Contributor ,
Sep 08, 2016

Copy link to clipboard

Copied

Same here, I wonder when this would be fixed.

I'm using iMac 5K Late 2015. Latest AE & Mac as right now. Upgrading to 32GB RAM from 8GB not helping though.

Tried submit bug report but when I submit there's error messages.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 08, 2016 2
Participant ,
Nov 03, 2016

Copy link to clipboard

Copied

Still the same problem here even after the new updates. Cache Before Playback is on. Can't preview 4 seconds without distortions. I'm on a Mac Pro with SierraOS.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2016 0
Adobe Community Professional ,
Nov 10, 2016

Copy link to clipboard

Copied

Davide Boscolo wrote:

Still the same problem here even after the new updates. Cache Before Playback is on. Can't preview 4 seconds without distortions. I'm on a Mac Pro with SierraOS.

That's got to be really frustrating. My Mac doesn't have the issue, but that's because it's a 15-inch MacBook Pro from 2011, so I don't have a huge screen resolution. I'm sure this is a high-priority issue for the AE team at Adobe as it's affecting so many people. They've done a few things to fix the issue for some people (it's not nearly as much of an issue in the CC 2017 release as it was in the first CC 2015 release), but the main issue is still a problem it would seem.

Hopefully they are close to a proper, real fix. They know it's a widespread issue that frustrates a lot of people, but it's taking a while to nail down the underlying cause. If you haven't yet, you could file a bug report. Give them as much technical information as you can about your system and the problem you're experiencing (but try to keep emotion out of it - I know it's frustrating and they know it's frustrating, so let's  just try to get it solved )..

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2016 0
Explorer ,
Jul 28, 2016

Copy link to clipboard

Copied

The green bar used to mean a rock-solid assurance that this cached content will play back right now. It now isn't worth the pixels it's displayed in.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 28, 2016 13
Community Beginner ,
Aug 18, 2016

Copy link to clipboard

Copied

Hello, so now its for me also time to get into the discussion because I have the exact same issues with the RAM Preview.

What I tried and what helps to get around this:

- making the timelinewindow smaller, so its just some layers high

- moving the rendered workarea out of the timeline view

If I see the timeline in "normal" size and the rendered work area, it makes also a lot of these vertical lines which look like coming from the current time indicator.

My system is a Z800 Win10 PC with latest AE 13.8.1.38 running. AND I am working with a two 4K Monitor Setup, while Windows scales 125%.

Another "strange" behavior while RAM Preview is, that during the glitchy playback, the Disk Cache is creating a lot of workload on my Media Stripeset, which I would not really expect because it should play out of the RAM? Shouldnt it?

Maybe I also should file in a bug report...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 18, 2016 3