Multiple compiler errors during movie export

Community Beginner ,
Jun 20, 2020 Jun 20, 2020

Copy link to clipboard

Copied

Does anybody know how to deal with compiler errors? Ive created animated sketch which is about 7 minutes long, but I am having trouble getting the file to export properly, even when i try to run a test viewing, it dosnt play as it does on the main timeline, everything all over the places, layers missing, camera dosnt zoom, cant seem to figure out what or where the issues are, keep getting the same 'compiler error' message, im still quite new to this programme, any help would be much appreciated, thanks.

Views

765

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 20, 2020 Jun 20, 2020

Copy link to clipboard

Copied

start with the top most message and correct it.  retest.  repeat.

 

to find the line number of the erroneous code click file>publish settings and tick "permit debugging".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 25, 2020 Jun 25, 2020

Copy link to clipboard

Copied

but im having trouble locating the problems individually as m not too sure what the message error is telling me, it has something to do with the camera i think.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 26, 2020 Jun 26, 2020

Copy link to clipboard

Copied

to find the line number of the erroneous code click file>publish settings and tick "permit debugging".

 

example error message:

Scene 1, Layer 'Layer_1', Frame 18, Line 1, Column 1 1120: Access of undefined property mc1.

 

which means in Scene 1, Layer_1, Frame 18 on line 1 is a reference to mc1 that animate doesn't understand.

 

 

 

p.s. if you still have a question about the resulting error message(s) you see, copy and paste the first error message.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 26, 2020 Jun 26, 2020

Copy link to clipboard

Copied

I am not sure what the error messages are telling me, I have a screenshot of the error messages that i have attatched.20200625_140402.jpg20200625_140411.jpg20200625_140626.jpg20200625_140632.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 26, 2020 Jun 26, 2020

Copy link to clipboard

Copied

copy and paste the error message.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 29, 2020 Jun 29, 2020

Copy link to clipboard

Copied

Error message 1: /Users/jemel/Documents/, Line 1, Column 6579 1152: A conflict exists with inherited definition flash.display:MovieClip.scenes in namespace public.

 

Error message 2:/, Applications/Adobe Animate CC 2019/Adobe Animate CC 2019.app/Contents/Common/Configuration/Camera/Flash/privatePkg/___Camera___.as, Line 1, Column 1 5000: The class 'privatePkg.___Camera___' must subclass 'flash.display.MovieClip' since it is linked to a library symbol of that type.

 

Error message 3: /Applications/Adobe Animate CC 2019/Adobe Animate CC 2019.app/Contents/Common/Configuration/Camera/Flash/privatePkg/___LayerProp___.as, Line 1, Column 1 5000: The class 'privatePkg.___LayerProp___' must subclass 'flash.display.MovieClip' since it is linked to a library symbol of that type.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 29, 2020 Jun 29, 2020

Copy link to clipboard

Copied

you're using a reserved name some place in your fla. the error's listed as being in /Users/jemel/Documents.  is that where you're saving your fla?  and the error is localized to line 1 column 6579 which looks like it would be in a minimized file.

 

you would see that error if you named an object MovieClip or true or x (all reserved words).  in your situation, you might check your document class name, if you have one.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 30, 2020 Jun 30, 2020

Copy link to clipboard

Copied

im not too sure on how to check my document class name, do you know what the other errors mean, and also are these errors all fixable?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 30, 2020 Jun 30, 2020

Copy link to clipboard

Copied

upload your fla to a file server and post a link.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 05, 2020 Jul 05, 2020

Copy link to clipboard

Copied

are you ok witth dropbox?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 08, 2020 Jul 08, 2020

Copy link to clipboard

Copied

yes.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 11, 2020 Jul 11, 2020

Copy link to clipboard

Copied

apoplogies for the delayed response, here is the link to the dropbox file

https://www.dropbox.com/s/0maimch5er0mf8l/mums%20life%20newDraft.fla?dl=0

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 12, 2020 Jul 12, 2020

Copy link to clipboard

Copied

i checked your file.

 

1. i saw a problem on the last frame that i corrected, but the errors persisted. 

2. i didn't see any code in you fla so there's no need to assign instance names to objects.  did you though?

3. the problem is introduced between frames 1547 and 3837.

 

doing more work on your file to find and fix the error would require more time than i am willing to do for free.  if you want to hire me to fix the problem, let me know.

 

otoh, i don't see a problem with the way your movie plays so, if you don't see a problem, i would recommend ignoring the error messages and not bothering.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 14, 2020 Jul 14, 2020

Copy link to clipboard

Copied

how much would you charge to correct the errors?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 14, 2020 Jul 14, 2020

Copy link to clipboard

Copied

Also, i cant remember if i changed the instance names or not, because each time i tried and failed to adress the errors i restarted the programme without saving it, so those changes shouldnt be there, but if you could help to fix these errors that would be great, as i worked for many months on this, would hate for the work to go to waste, thanks again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 14, 2020 Jul 14, 2020

Copy link to clipboard

Copied

before you pay anything, do you see any problem (other than the error messages)?  ie, is something not working correctly?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 17, 2020 Jul 17, 2020

Copy link to clipboard

Copied

The main problems besides the error messages are the camera layer (deleting the camera layer erased 2 of the errors, so maybe i could rework the camera layer again) also in the 1st scene on the close up shot, the pokeball that is thrown, when it opens the light animation is delayed and also out of place. The scene transitions also dont fade in and out as they should, maybe it coukd be another issue within the layer which i used for the black screen. Im still quite new to this, but everything else is pretty much fine in terms of the animation and sound and everything else, but i will have another few checks over it, do you want me to re-do the camera layers and then send it to you again with the single error message?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Jul 17, 2020 Jul 17, 2020

Copy link to clipboard

Copied

Hi mate,

 

If it plays ok on the timeline you should be able to export a PNG sequence and the audio separately and then combine those in Premiere to render a video.

 

Full details here: https://community.adobe.com/t5/animate/export-issue-stops-mid-export/td-p/10424361?page=1

 

Nick - Character Designer and Animator, Flash user since 1998
Member of the Flanimate Powertools Team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 19, 2020 Jul 19, 2020

Copy link to clipboard

Copied

great, thanks for the reply mate, apppreciate that

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 07, 2021 Mar 07, 2021

Copy link to clipboard

Copied

LATEST

jimmy jai Thank you! I have the same 'Compiler error' right now! My first time seeing it. Someone said on Youtube that we should refrain fropm using Shape Tween as it is notoriously troublesome. And I got that error message after applyng Shape Tween on an object.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines