• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Audio Connected Devices randomly not working

New Here ,
Aug 30, 2018 Aug 30, 2018

Copy link to clipboard

Copied

"The list of audio devices connected to the operating system has been changed..."

This message will randomly appear while recording, however, it will also appear when Audition is just sitting idle in the background of my laptop.

Not only will it interrupt my recording sessions, but it will also stop all audio on my laptop when this message appears. PLEASE HELP ME!

I am using audition for work and I can't have the program randomly drop out every couple of minutes.

Screen Shot 2018-08-30 at 6.38.10 PM.png

If anyone has had a similar problem or has any idea why this keeps happening please let me know,

Views

2.1K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 30, 2018 Aug 30, 2018

Copy link to clipboard

Copied

Active Socket Sensing. It's actually something the audio driver does. If it's a laptop, then the chances are that it's the Realtek driver causing this. If you can locate the control panel for it, then enabling multi-streaming will effectively disable this - but unfortunately it's also likely to stop the socket from changing from the setting it's on - so plugging in a pair of headphones, which would normally trigger a 'change of connection' won't be flagged - and the socket won't switch over and remains stuck on speakers. Yes it's really annoying. What you're looking for, to experiment with this is something like this:

Realtek HD audio manager multi-stream.JPG

It's the setting I've ringed - by default it's disabled. A lot of people think it's the operating system that causes this to happen, and whilst normally I'd be delighted to blame M$, this time it isn't actually them. Except, that is, that they've enabled an easy means to report any hardware changes to the audio driver, and this may be controllable by editing the registry. Unfortunately I'm only aware of some settings that work in the case of non-Realtek devices, or that work on older OS's like Windows 7, and not any current version.

What actually happens is that if you enable this setting, you still get the message in Audition, but a) it won't stop anything playing and b) if you dismiss it with the 'don''t show this again' box checked, playback will be normal, without interruptions. And no headphones available...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 29, 2018 Oct 29, 2018

Copy link to clipboard

Copied

I am getting this alert every time I start a session.  I have my audio routed through a PreSonus Audiobox USB  96 -- the computer (iMac) is set to that as both in and out, which it is.  I am monitoring via the headphone out, and there are two mic channel inputs.  Nothing is changing -- why does it think something is?

More of an irritant.  It does not seem to affect anything.

SteveG(AudioMasters)

audio-devices-have-changed.jpeg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 30, 2018 Oct 30, 2018

Copy link to clipboard

Copied

If this has only happened recently, have you 'upgraded' your OS to Mojave? Apparently they've freaked out about security and forced apps to make you positively connect a device to them - at least that's what it seems (I don't have a mac). You can read more about it here: https://www.idownloadblog.com/2018/08/16/howto-mac-camera-microphone-permission/

If I'm reading it correctly, it tries to do this every time you open an app - which means that if you close Audition and reopen it, this message will pop up unless you dismiss it. What's slightly confusing though is that everything appears to be working normally for you. But however you look at it, they've changed something, and it appears to be irritating a lot of users...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 30, 2018 Oct 30, 2018

Copy link to clipboard

Copied

If the audio I/O is still working OK you could always click the 'Don't show again' box.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 30, 2018 Oct 30, 2018

Copy link to clipboard

Copied

No, I haven't upgraded to Mojave.  I find it distressing to go from the High Sierra to the desert.

It's no big deal.  I followed Ry's advice and just disabled the alert.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Oct 31, 2018 Oct 31, 2018

Copy link to clipboard

Copied

Just to add my experience with that "error message":

The audio interface I use is a MOTU 8Pre on a firewire connection.  If, whilst Audition is running, I need to use my printer, which is connected via USB, turning it on results in that message appearing!

I simply ignore it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 31, 2018 Oct 31, 2018

Copy link to clipboard

Copied

The OS appears to be 'blind' when it comes to this message...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 15, 2020 Oct 15, 2020

Copy link to clipboard

Copied

Here we are three years later and I'm now having the problem,  This is an MSI brand computer. Bought it around 6 months ago.  Windows 10 Pro, i7-9700K CPU @ 3.6Ghz, 64 GB Ram.  The audio interface I'm most concerned with it a new Focusrite Scarlett 2i2 3rd Generation.  It can happen ocasionally or in rapid succession (click "no" or "yes" and it will error again before you can bring the Audition screen to focus.  

Extremely annoying when trying to edit but more so when it happens while recording a VO session.  My voice booth does not have a clear view of the computer screen and the error will often cut the audio input while leaving the transport rolling.  

It has a sound panel from "Nahimic" (I guess for gaming purposes), a MSI branded Realtec panel, NVIDIA (which I do not see a control panel for audio) and the Windows panel.  I enabled the multi-streaming ain the Windows sound panel and it's still sending the error.

Any further suggestions or experiences.  Windows driver and Focusrite driver are the latest.  Same with the others as far as I can tell.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2020 Nov 20, 2020

Copy link to clipboard

Copied

Hi Rickf779, did you ever get a resolution to this problem as I am also having the same issue? 

 

Support has been on and saw the issue but could not fix at the time. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 20, 2020 Nov 20, 2020

Copy link to clipboard

Copied

Hello Jaytat77

 

No, I did not get a good resolution but in my own tinkering around, I was able to stableize it.  Basically I went through and unplugged over half of the USB devices.  I had a multi-camera video setup, as well as scanner, printer, and many were using powered UBS hubs.  I have no idea which device may have been responsible, if any, for the device changing as it did.  I did turn off the multi-streaming first but that did not solve the issue.

 

I record voice overs and am usually in a hurry.  I'll notice when something screws up like this but I don't always notice until several days later that the system is stable.  That said, I think there was a Windows Update and an Adobe update all happening at about the same time after I did the original post.  Therefore, I can't say whether it was a USB problem, a Windows problem, or an Adobe problem.  I'm using an old iPad to mirror the screen in by voice booth area so I can tell if it goes down while recording.  That did happen once and missed recording about 15 minutes of a 20 minute script.  That's when I started yanking wires out of all the USB ports.

 

Rick

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 20, 2022 Nov 20, 2022

Copy link to clipboard

Copied

I now get this on Audition 2023, mbp M1 11.7.1 CONSTANTLY. And when I open the settings, nothing has changed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 20, 2022 Nov 20, 2022

Copy link to clipboard

Copied

One of the major problems with this is that the 'detection' happens at the hardware level, is picked up by the audio driver, and there appears to be no sensible (or otherwise) method of getting the OS to ignore it at a registry level, which would work best. I put a bit more information about it earlier in the thread.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 20, 2022 Nov 20, 2022

Copy link to clipboard

Copied

Well, firstly it's Core Audio, connected to external monitor through thunderbolt. No, the picture stays on perfectly all the time, it's just Audition "losing" something... It's set to use "system default" – this doesn't change.
Secondly, no other DAW does this – Digital Performer doesnt, Live doesn't.
Maybe CONSTANTLY was a little bit of a stretch, frequently would be more appropriate.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 20, 2022 Nov 20, 2022

Copy link to clipboard

Copied

My original comments were mainly aimed at what happens in Windows. But you might like to note what the error message actually says - which is that the list of audio devices has changed - not that your default setting has altered. I agree that there's little or no point in Audition reacting to this message if nothing you are actually using has altered, and that probably is an Audition issue. What I would like is an option in Preferences for Audition to ignore all of these messages unless an actual disconnect has happened.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 20, 2022 Nov 20, 2022

Copy link to clipboard

Copied

LATEST

There is no "error message" i.e. the prompt is exactly the same as in OP screenshot. For now I've just checked the "don't display this msg again" but this feels to me like cutting corners...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines