• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Stopping browser autocomplete in text boxes

Contributor ,
Feb 04, 2021 Feb 04, 2021

Copy link to clipboard

Copied

Has anyone found a way to stop the browser autocomplete dropdown choices from being shown on TEBs in a published project? Preferably by adding the form or input autocomplete attribute to the Captivate publish template, but even manually adding it post-publish to every project would be better than nothing. We're seeing the same issues previously reported where if a user picks an item from the autocomplete choices, the form auto submits, causing a loss of data in the record. Primary browsers are Chrome and IE. Thanks!

Views

685

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

I have not had a chance to test this but perhaps you can try this to see if it works.

Place the code as an onEnter action (Execute JavaScript) for the slide where your TEBs are.

 

$("input").attr("autocomplete","off");

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

Thanks, but it's not working.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

I just tested and one of the only ways was to set it to new-password

 

$("input").attr("autocomplete", "new-password");

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

Thanks. Still not working in Chrome here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

Are you copying and pasting?

Perhaps try deleting the quotes and re-typing them.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

Good thought, but still not working.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

Hi, having same issue. Were you able to figure out how to turn off auto-fill (I don't understand how anyone is using TEBs with this issue? Surely someone has figured out how to turn this off?). I have been told to set autocomplete="off" on the TEB, but no idea how to do (I am a Cap 19 beginner!)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

Note: I named my TEB variable TE_L506. Wouldn't think this is a field that would be auto-filled. But Adobe Cap19 TEB autocomplete issue.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

What is the name of your actual TEB field?

If the other code options above are not working, perhaps try the following adjustment where you replace only the word  entryBox with the name of your TEB.

Keep the  quotes, hash, and _inputField in place.

Again - this would need to be placed as an Execute JavaScript  onEnter action

 

$("#entryBox_inputField").attr("autocomplete","off");

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

lisakstocks_0-1618494724630.png

I guess my problem is, I do not know how to assign code to the TEB?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

How/where do I place an... Execute JavaScript  onEnter action?

(apologies as I am a beginner!)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

Here are some pics to help.

 

Stagprime_0-1618495293717.pngStagprime_1-1618495307055.png

Stagprime_2-1618495321816.png

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

THANKYOU!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

I set JavaScript on slide [On Enter] - Do I have this right?

Now, when I get to this page of training in Chrome,  Chome opens a new blank tab? 

 

Javascript on Enter.png

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

Looks like you have the right place. 

 

However, you will need to use the name of your text entry box rather than your variable name.

From what I can see, the name of your field is

Text_Entry_Box_L506

I would not expect it to open a new tab in your browser, though.

 

$("#Text_Entry_Box_L506_inputField").attr("autocomplete","off");

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

If you need to wait for the learner to perform functions on your slide - you may want to uncheck that box that says "Continue Playing the Project"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

Thankyou changed Javascript to... 

$("#Text_Entry_Box_L506_inputField").attr("autocomplete","off");

 

But when I come to this slide, still showing auto-complete box and still opening blank tab.

😞

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

If you are inclined, here is Cap file with my problem slide. 3 slides- TEB is on 2nd slide. 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

Hmmm... .cptx file(13MB within file size limit) won't post. Maybe not permitted?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

On the drop button beside the Script_Window button, make sure you have Current selected. That may take care of the blank tab opening.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

@Stagprime  just FYI by default the generic name of the TEB and its variable are the same, something which has always frustarted me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

@Lilybiri - yes, I am aware of that.

From the posted pictures, however, it looks as though some adjustments have been made to that.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

I was never able to resolve it before other larger fires erupted. It's still on my list of nagging issues.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

Hello everyone. I would love to hear if anyone has had any success with the proposed solutions above or has any new solutions. I am experiencing this very same issue myself.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines