Mouth disappearing between movements

Community Beginner ,
Apr 29, 2020 Apr 29, 2020

Copy link to clipboard

Copied

Hi there, Im working on an animation of aristotle for a school project (this is my first time using character animator) and I'm having trouble with the mouth. While I'm talking, the mouth occasionally dissapears. I've followed all suggestions from previous posts, Cycle layers is turned on for all of the mouth shapes (except neutra, surprised, etc.) all the groups have the eye icons turned on, i've adjusted the viseme detection, all the layers are tagged properly, and i'm not missing any. I'm really lost! Please help! Thank you so much in advance! RiggingRiggingRiggingRigging

TOPICS
Camera , How to , Puppet movement , Rigging , Tips and tricks

Views

1.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Apr 29, 2020 Apr 29, 2020

Why are the "Aa" and "U" mouth shapes inside the "Ah" group? Go back into your PSD, move those out of the group, and see if that solves your problem.

Likes

Translate

Translate
Community Expert ,
Apr 29, 2020 Apr 29, 2020

Copy link to clipboard

Copied

Why are the "Aa" and "U" mouth shapes inside the "Ah" group? Go back into your PSD, move those out of the group, and see if that solves your problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 30, 2020 Apr 30, 2020

Copy link to clipboard

Copied

Yes that did the trick! thank you! It's crasy how something so simple can throw the whole thing off 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 30, 2020 Apr 30, 2020

Copy link to clipboard

Copied

LATEST

Great! I'm glad everything is working again. Make sure to remove any unnecessary behaviors from those layers as too many can cause performance issues.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 29, 2020 Apr 29, 2020

Copy link to clipboard

Copied

If David's advice does not solve the problem, my suggestion of what to try next is in rigging mode find the Lip Sync behavior, then over in the Properties panel expand it. It should show all the viseme names. If you expand them one by one, it will show the layers it found and bound to. If a viseme is missing from the bindings, that might explain why the mouth disappears sometimes - that viseme goes blank. It is important that all visemes are siblings under the Mouth layer. (Don't worry about Jaw Handles - that is for nutcracker jaw movements, the alternative to visemes.)

 

For example, if a viseme bound Mouth/Ah/Aa for example (instead of Mouth/Ah) that could cause problems. Checking all the tags can help as well on layers. Normally you put child layers under a viseme if you want to use cycle layers to cycle through them for smoother animation, in which case I normally see the layers called 1, 2, 3 etc to make the purpose clearer. (Just wondering if those two child layers David mentioned were a cycle layer, but got accidentally tagged so got CH confused. If so, rename them to 1 and 2.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 30, 2020 Apr 30, 2020

Copy link to clipboard

Copied

Hi! thanks so much for your help! it turns out it was the Aa in the wrong folder that was causing the problem! its all owrking smoothly now! thanks again!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines