Video Wake Lock Prevents Monitor Display from Going into Standby

New Here ,
Aug 05, 2022 Aug 05, 2022

Copy link to clipboard

Copied

Marvin25541518cb0u_0-1659738734479.png

When active, display will not go to standby nor will PC go to sleep.  I can close down Creative Cloud Services and display and sleep work correctly.  Even though timer is set to 5 minutes for display and 20 minutes for sleep, neither will happen as long as creative cloud is active.  

This hassle has not always been there, but not sure what has changed.

 

Ideas?

TOPICS
Cloud storage web assets

Views

1.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Beginner , Aug 16, 2022 Aug 16, 2022

Here's something that is working for me, for now. You can override the Adobe wake timers in Windows 10/11 using the following command from an elevated cmd prompt:

 

powercfg /requestsoverride process "creative cloud.exe" display system

 

Doing that will override the "video wake lock" placed by Adobe Creative Cloud. In my experience, that override is sometimes temporary and sometimes gets undone with windows updates, software udpates, etc. but is easy enough to re-do if needed. Give that a try.  Hope

...

Likes

Translate

Translate
Community Beginner , Aug 17, 2022 Aug 17, 2022

I haven't used my main pc in a while but I noticed tonight it's doing the same thing. So I've set a taskscheduler task to automate the powercfg override. Here are my settings if anyone else wants to do it. I've manually ran the task a few times to confirm that it is working. (FYI - To remove a requestsoverride in cmd, just type the same command string without the variables "Display System" at the end.

 

powercfg /requestsoverride process "creative cloud.exe"

 

To view active overrides list

 

powercfg

...

Likes

Translate

Translate
Community Expert ,
Aug 06, 2022 Aug 06, 2022

Copy link to clipboard

Copied

pause file syncing.  

 

if that fails, try updating your video driver.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 06, 2022 Aug 06, 2022

Copy link to clipboard

Copied

I've been having the same issue lately

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 06, 2022 Aug 06, 2022

Copy link to clipboard

Copied

try the above.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 16, 2022 Aug 16, 2022

Copy link to clipboard

Copied

Here's something that is working for me, for now. You can override the Adobe wake timers in Windows 10/11 using the following command from an elevated cmd prompt:

 

powercfg /requestsoverride process "creative cloud.exe" display system

 

Doing that will override the "video wake lock" placed by Adobe Creative Cloud. In my experience, that override is sometimes temporary and sometimes gets undone with windows updates, software udpates, etc. but is easy enough to re-do if needed. Give that a try.  Hopefully, regardless of the claimed "majority" not having the issue but us all knowing it clearly is an issue, Adobe will eventually fix it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 16, 2022 Aug 16, 2022

Copy link to clipboard

Copied

thank you for that info.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 17, 2022 Aug 17, 2022

Copy link to clipboard

Copied

This workaround by MRMAdmin does work. 

I am going to explore with using the Windows Task Schedule to run the command every 30 minutes or so.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 17, 2022 Aug 17, 2022

Copy link to clipboard

Copied

why do have use more frequently than once after system start-up?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 17, 2022 Aug 17, 2022

Copy link to clipboard

Copied

It's a windows thing. I haven't had time to dig further to see about making it permanent but what the others are suggesting will probly work well as a temporary solution until the issue can be properly fixed by Adobe.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 17, 2022 Aug 17, 2022

Copy link to clipboard

Copied

Thanks for that, it's working well for me. I'm going to do the same as the other user and look into running a task sheduler event to run it once at every startup.

Thanks again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 17, 2022 Aug 17, 2022

Copy link to clipboard

Copied

that makes sense.  post your solution if you find one.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 17, 2022 Aug 17, 2022

Copy link to clipboard

Copied

I haven't used my main pc in a while but I noticed tonight it's doing the same thing. So I've set a taskscheduler task to automate the powercfg override. Here are my settings if anyone else wants to do it. I've manually ran the task a few times to confirm that it is working. (FYI - To remove a requestsoverride in cmd, just type the same command string without the variables "Display System" at the end.

 

powercfg /requestsoverride process "creative cloud.exe"

 

To view active overrides list

 

powercfg /requestsoverride 

 

To create the auto override, open task scheduler. Click "Create Task" on the right side. 

In general, make sure to check "run with highest privleges"

In triggers, I set mine to run once daily at 10:00am

In Actions, choose "Start a program" type"C:\Windows\System32\powercfg.exe" in the first box. In add arguments box type "requestsoverride process "creative cloud.exe" display system" note there is no / at the beginning. Leave "Start In" blank.

 

In the conditions tab I left everything as default

In the settings tab, I checked "Run task as soon as possible after scheduled start is missed"

That's it!

 

You can manually start the task by right clicking on the task in your task scheduler library and choose run. Then you can double check if it worked by going back to the command prompt and typing 

powercfg /requestsoverride to show the list of active overrides.

 

Good luck!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 18, 2022 Aug 18, 2022

Copy link to clipboard

Copied

@Nick22848596i4l5, thank you for that info!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 07, 2022 Sep 07, 2022

Copy link to clipboard

Copied

I'd love to know why Creative Cloud needs wake locks....
If it is related to syncing then the wake lock should only "lock" when syncing is occurring. A failed sync session should release locks. Additionally, the application should "catch" the sleep attempt and display to the user "the system has requested to enter sleep state and Creative Cloud is currently syncing your files to the Creative Cloud. Once finished Creative Cloud will automatically put the system to sleep."


Additionally, this same issue is keeping my computer from enabling the screen saver which locks my computer.

 

This is a security vulnerability.

Creative Cloud.exe is blocking a native Windows operating system security feature.

I rate this "bug/feature" as a Medium-High serverity security issue in any environment with sensitive data or stringent security controls.

Mitigations:

Disable Creative Cloud
Configure Creative Cloud to NOT launch at Login.

How:
Click Adobe User Account icon top righ corner of main Creative Cloud window.

Click Preferences

Click General
In the settings section turn off the option labeled
Launch Creative Cloud at Login

Summary
This will ensure the syncing component is not enabled.
Note:

If Creative Cloud is used to update Adobe applications, the user will need to EXIT the application by Opening Creative Cloud “hamburger menu” (three line menu icon) in the top left of the Creative Cloud main window

Select
File
Then
Exit Creative Cloud

Then choose QUIT. If the user selects HIDE Creative Cloud will continue to run and block screen saver and sleep functions. Do not select HIDE if you wish to resolve this issue.


Disable Adobe Cloud Syncing

Using Adobe Teams disable file syncing
Details are located on the Adobe site at the following link.
https://helpx.adobe.com/ca/enterprise/using/customize-creative-cloud-app.html#disable-file-syncing

Note: This mitigation may affect the way some users expect Adobe to operate. Review notes in End-User experience section of the disable file syncing section


Affected versions:
Windows
Creative Cloud Desktop 5.8.0.592

Above mitigations were tested on the versions detailed above. Future changes in Adobe components may make these mitigations function differently or not exist at all.

References:

Interactive logon: Machine inactivity limit

https://docs.microsoft.com/en-us/windows/security/threat-protection/security-policy-settings/interac...


Creative Cloud app & services | Customizations
https://helpx.adobe.com/ca/enterprise/using/customize-creative-cloud-app.html#disable-file-syncing

 

 


Any typos or incorrent information were not intended. I am not responsible for any loss of data, operability or other issues that may arise with Adobe software.
I am not an Adobe employee nor am I affiliated with Adobe other than using their software. I have a significant cyber security background and am confident in the data in this post. I am providing this information to improve security and functionality of Adobe products. I truly hope this issure is remediated in software.

 

 

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 08, 2022 Sep 08, 2022

Copy link to clipboard

Copied

for users looking for a solution:

 

per @tsmith35x 

Unofficial workaround for Adobe Creative Cloud video wake lock bug

1. Open Creative Cloud by double-clicking the icon in your Windows tray.

2. When the CC window opens, click these icons in sequence:

  • Fonts
  • Notifications
  • Cloud activity
  • Account

3. Close the CC window.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 08, 2022 Sep 08, 2022

Copy link to clipboard

Copied

Thanks for this additional workaround.

 

Based on this response.. the issue is with the notification component of creative cloud.exe.

 

Are there any updates from support/ development on fix/ patch for this issue?

 

Thanks 

Bedammit

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 08, 2022 Sep 08, 2022

Copy link to clipboard

Copied

you're welcome, but @tsmith35x deserves the big thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 08, 2022 Sep 08, 2022

Copy link to clipboard

Copied

Looking forward to a fix for this security bug.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 08, 2022 Sep 08, 2022

Copy link to clipboard

Copied

LATEST

there have been reports of sporadic issues for years.  most of us do not have this problem.

 

you can vote up or report the problem here, but based on the fact it's been years, i'm not sure a change on adobe's end will occur (or be timely), https://www.adobe.com/products/wishform.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines