• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Books transferred to device on ADE don't show up on my Kobo

New Here ,
Jul 26, 2020 Jul 26, 2020

Copy link to clipboard




I have a Kobo Touch, and recently I updated the Kobo software of my device. Today I tried to import some ebooks that I took from the library from Adobe Digital Editions on my pc to the ebook reader. I did the procedure as per usual, but once I disconnected the ereader I couldn't find the books imported from ADE anywhere. 


I tried to import other books that weren't from the library and they are not visible as well on the ereader. 

I tried to download the most recent version of ADE and also deauthorize and reauthorize the device, but it still doesn't work, and the books that seem to be imported on my Kobo from the software on my computer, are not actually to be found on my ereader once I disconnect it.


There are no error codes or anything (like it was happening in the past), the book is just not visible anywhere on my device... as if I never transferred it.






Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation