Adobe Digital Editions 4.5.10 not responding in Windows 10

New Here ,
Jan 09, 2019 Jan 09, 2019

Copy link to clipboard

Copied

Having issues downloading ebooks  to ADE from library.  Updated ADE to 4.5.10 on Windows 10.  Renamed My Digital Editions folder to OLD and created a new My Digital Editons folder.  Deleted previous downloads.  ADE continually fails with "not responding".

TOPICS
Kobo editions

Views

9.2K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 10, 2019 Jan 10, 2019

Copy link to clipboard

Copied

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 10, 2019 Jan 10, 2019

Copy link to clipboard

Copied

Loaded ADE 3.0.  Getting error - ERROR! CHECK ACTIVATION.

Authorize Computer - greyed out - no access

Authorization Information - This Computer Already Aurthorized

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 24, 2019 Jan 24, 2019

Copy link to clipboard

Copied

Windows:

    Close all applications.
    Press WINDOWS + R.
    In the Open text box, type regedit and then press Enter. The Registry Editor opens.
    In the left pane of the Registry Editor, locate the following registry key: HKEY_CURRENT_USER\Software\Adobe\Adept
    Remove the Adept Folder.
    In the Confirm Key Delete dialog, click OK.
    Close the Registry Editor.
    Open Adobe Digital Editions and reauthorize..

Macintosh:

    quit Adobe Digital Editions.
    Navigate to /Users/Library/Application Support/Adobe/Digital Editions and drag the activation.dat file to the trash.
    If you are using 10.7, see https://helpx.adobe.com/x-productkb/global/access-hidden-user-library-files.html
    Open Adobe Digital Editions and reauthorize.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 24, 2019 Apr 24, 2019

Copy link to clipboard

Copied

The above doesn't work either.  Installing older version does not work.  I've tried just about everything and nothing is working.  Contacted Adobe and they said they can't help and to post my issue here.  There are several other discussions related to the same issue - with no resolution.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 02, 2021 Jan 02, 2021

Copy link to clipboard

Copied

This worked for me. Thank you! Let's hope it continues to work.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 24, 2019 Apr 24, 2019

Copy link to clipboard

Copied

I think you have to deactivate your computer and then reactivate it.  It still thinks you're activated on a later edition

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 25, 2019 Apr 25, 2019

Copy link to clipboard

Copied

Hi there, did you ever got this right.

I'm struggling with it.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 25, 2019 Apr 25, 2019

Copy link to clipboard

Copied

Nope. I have to uninstall/reinstall EVERY SINGLE time I download a book.

As soon as I close it everything disappears. I don't know what to do.

On Thu, Apr 25, 2019 at 3:56 PM phindilem65021458 <forums_noreply@adobe.com>

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 14, 2019 Jan 14, 2019

Copy link to clipboard

Copied

Try creating another windows profile with admin rights and then install and authorise A.D.E

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 28, 2019 Apr 28, 2019

Copy link to clipboard

Copied

What is going on? Does anyone have an answer to this question? I have tried earlier versions with our success. Is there a solution????

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 29, 2019 Apr 29, 2019

Copy link to clipboard

Copied

I have had problems with ADE since version 2.x and this symptom is the same since then after working a while with this software on a Windows PC. The only way I got this to work was using a new profile/computer. All other things did not work. Is it the same with the iOS and Android version? Than I can spend the money on other things and not an iPad.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 29, 2019 Apr 29, 2019

Copy link to clipboard

Copied

I don't understand why they just don't bloody well FIX it! Not helpful I

know

On Mon, Apr 29, 2019 at 11:12 AM gerhardp33814215 <forums_noreply@adobe.com>

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 29, 2019 Apr 29, 2019

Copy link to clipboard

Copied

Another frustrated user here, just adding my voice to the chorus.

For me, downloads from the public library begin smoothly enough, and the completed downloads even show up in the Digital Editions library pane.

Then, everything freezes solid. Double-clicking a book won't open it, nor will right-clicking the book open a context menu of any kind. It's impossible to close the software itself without resorting to Windows Task Manager.

Digital Editions crashes on Windows 10 in ways that it didn't on previous versions of Windows. Please look into this, Adobe, because many of us rely on public libraries for our reading material. And Windows 10—for better and for worse—is here to stay.

Unfortunately, the solutions suggested above didn't work for me, so I'll be following this thread with interest.

Thanks.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Adobe Digital Editions, v4.5.10.186048  (authorized)

Windows 10 Pro x64

Version 1809 (Build 17763.168)

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 15, 2019 May 15, 2019

Copy link to clipboard

Copied

I didn't experience the same problems with Adobe Digital Editions as above, but I was having trouble opening it. I would download a new version and double click, try launching it, and nothing would work. I recently uninstalled both 4.5 and 3.0 versions. I recently installed some Windows updates 5/15/19, I'm not sure if they are related or not. I re-downloaded Adobe Digital Editions 3.0 and was able to transfer an ebook from my local public library onto my Nook. I've also had previous problems activating it similar to @stephaniel44346648 above. I was able to activate the Adobe Digital Editions properly through the 3.0 version and transfer books/get it working. Hope this helps.

Thanks

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 28, 2019 Jun 28, 2019

Copy link to clipboard

Copied

June 2019: I haven't been able to download or open library books for some days now.  Starting ADE just immediately exits with no error message or any screen display.  Tried all the suggestions above. Uninstalled/reinstalled 4.5.10, renamed My Digital Editions and allowed it to create a new one. Last attempt was to remove Adept registry key.  No luck on anything.  Will try installing on a different computer next, in desperation.  Don't really want to, I like this computer.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 30, 2019 Jun 30, 2019

Copy link to clipboard

Copied

Hello,  did you find out solution yet?  I have the same issue, can't fix so far.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2020 Dec 15, 2020

Copy link to clipboard

Copied

Unfortunately, one day when loading a bunch of equipment, I carelessly left my portable on the roof of my car and drove off without noticing.  I discovered my mistake when it took off like a flying wing when I got up to about 50 on the expressway... so Adobe problem solved, the machine was smashed and I had to get a new one 😕 (or possibly 🙂 )

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 28, 2019 Jun 28, 2019

Copy link to clipboard

Copied

Guys!

I just did a procedure here that worked!

I've installed the ADE 4.5.10 on my Windows 10 laptop a long time, and the ADE was always starting a blank screen (stucked); the computer was authorized a long time too. Also, when I tried to access the "Leitura (PT-BR)" menu (would be "Reading" in a EN version), next to the Help menu, the ADE just shut down.

FIrst, I removed the program ADE 4.5.10 from Windows, and installed the ADE 3.0, available on the website, but I got the same error as stephaniel (Jan 10th 19), when trying to open an acsm file; the "check activation" error.

Then, I installed the ADE 4.5.10 back to Windows, removed the authorization (of my laptop) and authorize the computer again (both on ADE 4.5.10). It didn't work.

Last, I removed the authorization for my laptop (on ADE 4.5.10), and restarted the ADE 3.0, that started without the authorization, and authorized my laptop on ADE 3.0. Finally I could open my acsm files withou any problem.

Resume:

1-) Remove the computer authorization on ADE 4.5.10

2-) Install ADE 3.0

3-) Authorize you computer (with your Adobe ID) on ADE 3.0.

4-) Open you e-book (I was using an acsm file).

Hope it works for you too!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 30, 2019 Jun 30, 2019

Copy link to clipboard

Copied

Hello,

I have the same issue only with android tablet acer iconia:  suddenly ade 4.5.10 stopped adding my own downloads (ebooks, epub format),  When connect android to pc, can see downloads in the library.  But they disappear when open library on android.

Any ideas how to fix that?

Thank you in advance.

Inna

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 11, 2019 Jul 11, 2019

Copy link to clipboard

Copied

Guys, I checked a forum on windows10forums.com, and some blessed guy recommended to reinstall the ADE in another folder (directory). I just did it, and it worked out!!! I can't believe it!! I won't shutdown my laptop anymore!! Try it out!!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 28, 2020 Jan 28, 2020

Copy link to clipboard

Copied

Works! Tks a lot.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 06, 2019 Aug 06, 2019

Copy link to clipboard

Copied

Hi.

I had the same problem that ADE 4.5 suddenly did not work. Clicked and clicked, just nothing happened.

I tried reinstall older version using my old downloaded file, and it did work, but the display was horrible, looked like picture rather than texts.

Just now, I reinstalled ADE 4.5 on drive D, instead of the default drive C, and I keep the My Digital Edition library still on drive C.

Now everything is back as before.

You may want to try and see if that solves your problem.

Have a great day.

Raymond SEOW

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 08, 2019 Aug 08, 2019

Copy link to clipboard

Copied

Just did that and it is indeed working fine. I have been trying to get ADE working for months. Thanks Ray!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 09, 2020 Jan 09, 2020

Copy link to clipboard

Copied

It works for me, less than a minute. All by just renaming the existing folder to OLD and then create a new folder with the existing name. Thank you!!!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines