Highlighted

Issues Installing from Creative Cloud on Windows 10

New Here ,
Jul 20, 2017

Copy link to clipboard

Copied

Having issues with installs of applications from Creative Cloud on Windows 10 prompting for Admin rights

The relevant section of the logs appears to be:

07/21/17 15:53:35:154 | [INFO] | 9572 | ADCS | ElevationManager | AAMElevatedProcessLauncher |  | ElevationManager | 9888 | Inside launchAIviaAUS

07/21/17 15:53:35:155 | [INFO] | 9572 | ADCS | ElevationManager | ElevationManager |  | ElevationManager | 9888 | Inside sendMessageToService xmlData = <action><actionType>createProcess</actionType><actionArgs><cmdArgs><cmdArg>--pipename={239A17C8-BA88-4B7A-B475-BD037FFC4C31}</cmdArg></cmdArgs><processName>AdobeInstaller</processName><sessionID>1</sessionID></actionArgs></action>

07/21/17 15:53:35:158 | [ERROR] | 224 | ACCC | HEX | HEX |  | HEX | 10296 | Inside processMessageObjectForJSON: stringValueForXQuery failed for //guid or guid is empty.

07/21/17 15:53:35:234 | [ERROR] | 2016 | AAMHelper_logs |  |  |  |  | 6260 | AAM Helper: Doesn't have admin priviliges!

07/21/17 15:53:35:720 | [ERROR] | 2016 | AAMHelper_logs |  |  |  |  | 6260 | AAM Helper: couldnt get handle of sender process

07/21/17 15:53:35:744 | [WARN] | 9572 | ADCS | OOBEUtils | CommBridge |  | OOBEUtils | 7984 | Aborting read on pipe 00000F00 , errno: 109

07/21/17 15:53:35:744 | [ERROR] | 9572 | ADCS | ElevationManager | AAMElevatedProcessLauncher |  | ElevationManager | 9888 | Validation of AUTH_RESP pkt failed!

07/21/17 15:53:35:744 | [WARN] | 9572 | ADCS | OOBEUtils | CommBridge |  | OOBEUtils | 7984 | Aborting read on pipe 00000F00 , CBRawReadTry failed for packet info.

07/21/17 15:53:35:744 | [ERROR] | 2016 | AAMHelper_logs |  |  |  |  | 6260 | AAM Helper: handShakeWithClient failed!

07/21/17 15:53:35:744 | [ERROR] | 9572 | ADCS | ElevationManager | AAMElevatedProcessLauncher |  | ElevationManager | 9888 | Inside launchAIviaAUS : Handshake with AAMHelper failed retCode= 2

07/21/17 15:53:35:745 | [WARN] | 9572 | ADCS | ElevationManager | ElevationManager |  | ElevationManager | 9888 | Inside launchCreativeCloudHelper: Failed in Launching Adobe Installer via the Adobe Update Service, Going to fallback code, will ask for elevation prompt!

Install from within the Creative Cloud application works fine on Windows 7 without prompting for admin rights.

HiHaydenRead ,

I am not entirely sure what might be causing this, but i suspect it might be group policy on Windows 10 machines.

One thing is certain that the issue is not with the package, as it is installing fine on Windows 7.

~Rohit

Views

440

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Issues Installing from Creative Cloud on Windows 10

New Here ,
Jul 20, 2017

Copy link to clipboard

Copied

Having issues with installs of applications from Creative Cloud on Windows 10 prompting for Admin rights

The relevant section of the logs appears to be:

07/21/17 15:53:35:154 | [INFO] | 9572 | ADCS | ElevationManager | AAMElevatedProcessLauncher |  | ElevationManager | 9888 | Inside launchAIviaAUS

07/21/17 15:53:35:155 | [INFO] | 9572 | ADCS | ElevationManager | ElevationManager |  | ElevationManager | 9888 | Inside sendMessageToService xmlData = <action><actionType>createProcess</actionType><actionArgs><cmdArgs><cmdArg>--pipename={239A17C8-BA88-4B7A-B475-BD037FFC4C31}</cmdArg></cmdArgs><processName>AdobeInstaller</processName><sessionID>1</sessionID></actionArgs></action>

07/21/17 15:53:35:158 | [ERROR] | 224 | ACCC | HEX | HEX |  | HEX | 10296 | Inside processMessageObjectForJSON: stringValueForXQuery failed for //guid or guid is empty.

07/21/17 15:53:35:234 | [ERROR] | 2016 | AAMHelper_logs |  |  |  |  | 6260 | AAM Helper: Doesn't have admin priviliges!

07/21/17 15:53:35:720 | [ERROR] | 2016 | AAMHelper_logs |  |  |  |  | 6260 | AAM Helper: couldnt get handle of sender process

07/21/17 15:53:35:744 | [WARN] | 9572 | ADCS | OOBEUtils | CommBridge |  | OOBEUtils | 7984 | Aborting read on pipe 00000F00 , errno: 109

07/21/17 15:53:35:744 | [ERROR] | 9572 | ADCS | ElevationManager | AAMElevatedProcessLauncher |  | ElevationManager | 9888 | Validation of AUTH_RESP pkt failed!

07/21/17 15:53:35:744 | [WARN] | 9572 | ADCS | OOBEUtils | CommBridge |  | OOBEUtils | 7984 | Aborting read on pipe 00000F00 , CBRawReadTry failed for packet info.

07/21/17 15:53:35:744 | [ERROR] | 2016 | AAMHelper_logs |  |  |  |  | 6260 | AAM Helper: handShakeWithClient failed!

07/21/17 15:53:35:744 | [ERROR] | 9572 | ADCS | ElevationManager | AAMElevatedProcessLauncher |  | ElevationManager | 9888 | Inside launchAIviaAUS : Handshake with AAMHelper failed retCode= 2

07/21/17 15:53:35:745 | [WARN] | 9572 | ADCS | ElevationManager | ElevationManager |  | ElevationManager | 9888 | Inside launchCreativeCloudHelper: Failed in Launching Adobe Installer via the Adobe Update Service, Going to fallback code, will ask for elevation prompt!

Install from within the Creative Cloud application works fine on Windows 7 without prompting for admin rights.

HiHaydenRead ,

I am not entirely sure what might be causing this, but i suspect it might be group policy on Windows 10 machines.

One thing is certain that the issue is not with the package, as it is installing fine on Windows 7.

~Rohit

Views

441

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Jul 21, 2017

Copy link to clipboard

Copied

HiHaydenRead ,

The best  possible solution wold be to create a Creative Cloud Desktop Application package with Elevated Rights and then deploy it.

Once done then you can update/install the applications from within Creative Cloud desktop application.

If howsoever you try to update or install Creative cloud desktop application itself you need admin rights for that.

~Rohit

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 23, 2017

Copy link to clipboard

Copied

The package has been created with Elevated Rights, and works correctly on Windows 7 to elevate the rights for install, but fails on Windows 10 to Elevate the rights...

Also, on Windows 10, once the admin rights have been entered once, all subsequent installs work successfully without further Admin rights prompts, until the computer is restarted.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Jul 28, 2017

Copy link to clipboard

Copied

HiHaydenRead ,

I am not entirely sure what might be causing this, but i suspect it might be group policy on Windows 10 machines.

One thing is certain that the issue is not with the package, as it is installing fine on Windows 7.

~Rohit

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...