Cross Ref not working correctly

Explorer ,
Jan 15, 2021 Jan 15, 2021

Copy link to clipboard

Copied

I created a cross-ref from one document to a figure in another. When clicking the link in the origin doc, it goes to the figure title for about half a second and then jumps to the section title just before the figure.  I have successfully linked to other figures in the same destination doc, but not this one figure.  I have removed the markers, remove the image, removed the paragraph tag and reimplemented it.  I have tried just about everything but clicking the origin link still goes to the figure and then immediately jumps to the topic heading immediately before the figure.

Views

183

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 15, 2021 Jan 15, 2021

Copy link to clipboard

Copied

You don't say what version of FrameMaker you are using, but try this:

Right-click on the image and choose Runaround Properties. Set it to Don't Runaround and click Set.

See that fixes the problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

Didn't fix the problem.  It's working, but not in test mode.  When published it works fine.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 17, 2021 Jan 17, 2021

Copy link to clipboard

Copied

Hi Kenneth,

 

And what happens, when you have another paragraph format before your figure?

Can you delete this paragraph and test the cross-reference?

 

Is there a difference, when you use other zoom levels?

 

Can you do a MIF wash? Save as MIF, then open the MIF and save as FM again. This consolidates the file, if there are any issues.

 

Best regards

 

Winfried

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

Tried this already.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 19, 2021 Jan 19, 2021

Copy link to clipboard

Copied

Are you cross-referencing the paragraph containing the figure, or a marker that's close to the figure?

In Working with Content, I often place an xref marker near a figure if there's no figure title to go with the image.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

I have figure titles and makers.  As I said, it works, just cannot do the hyperjump within the document.  Works fine otherwise, When published, it works fine.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

At this point Matt, not sure I could even find the link again.  It is working, just not during live test in Frame. When I click the lock icon to test it, it does the jump to the previous topic heading, like I said.  It works after conversion to PDF.  If I find it again, and I will, because I will be checking all links before I publish to the web.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 25, 2021 Jan 25, 2021

Copy link to clipboard

Copied

Although I didn't intentionally find the real issue, the link does work.  When I closed the destination file, the link works just fine.  When the source and destination files were both open, it would not work, while others work just fine.  Winfried, tried everything you mentioned, except the MIF file wash.  As far as Runaround property, I will take a look at that today.  Matt, I am cross-referenceing the figure marker and title.  In all cases, I created the links the same way.

 

I have tried removing prior paragraph, removing the figure and relinking, etc., but to no avail.  As I said, the link is working from the source file, but not when both source and destination are open.  Very strange, since there has been no change in linking method, image import, marker linking to, etc.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 25, 2021 Jan 25, 2021

Copy link to clipboard

Copied

Have you tried copying a working xref and using it to replace the non-workig one, and then using Replace to update the location? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

Yes, tried this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

Let's start from the beginning - what point version of FM are you running? Structured or Unstructured? How are you making the cross-references - xrefs or hyperlinks?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

Ken, does Ctrl+Alt+Click work to activate the hyperlink in Fm?

 

-Matt

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

LATEST

Running 2020 Version 16.0.1  I am using unstructured Frame. XREFS

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines