Page Numbering

New Here ,
Sep 10, 2021 Sep 10, 2021

Copy link to clipboard

Copied

I am working on a book with 14 chapters and 4 chapters before the first one (title page, intro, TOC and preface). I am using FrameMaker 2020 e 2019 32-Bit. FrameMaker 2019 32-Bit is for using IXgen Power Indexing & Marker Management Tool for FrameMaker.

I am trying to number chapters before the first one (title page, intro, TOC and preface) with the roman (xiv) format. Then I procede as follows (the steps that follows is from the book "FrameMaker Working with Contents" by Matt R. Sullivan):

1. Select all of the files in the book window;

2. Select Format>Document>Numbering to display the numbering properperties;

3. Click the Page tab to display the page numbering properties;

4. Click the Continue Numbering from Previous Page in Book radio button and click button;

5. Now, set numbering exceptions. Select intro file and display the Page tab in the Numbering dialog box again. In the First Page # field, type 1. In the Format drop-down list, click roman (xiv). Click the Set button;

6. Select the first chapter file. Display the Page tab. In the First Page # field, type 1. In the Format drop-down list, click Numeric (14). Click Set button.

7. Update the book.

After doing these procedures, FrameMaker 2020 and 2019 number the pages of the chapters before the first one with the format Roman (XIV) instead of roman (xiv).

What can I do for FrameMaker number these pages correctly? What am I doing wrong?

Any help will be appeciated!

Views

456

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Community Professional , Sep 20, 2021 Sep 20, 2021

OK, here goes: You have a Number character format applied to your Current Page # variable definition.

frameexpert_0-1632186489486.png

It is making the page number bold, but it is also setting it to Uppercase:

frameexpert_1-1632186601474.png

 

Likes

Translate

Translate
Adobe Community Professional , Sep 20, 2021 Sep 20, 2021

To fix it, go to any body page and click in the margin so no text is selected.

Choose View > Panels > Character Designer.

Select Number from the Styles drop-down menu.

Uncheck Uppercase (click the checkbox twice).

Click the Update Style button.

If you are prompted about Overrides, you can Retain them.

 

frameexpert_0-1632186882922.png

 

Likes

Translate

Translate
Adobe Community Professional ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

You have to set the numbering format for every single file, not just the first one. Continue numbering only affects the page number, not the format used.

 

My usual practice is to go to the first file and set the page # to 1 and the page formatting, then I select the files following the first file that use the same numbering format and set them to continue and the correct page formatting. Repeat each time your numbering format changes.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

Hello!

Thanks for your e-mail and your help!

There is nothing wrong with the page numbering itself. The problem is the
roman numbers in the chapters before the first one. It should be in
lowercase roman, but when I update the book the roman numbers are set to
uppercase roman.

Can you understand what I mean?

Regards
Iracildo

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

Hi Iracildo,

 

I just tested this with a single file.

When I select roman, the page numbers are lower case roman numbers.

When I select Roman, the page numbers are upper case.

Does this work for you?

When I make a copy of one of my books and test this, it's the same. The roman page numbers are still lower case.

Was the book file selected, when you changed the numbering of some files in the book? The settings in the book will overwrite the settings in the files, when you update the book.

 

Is FrameMaker up-to-date? What's the version number in Help | About? For FM 2020 it should be 16.0.2.916.

 

Best regards

 

Winfried

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

Hi, Winfried!

I did what you suggested. I tested with a single file in which pages are
numbered ROMAN upper case. I select roman lower case and nothing happens.
The page numbers remain the same.

FrameMaker 2020 version is 16.0.2.916.

The book files were converted from FrameMaker 9. Do you think it has
anything related to this problem?

Best regards
Iracildo

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

Sometimes odd things like this can be cleared up by doing a MIF Wash. I believe that in FM2020 they added Book Utilities to the menu bar when your focus is on the book file, which makes MIF washing really easy. If they didn't add it by default, you can add it by:

 

  1. Closing FrameMaker
  2. Copying the BookComponentMIFWash.dll from C:\Program Files\Adobe\Adobe FrameMaker 2020\Samples\ScriptsAndUtilities\BookMIFWash to C:\Program Files\Adobe\Adobe FrameMaker 2020\fminit
  3. Opening the maker.ini file in C:\Program Files\Adobe\Adobe FrameMaker 2020 and adding the following to the [APIClients] section:
  4. MIFwash=Standard, MIF Wash, fminit\BookComponentMIFWash.dll, all
  5. Restarting FrameMaker and reopening your book

 

Once you have that in the menu bar, click on the name of the bookfile in your book management window, then click Book Utilities Book > MIF Wash. It goes faster if you have all the files in the book open already, but it isn't necessary.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

Hello,

I run MIF Wash tool on the book file. Then I set up page numbering again.
Nothing changed!

Regards
Iracildo

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

How are you numbering the pages? Are you using a variable or are you using autonumbering in a paragraph tag? I ask because it's possible to use roman numerals, upper and lower case, in autonumbering and if that's what you did, it would override the numbering properties for the book or file because those affect the variables.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

Hello!

I am using a variable, #.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

Well, nuts. So much for that bright idea.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

I did not understand what you mean!

Is there anything wrong with variable #?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

Nothing at all. But since you're using it, my idea doesn't help you at all.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

I know what you mean!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 16, 2021 Sep 16, 2021

Copy link to clipboard

Copied

As far as I can tell, you're doing it right, so I don't know why it's coming out wrong.

 

Have you tried the divide & conquer method? Copy the files to a different directory, then either remove all but, say, the first Roman numeral file and a regular number file, regenerate, and see what happens. Repeat with the remaining files you want to number with Roman numerals until you've identified which file or files is causing the issue. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

Are you able to have a quick web meeting? If I can see the document, I can tell you what is wrong right away. Please contact me offlist: rick at frameexpert dot com.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

Is the paragraph where your page numbers are set to display in uppercase?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

No!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

Hi Iracildo, 

Have you tried creating a new book and adding your existing chapters?

If that doesn't work, can you reproduce the problem with new (short) test files?

If your problem still remains with simple test files, we can get Adobe techs to take a look at it.

-Matt

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 18, 2021 Sep 18, 2021

Copy link to clipboard

Copied

Hi, Matt!

Thanks for helping!

I already created several books trying to solve this problem without success!

I am thinking of your suggestion of testing with small files. I did not get the idea!

Regards

Iracildo

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 20, 2021 Sep 20, 2021

Copy link to clipboard

Copied

I am pretty sure if I see your files via a short web meeting, we can solve it quickly. There would be no cost for this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 20, 2021 Sep 20, 2021

Copy link to clipboard

Copied

Hi, frameexpert!

What can I do for the web meeting?

Regards

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 20, 2021 Sep 20, 2021

Copy link to clipboard

Copied

I am on Eastern Time in the US. Contact me offlist when you are available and I will send you a meeting link. rick at frameexpert dot com

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 20, 2021 Sep 20, 2021

Copy link to clipboard

Copied

I recommend you create 3 new FrameMaker files using File>New>Blank>Portrait.

In each, place a title and a paragraph.

Create a new book, and add your 3 new Fm files to the book.

You should be able to set the numbering to your liking.

 

If this test works for you, then there's an issue with your existing files.

I recommend you take Rick up on his generous offer to look at your files online to set them correctly!

 

-Matt

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 20, 2021 Sep 20, 2021

Copy link to clipboard

Copied

OK, here goes: You have a Number character format applied to your Current Page # variable definition.

frameexpert_0-1632186489486.png

It is making the page number bold, but it is also setting it to Uppercase:

frameexpert_1-1632186601474.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 20, 2021 Sep 20, 2021

Copy link to clipboard

Copied

To fix it, go to any body page and click in the margin so no text is selected.

Choose View > Panels > Character Designer.

Select Number from the Styles drop-down menu.

Uncheck Uppercase (click the checkbox twice).

Click the Update Style button.

If you are prompted about Overrides, you can Retain them.

 

frameexpert_0-1632186882922.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines