• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit Search
1

Illustrator 100% CPU

Community Beginner ,
Mar 10, 2023 Mar 10, 2023

Copy link to clipboard

Copied

Hi everyone, I have a 2014 iMac and after the last illustrator update is very slow and fan keeps switching on. On the activity monitor something called Adobe Illustrator Web Content takes 100% CPU! I installed and reinstalled the app, removed and reset preferences, nothing works. Does anyone know what Illustrator Web Content is and why it takes 100% of CPU? Can it be disabled or deleted?

Thanks!

TOPICS
How to

Views

1.3K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Mar 10, 2023 Mar 10, 2023

Hi @Phil Vas your issue could be your GPU is outdated so the application could be relying completely on CPU to render graphics.

On the "high-end" 2014 iMacs came with a Radeon R9 M295X GPU which clocks in at 750 ops/sec.

Current recommended minimums are 2,000 ops/sec.

You can try resolving the CPU usage with the suggestions on this page:

https://helpx.adobe.com/x-productkb/global/high_cpu_usage_cephtmlengine.html

But there comes a point with a 9 year old machine that you have to make a hard choi

...

Votes

Translate

Translate
New Here ,
Mar 10, 2023 Mar 10, 2023

Copy link to clipboard

Copied

I'm having a similar issue with a 2016 MacBook Pro. It's not slow, but the fan is running constantly and I'm also seeing "Adobe Illustrator Web Content" in my activity monitor. Would love to find a solution...

Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 11, 2023 Mar 11, 2023

Copy link to clipboard

Copied

Solved the problem by uninstalling the latest version and installing  previous version. Now it works fine!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 10, 2023 Mar 10, 2023

Copy link to clipboard

Copied

Hi @Phil Vas your issue could be your GPU is outdated so the application could be relying completely on CPU to render graphics.

On the "high-end" 2014 iMacs came with a Radeon R9 M295X GPU which clocks in at 750 ops/sec.

Current recommended minimums are 2,000 ops/sec.

You can try resolving the CPU usage with the suggestions on this page:

https://helpx.adobe.com/x-productkb/global/high_cpu_usage_cephtmlengine.html

But there comes a point with a 9 year old machine that you have to make a hard choice - stay on the last stable/compatible version of the software and not upgrade or purchase newer equipment that is able to effectively run current software.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 11, 2023 Mar 11, 2023

Copy link to clipboard

Copied

Yes thats right! Solved the problem by uninstalling the latest version and installing a previous version. Now it works fine!

 

Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2023 Mar 16, 2023

Copy link to clipboard

Copied

I think there's something else going on here. I have the same issue on a 2019 Macbook Pro with a Radeon Pro 5500M.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 16, 2023 Mar 16, 2023

Copy link to clipboard

Copied

Hi @brananan what OS version are you running? Monterey or older or Ventura?

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2023 Mar 16, 2023

Copy link to clipboard

Copied

Catalina

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 16, 2023 Mar 16, 2023

Copy link to clipboard

Copied

What do you have set under Apple System Preferences/Energy Saver/Battery Health?

https://www.macrumors.com/how-to/disable-macos-catalina-battery-health-management/

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 17, 2023 Mar 17, 2023

Copy link to clipboard

Copied

I have that checked. Are you saying it should be unchecked?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 17, 2023 Mar 17, 2023

Copy link to clipboard

Copied

I would disable it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 17, 2023 Mar 17, 2023

Copy link to clipboard

Copied

Alright, I'll consider it if the problem persists. For now I just switched to the previous version of Illustrator and that is working fine, so I think it might be a bug that may get resolved in the future. I don't want to disable the battery health feature if I can avoid it, since I am in the exact scenario it is intended for (leaving my laptop plugged in most of the time)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 17, 2023 Mar 17, 2023

Copy link to clipboard

Copied

You can also check (in Catalina) your Energy Saver/Battery settings to disable Automatic Graphics Switching.

 

kevinstohlmeyer_0-1679061445029.png

https://support.apple.com/en-us/HT202043

 

I dont think this is a bug - as software needs increase there comes a tipping point where Illustrator  is using more GPU resources due to the updated 3D capabilities and general improvements and older machines (not saying your 2019 MBP is old) will become burdened.

 

Eventually there comes a fork in the road - stay on your current setup on a stable version that runs without user modifications, or update your OS or eventually your hardware to a more compatible ecosystem that can run newer releases without issue. Again, not saying you are at this point but with Catalina coming up on 4 years old and three newer OS releases - there will come a point where that OS no longer meets requirements for Creative Cloud.

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 17, 2023 Mar 17, 2023

Copy link to clipboard

Copied

Sorry, but I disagree. The version I was struggling with, 27.3.1, had the"Adobe Illustrator Web Content" using 100% of my CPU even with no files open. Now that I've reverted to version 27.2, that % is down to zero, even while I work on a large file. I find it hard to believe that whatever changed is normal behavior.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 17, 2023 Mar 17, 2023

Copy link to clipboard

Copied

LATEST

The reason why I said "I dont think its a bug" is this isnt being reported wide spread by users.

 

I am on Illustrator 2023 27.3.1 on Mac OS Ventura and even with a seriously complex Adobe Stock image I am not seeing spikes in Adobe Illustrator Web Content:

kevinstohlmeyer_0-1679065210264.png

I also tested on my MBP 2019 last night at home and did not see the same issues you are - but I am on Monterey on that system not Catalina.

 

So when attempting to narrow down the issue, the question comes up - what is different between user X and Y? Version 27.3 specifically had a lot of changes to 3D rendering/lighting and other features.

Catalina and Big Sur were also notorious for having memory leaks - the solution for that was to upgrade to Monterey.

In the past the culprit has been the CEPHTML engine which is connected to plugins and other web-related content (library syncing, etc).

https://helpx.adobe.com/illustrator/using/whats-new/2023-2.html

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines