• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

Illustrator 25.1 GPU Preview greyed out

Contributor ,
Feb 03, 2021 Feb 03, 2021

Copy link to clipboard

Copied

BUG!

Going to any other preview (outline/pixel) force CPU preview

when coming back to regular preview it stays at CPU preview and can't go back to GPU

I am working with 4K monitor and it's impossible to work with CPU preview.

you don't need to close the program, just the file, and open it again

 

Went back to the previous version works fine

 

General note

It's about time adobe will start to understand that people moving to 4K

Adobe UI is terrible on 4K in performance and size

we need better performance and much more flexibility to set the interface

text size / roller size / tools icons / individual sizing for windows items

(e.g bigger layer panel to be able to read names with small color swatch which can be easily seen)

more UI options will let the user enjoy a bigger screen in a smarter way

 

 

 

TOPICS
Bug , Performance

Views

4.1K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Feb 08, 2021 Feb 08, 2021

Hi there,

 

Sorry to hear about your experience. This issue has been reported by many users & product team is working to fix this issue. I'd request you to upvote  this Illustrator UserVoice post(https://illustrator.uservoice.com/forums/601447-illustrator-desktop-bugs/suggestions/42443869-view-using-gpu-gets-greyed-out-permanently-with-ou) & add your comment to stay updated about the fix.

We appreciate your patience.

 

Regards,

Ashutosh

Votes

Translate

Translate
Adobe
Adobe Employee ,
Jan 28, 2021 Jan 28, 2021

Copy link to clipboard

Copied

Hi All,

 

We're sorry for the inconvenience. This issue is being reviewed by the product team. You may upvote & add your comment on this Adobe Illustrator UserVoice post(https://illustrator.uservoice.com/forums/601447-illustrator-desktop-bugs/suggestions/42443869-view-u...) and stay tuned for the updates.

We appreciate your patience.

 

Regards,

Ashutosh

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 04, 2021 Feb 04, 2021

Copy link to clipboard

Copied

Hello there,

 

I have a constant struggle with Illustrator for the last year or so. Every time I work in a document, no matter the size, the elements I have in it, colour space and so on it keeps switching from GPU to CPU preview. After that automatic switch, the performance drops significantly, and it's almost impossible to work in it. 

 

I've uninstalled Illustrator, removed all presets, uninstalled the complete Creative Cloud and can't seem to find a solution on why it's happening. Every other software (Blender, performance-heavy games, etc.) is running perfectly smooth. It's just Illustrator and sometimes Photoshop that's giving me a headache.

 

I did find a quick hack to solve my problem. If the GPU preview gets deactivated, I have to go to Window -> New Window to create a new window for my current document. After that, I can work for sometimes a couple of minutes, sometimes just for one action before it gets deactivated again and I need to restart that game Illu wants to play with me.

 

It got to that point that I am seriously considering cancelling my CC subscription and get any other vector software because it's that damn annoying. Hopefully, someone had the same problem, or you guys can help me.

 

My workstation:

Ryzen 7 1700X

ASUS CROSSHAIR VI HERO (Bios Version 7704)

32GB DDR4-3200

Gainward GeForce GTX 1080 GLH

Illustrator 25.1

Windows 10 Pro - 64 bit

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

And what kind of documents are you working on? Do you use color management? Is the graphics driver up to date? There's more to this...

 

Mylenium

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

Drivers are all up to date, from mainboard component drivers to graphic card, etc.

 

Documents I work on vary, from illustrations for tees, flyers to logos or typographic artworks. But like I said it can be an empty document and I just write in Arial a single character and it switches back to CPU Preview. I've also deleted every manually installed font and removed all adobe fonts. This is a solitary problem in Illustrator and Photoshop, InDesign, After Effects or Premiere Pro for example run fine.

 

It happens both in RGB and CMYK Color Mode. Working spaces have been altered between Monitor sRGB, Adobe RGB, SWOP v2, ISO coated v2 300%, Euroscale Coated and uncoated. It doesn't matter, it keeps deactivating GPU Preview.

 

I've also tried multiple ram tests, checked my hard drives for errors, hooked up another monitor (running 2x Dell U2515H). The only thing I haven't swapped yet is my CPU, but as I mentioned I can run hardware hungry games on this machine without any problem. I recently played Cyberpunk and had some minor bugs at a 2560x1440 resolution with ultra settings in-game. So I doubt that it is a performance issue, there must be something that is messing with these two programs.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 23, 2021 Feb 23, 2021

Copy link to clipboard

Copied

Hi Von,

 

Sorry to hear about your experience. Please update Adobe Illustrator to the latest version(25.2) & let us know if you still have such concerns. You may follow this help article to know how to update the app.

Looking forward to your response.

 

Regards,

Ashutosh

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 23, 2021 Feb 23, 2021

Copy link to clipboard

Copied

Well, it seems that for now, it solved my problem. I played around with some older files and Illustrator didn't switch to a CPU Render Preview, yet. I'll keep you posted when I work with it a bit longer, but it seems that your latest update did the trick.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

Same issue. Simple file with fonts and one zigzag effect and GPU gone... this is a shame

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 24, 2022 Mar 24, 2022

Copy link to clipboard

Copied

Hello,
Is there an update on this awful bug?
I have exactly the same issue with my Illustrator for 1 year. And it is almost unusable.
When I create a very simple document with just a line everything is fine (GPU preview). When I switch to outline mode (ctrl+Y) everything becomes super laggy because it switched on CPU preview mode. 

All my drivers are up to date. I use the 26.1 illustrator version.
I work on a powerful station:

  • proc: intel 11th i9 11900F
  • Ram 64 go
  • SSD 4to
  • GPU : geforce RTX 2070 super 8GB
  • 4K screen dell ultrafine

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 24, 2022 Mar 24, 2022

Copy link to clipboard

Copied

It was fixed in the previous version, but re-emerged with the most recent. Your options are: wait for the next release, or roll back to 26.0.3 and see if that helps.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 06, 2022 Dec 06, 2022

Copy link to clipboard

Copied

LATEST

Just upgraded my system and this problem just started happening. My old computer specs are terrible compared to my upgrade. I did a screen share with an adobe customer service rep, but he couldn't seem to comprehend the difference of GPU and CPU preview. Hopefully this is fixed soon.

 

Old PC:

i5-8600k

Asus or MSI Radeon RX580

8GB DDR4 Ram

 

New PC:

i7-12600KF

Gigabyte RTX 3070 Ti

32GB DDR5 Ram

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines