Illustrator No Longer Correctly Imports .dwgs with Visibility States.

New Here ,
Jun 15, 2022 Jun 15, 2022

Copy link to clipboard

Copied

Hi there, 

 

I work with a lot of Autocad files and have always used Illustrator CC to open them and export them as a .wmf file for use in an in-hoise piece of software.

The cad blocks in the drawings are "Dynamic" and use visiblity states to hide and unhide certain views of my objects in different areas of the drawing i.e. top view/side view/ front view etc.

Until a recent re-install of Illustrator (v26.3.1) the .dwg would appear fine, and as-seen in AutoCAD, however, the newest version of Illustrator appears to completely ignore the fact there are visibility states and shows all views all at once over the top of itself.

For the life of me I can't seem to find a way around this so was helping you cleaver people might have a fix.

 

Things I have tried:

1: Saving as pdf and using that instead:  This creates a huge 8mg file rather than 200kb so thats no good.

2: Copying and pasting from the autocad screen to an new Illustrator file: This works but I have many hundreds of drawings I need to convert at once using a batch command so this is not an option I can use.

3. Saving the files in all previous autocad versions of dwg i.e. 2010/2004/2000 etc.: This make no difference.

4. saving as dxf: no difference

 

Any ideas?

 

This is the view in Autocad:

Michael248777270phx_0-1655301412616.png

 

However it opens in Illustrator like this:

 

Michael248777270phx_1-1655301514783.png

 

Any idea?

 

Michael

 

 

 

TOPICS
Import and export

Views

10

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation