Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Layer not appearing in PDF even with Print selected in Layer options

New Here ,
Jun 19, 2021 Jun 19, 2021

Copy link to clipboard

Copied

I've got two open files in Illustrator. I've been working in them both for hours. I've saved them both as PDFs and everything was fine. I then added new layers to both and saved them both and everything was still fine. 

 

Then I realized that I wanted one of the layers to not be visible in the PDF, so I clicked the eyeball to turn off visibility for that layer in both documents but kept the other relevant layers visible. 

 

Document 1 saved fine. Everything displays as I want it to. Document 2 is missing a layer. That layer is visible in Illustrator. That layer's options are set to "Print" (see image). When I Save As... PDF, I don't get any options to "Print all layers." 

layer-print.PNGgeneral.PNG

 

What's truly puzzling is that it's working fine for one document and the other it's not. 

TOPICS
Import and export

Views

130

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Jun 22, 2021 Jun 22, 2021
I figured out the issue. Although I was seeing the text as black, for some reason it was actually white. There was some kind of mask or some other feature involved that allowed me to see the characters but in reality, their fill was set to white. Once I went back in and made sure their fill was set to solid black, the export worked. 

Likes

Translate

Translate
Adobe Community Professional ,
Jun 19, 2021 Jun 19, 2021

Copy link to clipboard

Copied

Can you share both Illustrator files?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

LATEST

I figured out the issue. Although I was seeing the text as black, for some reason it was actually white. There was some kind of mask or some other feature involved that allowed me to see the characters but in reality, their fill was set to white. Once I went back in and made sure their fill was set to solid black, the export worked. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines