Missing Colon on Karla Font when exporting to PDF

Community Beginner ,
Nov 16, 2021 Nov 16, 2021

Copy link to clipboard

Copied

I am using the Karla font. When I export to a PDF, all of the colons : (and just the colons) are converted into a white box with an X in it. See attached photo.

TOPICS
Bug

Views

160

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 17, 2021 Nov 17, 2021

Copy link to clipboard

Copied

Hi, I'm having the same issue and I'm still looking for a solution. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 17, 2021 Nov 17, 2021

Copy link to clipboard

Copied

Hi again, I've downloaded and installed again the original font files from Google Font and now everything is working fine.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 17, 2021 Nov 17, 2021

Copy link to clipboard

Copied

I had this problem today. I fixed it by deleting the variable font and installing the "static" ttf fonts instead. They're included in the download package.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 10, 2022 Jan 10, 2022

Copy link to clipboard

Copied

Hi, I'm facing similar issues with Karla. First it was the missing colons and now the entire Regular weight is missing. I have tried uninstalling the variables and only installing the static ttf fonts, but the problem persists. Appreciate any help on this! Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 10, 2022 Jan 10, 2022

Copy link to clipboard

Copied

Exactly what have you been doing step by step when this happens?

What does the foundry say to that issue?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 10, 2022 Jan 10, 2022

Copy link to clipboard

Copied

I styled a doc using Karla. The body text has been styled with the Regular weight. I created a pdf of the document and noticed that all the colons used in the doc were showing up with a box with an x inside (grab attached) When I tried fixing the colons, the regular weight went missing. (Grab attached) All other weights are appearing fine. Havent checked with the foundry yet. Few blogs suggested uninstalling the variable fonts that come with the Static ttf fonts and I tried that too. 

Screenshot 2022-01-10 at 7.15.44 PM.png

 

Screenshot 2022-01-10 at 7.19.03 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 10, 2022 Jan 10, 2022

Copy link to clipboard

Copied

That is a screenshot from InDesign. Are you using Illustrator or InDesign?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 10, 2022 Jan 10, 2022

Copy link to clipboard

Copied

Yes, I'm using Indesign. Sorry I realised after I had posted, that this is specific to Illustrator! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 10, 2022 Jan 10, 2022

Copy link to clipboard

Copied

As annoying as it is, I had to have IT completely wipe the font, uninstall Adobe completely, then download the static version of the font and it fixed it.

 

Even that didn't fix it for my coworker, so they were going to wipe her computer completey and then download the static version of the font.

 

I have not yet figured out why Karla is so annoying.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 10, 2022 Jan 10, 2022

Copy link to clipboard

Copied

Oh no! And i'm here thinking there has to be a simple fix to this. Going to wait and see if anyone here has found a less teadious way out of this annoying problem. 😞  I also wonder why I was able to design an entire 50 page indesign document with the font not acting up once and now all of a sudden it just wont work. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 10, 2022 Jan 10, 2022

Copy link to clipboard

Copied

For me, it was doing that for the "Regular" version of the font because somehow it was "remembering" JUST the regular version of the Variable font. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jan 10, 2022 Jan 10, 2022

Copy link to clipboard

Copied

LATEST

Google needs to do a better job testing the type families it hosts on the Google Fonts web site. I've encountered several typeface families with serious technical problems, including some of the variable fonts. Encode Sans is one example; its standard fonts work alright but the variable versions do not on any of my PCs. Some of the Exo fonts have issues. These may be free/open source fonts, but if they're going to be hosted on a web site with an extremely well-known brand the font files should function up to a certain proper standard. It's one thing to find out a free font is glitchy and not useable when downloaded from a site like DaFont. The Google Fonts web site gives users the impression the fonts hosted there are professional quality.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines