• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
15

Sticky selection tool in illustrator 27.9

Explorer ,
Oct 23, 2023 Oct 23, 2023

Copy link to clipboard

Copied

Me and my team are all experiencing this same issue. Happened to all of us after a recent update. Anyone else?

TOPICS
Bug , Performance , Tools

Views

2.4K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe
Adobe Employee ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

Hello @cathyk22,

 

I'm sorry to hear that you and your team are experiencing this issue with the Sticky Selection Tool in Illustrator. To provide you with more effective assistance, I'll need a bit more information:

  • Could you explain in more detail what the problem is? What's happening with the Sticky Selection Tool?

  • Would you mind updating to v28.0 and see if that helps, or revert to v27.8.1 and share your observation with us?

  • Are you and your team members all on the same operating system, or are there different systems involved (e.g., Windows and macOS)?

  • Have you tried any troubleshooting steps, such as restarting Illustrator or your computer?

 

By sharing these details, we can better understand the issue and work towards a solution. Your input is crucial in resolving this matter, and I'm here to help you.

 

Best regards,

Anshul Saini

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

Hi, I'm on Mac OS Monterey 12.3 with Illustrator 27.9.  We use plug-ins that aren't available in v28.0 yet... so we'll have to stay on 27.9.  Yes, we're all rebooted a bunch of times.  The issue come when you select an object.  There's a lag and it doesn't move for a second or so.  Then it's "sticky" and won't drop until you click somewhere.  Then you have to CMD+Z to get it to return to its original location and select it again.  Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

 I work on a macbook Pro

Processor: 2.9 GHz, Quad-core Intel Core i7

Graphics: Radeon Pro 560 4 GB, Intel HD Graphics 630, 1536 MB

Memory: 16 GB 2133 MHz LPDDR3

OS: Ventura 13.6

 

Just updated to Illustrator 28.0, but the same issue with Illustrator 27.9

So my "sticky" selection tool issues...

  • when i click on an object, there is a lag when i attempt to move it, where normally when i click on an object and drag it happens immediately. 
  • When I select more than one object, they both lag (see above)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 26, 2023 Oct 26, 2023

Copy link to clipboard

Copied

@Anshul_Saini I have tried running 28.0, 27.9 and 27.8.1 with all the same issues

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 10, 2023 Nov 10, 2023

Copy link to clipboard

Copied

@cathyk22 @udowooten Has anyone found a fix yet? My team and I continue to have this problem

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 30, 2023 Dec 30, 2023

Copy link to clipboard

Copied

I am on a M1 Macbook Pro 16GB  Sonoma 14.2.1 running Illustrator 2024 (v28.1) Having the exact same issues, and possibly additional issues.
I am currently only using my trackpad, no bluetooth or external devices are connected. I've disable all drivers from Wacom and Huion.
My "sticky" selection tool issues are:

  • when I click on an object, there is a pause of about 1 or 2 seconds and the object jumps
  • when double clicking on a group of objects, the selection jumps again
  • sometimes when clicking on an object, the object will get "Stuck" to my cursor and if I move my mouse the object moves with it as if I am holding the mouse button down.
  • if I click and drag on an object, it will take about 1 or 2 seconds for the object to move to where my cursor has moved.
  • Sometimes there is significant lag when moving objects and I get the spinning beach ball.


I am experiencing all these issues, some more than others, in every single document I open. I have tried reinstalling Illustrator, switching to older versions (v27.5), clearing all preferences and plugings, restarting computer every single time.

This problem began about 2 weeks ago when I believe Illustrator 2024 was released. I didn't notice how bad these issues were until yesterday as i had not been using illustrator very much until then. I've used illustrator daily in the past few months and never had these performance issues. It is now at a point where my workflow has taken a considerable hit. This needs to be fixed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 30, 2023 Dec 30, 2023

Copy link to clipboard

Copied

I forgot to mention, I am not on a company computer and am not running any background security plugins/apps.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 30, 2023 Dec 30, 2023

Copy link to clipboard

Copied

Does it also happen when you boot into Safe Mode and then run Illustrator?

Does it happen when you turn off all other apps?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 30, 2023 Dec 30, 2023

Copy link to clipboard

Copied

It doesn't happen in Safe mode. Not exactly sure how to "Turn off all other Apps".

HOWEVER, I think I found the culpret...

 

Since it worked in Safe Mode I knew it must be a background app or process causing the issue. I had already ruled out Wacom and Huion drivers as not being the issue. I toggled off an app called "Magnet" for Mac, a window manager/organizer that automatically resizes windows for multitasking. Once I toggled the app to disable itself when using illustrator, the "sticky" issue no longer exists. Toggling it back on, the "sticky" issue comes back.

 

I'll keep an eye on it over the next couple days, but I hope this will help someone else who is using a similar program.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 30, 2023 Dec 30, 2023

Copy link to clipboard

Copied

Glad you could solve it. I'm sure this will help others.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 11, 2024 Jan 11, 2024

Copy link to clipboard

Copied

This fixed it for me! Thank you so much! I love Magnet but it was making Illustrator unusable. Hopefully there's an update soon to fix this.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 14, 2024 Jan 14, 2024

Copy link to clipboard

Copied

Thank you for this. I have had the same issue for 2 weeks and it's infuriating! Turning off Magnet solves the proble. Now, back to work. 🙂

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 07, 2024 Feb 07, 2024

Copy link to clipboard

Copied

I can also confirm that when running Magnet and telling it to 'ignore Illustrator' the sticky pointer issue goes away and reappears if Magnet is reset to include Illustrator. Great discovery ceadespup!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 02, 2024 Apr 02, 2024

Copy link to clipboard

Copied

Just a note that this fixed my problem, good lord this was frustrating. @Monika Gause there seems to be a conflict between these two softwares, just a heads up. Thanks @caedespup ! 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 07, 2024 May 07, 2024

Copy link to clipboard

Copied

Thank you *SO* much for posting this. It solved my problem. This was driving me utterly insane. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 25, 2023 Oct 25, 2023

Copy link to clipboard

Copied

Anshul, this seems to be a common problem with Photoshop as well. 

https://community.adobe.com/t5/photoshop-ecosystem-discussions/hand-tool-lock-after-releasing-spaceb...

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 25, 2023 Oct 25, 2023

Copy link to clipboard

Copied

@Anshul_Saini I'm experiencing this as well while using 28.0 as well as previous versions. Several of my coworkers on MacOS are as well.

 

@cathyk22 
Does your team have system security plugins/apps that run in the background like many companies install on each machine?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 25, 2023 Oct 25, 2023

Copy link to clipboard

Copied

@David of course my company has security apps running in the background. But that has been the case for awhile now. This "sticky" issue seems to have come right around the time of AdobeMax, so wondering if there was an update that has a bug?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 25, 2023 Oct 25, 2023

Copy link to clipboard

Copied

 Do you happen to know which ones? I'm thinking an update installed quietly might have caused this. I noticed that starting up in Safe Mode will allow Illustrator to operate as expected, but any fonts that aren't system defaults don't seem to load, so that doesn't really make it a fix. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 26, 2023 Oct 26, 2023

Copy link to clipboard

Copied

Zscaler is our internet firewall. Sisco Secure Endpoint is our malware/virus software. HBU @DavidRulz 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 26, 2023 Oct 26, 2023

Copy link to clipboard

Copied

@cathyk22 our machines also have Zscaler. Workspace ONE, Enterprise Connect, and some I don't know what they are... I just see login items Azul Systems, Carbon Black, Flexera, Proofpoint and Wandering WiFi.

 

Zscaler seems like it would be a strange culprit...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 15, 2023 Dec 15, 2023

Copy link to clipboard

Copied

@ckallas22 do you know what security programs your computers are using? Trying to figure out what sort of "always going in the background" kind of software might be causing this. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 15, 2023 Dec 15, 2023

Copy link to clipboard

Copied

@DavidRulz I have been racking my brain to figure it out. It all seems to have happened around AdobeMax in October... looking in activity monitor I find... Anyconnect, AMP for endpoints connector(?), IT Protector (?) but who knows what IT pushes regularly onto our computers.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 15, 2023 Dec 15, 2023

Copy link to clipboard

Copied

I'm pretty sure it is related to some IT update, as I began having the issue one morning after leaving my laptop at work. I have to think something was installed overnight since I wasn't having the issue the day before.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines