• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

The filter cannot complete because of an unknown error

Explorer ,
May 27, 2022 May 27, 2022

Copy link to clipboard

Copied

In the latest version of Illustrator 26.3.1. I am trying to save a variable library and keep getting this error message "The filter cannot complete because of an unknown error" 

HenrySolis_0-1653672288929.png

I am wondering if anyone else has experienced this issue.

When I revert to the older Illustrator version 26.2.1 variable library saves fine no issues.

TOPICS
Bug

Views

5.3K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Nov 21, 2022 Nov 21, 2022

Hi Kate,

We reverted to last version of illustrator and that worked.

Votes

Translate

Translate

correct answers 1 Pinned Reply

Adobe Employee , Nov 18, 2022 Nov 18, 2022

Hi @Kangi Sportswear,

 

Thanks for reaching out and trying to resolve the issue by reverting to an older version. As Ton suggested above, have you tried resetting Illustrator preferences?

 

If that didn't help, would you mind sending us the packaged Ai & eps file via DM and sharing a small recording demonstrating the issue along with a screenshot of system specifications? I will forward it to the product team for further investigation.

 

Also, would you mind upvoting this UserVoice (https://illustrator.uservoice.com/forums/601447-illustrator-desktop-bugs/suggestions/45199726-broken-save-variable-library

...

Votes

Translate

Translate
Adobe
Guide ,
May 27, 2022 May 27, 2022

Copy link to clipboard

Copied

I'm not sure about this particular issue but the first thing to try is resetting Preferences. Use the Preferences button, or Edit > Preferences > General, or Ctrl/Cmd+K to open the General option in Preferences, click Reset and Restart Illustrator. If this does not help, well then we'll have to search for something else.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 27, 2022 May 27, 2022

Copy link to clipboard

Copied

If something still works in a previous version I would contact Adobe support:

Welcome to Adobe Customer Care! Need help?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 27, 2022 May 27, 2022

Copy link to clipboard

Copied

I imported a .csv file and  was able to Save Variable LIbrary to .xml on 

Mqc OS 10.15/7 and the latest Ilustrator 26.3.1

 

Can you try with a simple data file, might be an nonfriendly character in the data like a slash or colon. Just open a.csv in TextEdit and strip out all but a few fields. We will then know if this works on a simple file, or not at all.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 27, 2022 May 27, 2022

Copy link to clipboard

Copied

But I agree with Anna, resetting Preferences and restarting your machine is the first thing to try.

https://helpx.adobe.com/illustrator/using/setting-preferences.html

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 26, 2022 Sep 26, 2022

Copy link to clipboard

Copied

Did you figure out what was going on? I'm encountering the same issue in Illustrator 2022.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 21, 2022 Nov 21, 2022

Copy link to clipboard

Copied

Hi Kate,

We reverted to last version of illustrator and that worked.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 25, 2023 Aug 25, 2023

Copy link to clipboard

Copied

how far back in versions did you have to go?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 28, 2023 Aug 28, 2023

Copy link to clipboard

Copied

Hi @Nikitarose,

 

Thanks for reaching out. As per Henry's original post, Illustrator version 26.2.1 has been reported to work without any issues related to the error message "The filter cannot complete because of an unknown error." You might consider using this version to avoid the problem you're facing.

 

Best regards,

Anshul Saini

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

Did you solved this issue? I'm encountering the same problem but only with linked images (EPS). Texts work.

I tried to revert to version 26.0 but it still doesn't work.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 18, 2022 Nov 18, 2022

Copy link to clipboard

Copied

Hi @Kangi Sportswear,

 

Thanks for reaching out and trying to resolve the issue by reverting to an older version. As Ton suggested above, have you tried resetting Illustrator preferences?

 

If that didn't help, would you mind sending us the packaged Ai & eps file via DM and sharing a small recording demonstrating the issue along with a screenshot of system specifications? I will forward it to the product team for further investigation.

 

Also, would you mind upvoting this UserVoice (https://illustrator.uservoice.com/forums/601447-illustrator-desktop-bugs/suggestions/45199726-broken...) and adding your comment there?

 

I will be looking forward to your response.

 

Thanks,

Anshul Saini

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 02, 2022 Dec 02, 2022

Copy link to clipboard

Copied

Hello everyone.

Few weeks ago i started using variables and I encountered the same issue OP had but specifically for linked images, text variables worked fine. I tried everything, resetting preferences, reverting Ai version, uninstalling-re-installing, made simple text with simple images and names. Nothing worked, untill it did. Dont' ask me how but hat error popup disappered and i was able to use variables again on the last Ai version. ...until today, as few minutes ago the same error accoured. I did again all the tests (except reverting) but it's still not working.

This is a huge problem form me cause i was setting my workflow, scripts and whatsoever based on the possibility to use the variables.

Does anyone have a definitive solution? Is the product team working on it?

Thanks in advance.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 02, 2022 Dec 02, 2022

Copy link to clipboard

Copied

How do you import your variables? Can you try and use the variable importer script?

https://github.com/Silly-V/Adobe-Illustrator/tree/master/Variable%20Importer

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 02, 2022 Dec 02, 2022

Copy link to clipboard

Copied

Hi Monika and thank you for your reply.

I upload a CSV file on the variables windows. I knew there is a script to do that but since it was functioning well till today i thought it wasn't necessary. Are you saying using the script will solve the issue?
I'm going to try it right away.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 02, 2022 Dec 02, 2022

Copy link to clipboard

Copied

The script has several options that can solve file paths and format issues with the CSV (that some versions of Excel create)

See a tutorial: https://www.hypertransitory.com/blog/2015/04/26/illustrator-variable-data/

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 02, 2022 Dec 02, 2022

Copy link to clipboard

Copied

Hi Monika, i've already watched the tutorial you brought to my attention and several more on the same subject but always rejected to use the script cause i thought i was faster the other way... but i have to thank you for suggesting me to use the Variables Importer script cause i finally try it and: it actually "works. At least so far. I don't wanna jinx me...
The scripts options are indeed useful but there's something quite annoying and i'd like to ask you if it can be avoided. Let me explain myself.
Before using the script i was uploading into the variables windows the csv file (generated from google sheet, not excel) in which the image-variable (@variableN) column already contained the path where the images are located. Now using the script i have to input that path everytime. Is there a way to avoid it so i can save time and lower the odds to make mistakes?
Does the script still work if i put the path in the csv and not in its option panel? I'd say "no" cause its the path inside the csv itself that trigger the error.. but i ask you just to be sure.

Thank you in advance, have a nice day.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 02, 2022 Dec 02, 2022

Copy link to clipboard

Copied

I'm sorry I don't use the script extensively, so I cannot answer that, but I hope that someone can chime in.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 02, 2022 Dec 02, 2022

Copy link to clipboard

Copied

I think @Silly-V  who, I believe wrote the script, may be able to help.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 02, 2022 Dec 02, 2022

Copy link to clipboard

Copied

I guess i spoke too soon? I was doing some tests and suddenly the variables importer started to give me this error (see attachment). I really don't know what i did to make this happen., the files involved were the same, i recorded some more separated actions but nothing related to the variables...
I really hope someone, or even Silly-V could help me.

How can i reach him? I have another question related to his script.

Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 02, 2022 Dec 02, 2022

Copy link to clipboard

Copied

I think i isolated the problem and i'm pretty sure it's caused by triggering the script from an action (for convenience i saved the script into an action to recall it a bit easly..) while when i recall it from the file menu it works.

I hope it was just that.

Now i'm going ot message Silly to thank him for his work and ask one more question.

Thank you all!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 03, 2023 Nov 03, 2023

Copy link to clipboard

Copied

I had the same problem.
For me, the issue seems to be related to the fact that I'am working with a multiple artbords document.
If I delete the artboards and I move all my information to one artboard, works perfectly.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 30, 2024 Apr 30, 2024

Copy link to clipboard

Copied

Yes, I am creating batches of bus flags from a spreadsheet. When I set it up to import one side of the flag onto one artboard it worked fine. I could make tweaks to the CSV file and re-load the variable which updated the artwork. I then added a second artboard for the reverse side of the flag with the same data. It works when I delete all the variables and re-add them but if I re-load the CSV to update artwork I get this error. Pretty annoying to my workflow so it would be good if a fix could be developed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 01, 2024 May 01, 2024

Copy link to clipboard

Copied

LATEST

Hello @CorporalJellyfish,

 

We're sorry to hear about the error you're encountering. We're here to help! Could you please provide a few more details:

  • What operating system and version of Illustrator are you using?
  • Is the issue specific to a particular document/ CSV file? If so, could you share the document with us? You can upload it to Creative Cloud and share the download link.
  • Where is the CSV file saved? (Network Drive/System HDD/Shared Folder on System/External HDD)
  • Have you tried resetting Illustrator Preferences to see if it resolves the issue?

Please note that resetting preferences will restore Illustrator to its default settings, removing any customizations. You can back up the folders if needed, as mentioned in the article.

 

Looking forward to resolving this issue for you!

 

Best,

Srishti

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines