Why so many processes of Adobe CEP HTML Engine running in background on Windows system.

Community Beginner ,
Jul 25, 2019 Jul 25, 2019

Copy link to clipboard

Copied

I'm using Illustrator and Photoshop CC 2019 and my task manager showed that more than 20 process of Adobe CEP HTML Engine running in the background. This is too much, how do I disable them?

I have searched the forum and the solutions found on this page does not work - High CPU usage due to CEPHtmlEngine - it's outdated and I cannot find those mentioned files in my Adobe Illustrator CC 2019 folder.

Adobe-CEP-HTML-Engine.jpg

{Renamed by MOD}

Views

7.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 26, 2019 Jul 26, 2019

Copy link to clipboard

Copied

Hi there,

Thanks for reaching and sharing the feedback. I see that there are so many CEP HTML processes running in the background. Are you facing any performance issue with Illustrator and Photoshop? If yes, let us help you make this right. I would need a few more details like:

  • Please check if there are any Windows updates pending?
  • If not, try logging in to Hidden Admin account and check how it works there?

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 21, 2021 Oct 21, 2021

Copy link to clipboard

Copied

This has actually worsened the problem. We've nearly exhausted very copy/paste Knowledge Base article provided by ADobe in both forums, calls, emails, etc...and the constant maintenance with this unreliable software is proving a trend in tail chasing reliable and effective solutions. We've even tried to uncheck the plugins that connect to the internet under "Preferences", and discovered that the uncheck does absolutely nothing as it will STILL continue regardless and sometimes runs twice the Adobe CEP html Engines. Should we get it to disable, we alos noticed when attempting any local "Saves" it seems to cue it back it up, attempts to sync to libraries and cloud, we are prompted to pay, stalls at 99%, then crashes. Our usual routine is the 3rd Save, or force Close the App, rely on Auto-Recovery, re-save under new name, copy over to project folder, then rename to actual intended filename. This routine has reduced our productivity alone by 15%. However, I do appreciate that someone reporting to the Executive branch confirmed that Adobe CC, despite it widely advertised, is not meant to run on an Enteprise server. It is my hope that Adobe will return to the Enterprise performance it had with 2017 in the very near future.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 30, 2019 Jul 30, 2019

Copy link to clipboard

Copied

Yes, you are right, Srishti. After I update my Windows 10, the number of CEP HTML processes reduced from 9 to 3.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 02, 2019 Aug 02, 2019

Copy link to clipboard

Copied

Thank you so much for confirming. Do let us know if you have any other queries. We're happy to assist.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 27, 2021 Apr 27, 2021

Copy link to clipboard

Copied

I have a Citrix server with 10 users, only one is using InDesign.

Why has everybody started ?

  • AdobeLPCBroker.exe
  • CCXProcess.exe

 

Why has the 1 Indesign user started this mutch?

defaultxobua3vdu941_0-1619527124786.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 27, 2021 Apr 27, 2021

Copy link to clipboard

Copied

Hi there,

 

Sorry about this trouble. Could you please check how much is the CPU usage? 

 

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 27, 2021 Apr 27, 2021

Copy link to clipboard

Copied

No CPU usage to notice - only RAM usage.

And why has everybody some Adobe files running, when they are not using Adobe-products?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Aug 02, 2019 Aug 02, 2019

Copy link to clipboard

Copied

You can follow the below link to resolve the issue regarding the CEP HTML engine of Adobe

High CPU usage due to CEPHtmlEngine

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 05, 2020 May 05, 2020

Copy link to clipboard

Copied

This did not resolve the issues for me. Thanks for nothing Adobug.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 18, 2021 Oct 18, 2021

Copy link to clipboard

Copied

This article is mildly useless. It says

"Confirm that the folder exists and you have write permissions for it."

Cool, so what if I don't have that folder? It gives zero (=NO) information about what to do in that case. How is that helping me?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 01, 2021 Dec 01, 2021

Copy link to clipboard

Copied

Well, I have over 100 instances of the CEP HTML Engine running! I created the missing log folder. No difference.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 01, 2021 Dec 01, 2021

Copy link to clipboard

Copied

Untitled-1.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 24, 2022 Apr 24, 2022

Copy link to clipboard

Copied

LATEST

Same issue, did you find  a fix? Driving me mad!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines