Highlighted

Illustrator CC 2014 extremely choppy. Please help.

Nov 04, 2014

Copy to clipboard

Copied

I just bought an iMac 5k Retina Base model with Yosemite installed. All other CC applications work like a breeze except illustrator. Illustrator is extremely choppy and almost unworkable. Can someone help me out?

SeanJM,

I just updated to CC 2015 and Illustrator is back to being snappy, responsive, and smooth on a 5k Retina iMac!

After installation, a pop-up of "Compatible GPU detected" auto-enabled the new Mac GPU settings.


If this didn't automatically happen for you, go to:

Illustrator CC > Preferences > GPU Performance - and check the box labeled "GPU Performance".


Thank you to the Adobe team for getting the engine updated!

I can safely recommend Creative Cloud to 5K Retina iMac users now.


Edit: This was using the AMD Radeon R9 M295X 4GB graphics card.

Views

55.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Illustrator CC 2014 extremely choppy. Please help.

Nov 04, 2014

Copy to clipboard

Copied

I just bought an iMac 5k Retina Base model with Yosemite installed. All other CC applications work like a breeze except illustrator. Illustrator is extremely choppy and almost unworkable. Can someone help me out?

SeanJM,

I just updated to CC 2015 and Illustrator is back to being snappy, responsive, and smooth on a 5k Retina iMac!

After installation, a pop-up of "Compatible GPU detected" auto-enabled the new Mac GPU settings.


If this didn't automatically happen for you, go to:

Illustrator CC > Preferences > GPU Performance - and check the box labeled "GPU Performance".


Thank you to the Adobe team for getting the engine updated!

I can safely recommend Creative Cloud to 5K Retina iMac users now.


Edit: This was using the AMD Radeon R9 M295X 4GB graphics card.

Views

55.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 05, 2014

Copy to clipboard

Copied

Same issue here. Absolutely devastated.

Illustrator CC is practically unusable on the new base model iMac Retina with i5 CPU and Radeon R9 M290X GPU.

The issue seems to be unique to Illustrator.

Can anyone advise if Illustrator performs OK with the 4GB Radeon R9 M295X?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Nov 05, 2014

Copy to clipboard

Copied

Hi mckeownr,

Can you please elaborate the word "Absolutely Devastated" a little more ? What are you observing ? Which other Adobe products are working fine for you ?

I want to have a look into this issue.

With Best Regards,

Raghuveer

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 05, 2014

Copy to clipboard

Copied

I can understand mckeownr's devastation. 'cause I'm going through similar emotions. Let me try to explain.

I have a iMac 5K base model, the latest version of Yosemite and Creative cloud. When I fire up Illustrator, it's ready to go in a flash. Then, when I open a file, it opens in a flash too. But just doing any kind of work on it is woefully bad. Like dragging an artboard or zooming in or zooming out, or moving an image around or a text box or a large headline. Everything is just so sluggish that it's unbearable. I reduced the resolution on my mac to its lowest. Yet no respite. I quit all applications and did everything to squeeze every bit of juice out of my mac, yet there isn't an iota of change in the way illustrator behaves. This is why it's truly devastating, compounded with the fact that I'm a designer and will be required to use illustrator extensively.

I must mention that applications such as Premiere Pro and Photoshop work like a song. I mean it's truly a pleasure working on these application on the 5K iMac. But illustrator is just complete trash.

In fact the very same files opened on the very same version of Yosemite and the version of illustrator on my Mac Air (late 2010) work perfectly alright.

I pray that someone helps. My rent depends on it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Nov 05, 2014

Copy to clipboard

Copied

Hi Sahit Anand,

Thanks for sharing this in detail. Will it be possible for you to share your AI file with me at rbhunwal@adobe.com

If this file contains any linked images then please create a package of the file and then make a ZIP of the packaged folder and share it with me.

With Best Regards,

Raghuveer

Illustrator Team

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 05, 2014

Copy to clipboard

Copied

rbhunwal Will definitely try to do that.

In the meantime, I've sort of discovered something new. If I use Illustrator (at my monitor's highest resolution) where the Illustrator window is fully maximised, the sluggishness is extremely high. But if I change the size of the window to say about 1/3rd of the screen (highest resolution),the sluggishness is vastly reduced. Not gone. But reduced.

And then, when I change the resolution of my Mac to its lowest, and the window is full screened, the sluggishness is again largely alleviated. I know that I said before, that no matter what the resolution the sluggishness remained. Well apparently, at its lowest resolution, its not there anymore.

I think I have a theory. I don't think Adobe's illustrator CC 2014 release is utilising my Graphics GPU at all. Which, I think, explains the above phenomenon.

Any thoughts?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Nov 05, 2014

Copy to clipboard

Copied

Hi bozogubu,

I tried to repro the same at my end but in my case there is no sluggishness. AI is working perfectly.

Are you observing the issue with all the files or with some particular files ?

Is the "Links" palette opened at that time ?

What happens with a newly created file ?

Waiting for your source file.

Thanks & Regards,

Raghuveer

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 05, 2014

Copy to clipboard

Copied

The Link palette isn't opened. I'm experiencing with every file that I have, even if it's just plain type based files. Even when I create a brand new file, this happens. In fact The sluggishness is there even if I just have a blank art board. No pictures or text or anything.

I'm uploading the files as we speak. You have a base model iMac 5K retina too?

Regards

Sahit

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Nov 06, 2014

Copy to clipboard

Copied

bozogubu

Yes we have the same base model. There is only one model available. iMac with Retina 5K display - Buy iMac Desktop Computers - Apple Store (U.S.)

Are you on CC 2014 or 2014.1? Please look for version number in Illustrator menu Illustrator>About Illustrator

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2014

Copy to clipboard

Copied

I have Illustrator 2004.1.0

Apparently this isn't a totally unique problem. Check this out.

https://forums.adobe.com/thread/1000477?start=0&tstart=0

Illustrator CS6 - Lagging - extremely slow!!

Really running out of options here. I have project coming and I have no idea how I'm going to handle it with this problem.

rbhunwal I've sent you the file. Please check and let me know.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2014

Copy to clipboard

Copied

Might be an obvious answer but have you tried turning off gpu performance in preferences. If there is an issue with Illy and your graphics card then it will preview really slow.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2014

Copy to clipboard

Copied

I'm trying to... But I can't find that option in my preferences. In fact that was the first thing that I looked for. But instead of trying to turn it off as you suggested, I was wondering If it was switched off as default and was looking around to turn it on or something. Considering I'm using the illustrator at full 5120x2880 resolution..

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2014

Copy to clipboard

Copied

I have exactly same issue with you. My illustrator cc works very slow on my base model retina iMac while photoshop works fine. The problem gets worst when I click and drag my mouse in color panel, the select circle has intensive lag following my mouse.

Also I tried to reduce the window size and it indeed gets better.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 14, 2014

Copy to clipboard

Copied

That option isn't available on macs. It might be available if the mac runs an nvidia gpu, but this issue is about iMac Retinas which only have AMD Radeon's.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 02, 2014

Copy to clipboard

Copied

I have the same issue. I've abandoned Illustrator until such time that they fix it and if it's not fixed in a timely fashion, will be ceasing my CC subscription. I suggest everyone else do the same. I pay GOOD money for a product, I expect it to bloody-well work!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 14, 2014

Copy to clipboard

Copied

Just an update to my previous post.

I have since cancelled my CC subscription until such time they fix this issue. I was hoping they would have fixed this major issue in the latest Illustrator updates but they didn't. Your loss Adobe. I'd rather deal with Corel or Sketch.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 15, 2014

Copy to clipboard

Copied

It's not limited to iMac Retina but all Retina models. I've got a 2014 MBP Retina (Nvidia GT 750M 2GB) and it's the same problem. To be sure just open the .app in low res and everything should run smoothly.

COME ON Adobe!!!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 15, 2014

Copy to clipboard

Copied

Has this always been the case or is it since updates? Retina has been out a while for MacBooks so you would have hoped they would have optimised it for them by now!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 15, 2014

Copy to clipboard

Copied

This has always been this way. The update don't fix anything however. Adobe adds retina support since 2012. Almost 3 years later, Illustrator is still choppy. I don't think they'll fix it one day.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 21, 2015

Copy to clipboard

Copied

I Am also having slow performance on my 5k iMac this really sucks I hope you can work out a soloution soon.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2015

Copy to clipboard

Copied

NO!  My brand new macbook pro retina display, has the exact same issue running Photoshop Elements 13!  It hs HUGE problems running Photoshop!  I am also very upset about this because I purchased this upgraded macbook pro to primarily run Adobe products.  This issue is all over the internet.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 12, 2016

Copy to clipboard

Copied

I have the same one, and I can attest to this. Illustrator is so sluggish, it's unusable, PLEASE ADOBE FIX THIS ASAP, I got work to do!

Has anyone found a fix yet?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2014

Copy to clipboard

Copied

I guess we still don't have an answer for this? I'm having the same exact problem here.

Brand new iMac (Retina 5k, i5, 16GB RAM, Fusion Drive, R9 290X 2048MB), everything seems to run fine except illustrator. It's just unusable.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2014

Copy to clipboard

Copied

Hi,

I have the same problem in Illustrator CC 2014. iMac Retina, R295X, 512GB SSD, yet 8GB Ram.

Scrolling in a File, using the hand tool is very slow.  To be said is, that it doesn't matter if

the file contains graphics (whether vektors or big pixel images) or is just an empty freshly created file,

also the artboard size doesn't matter.

What I also discovered is, if I scale the artboard to one third of the screen width, it scrolls fine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2014

Copy to clipboard

Copied

ive had a representative from adbe help me through the problem. He said that adobe was able to recreate the issue in their computers and is working on a fix for it. I'm hoping a fix happens quickly.

quite frankly, illustrator should be a joy working on a 27 inch retina screen. Can't wait for the bug to be fixed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2014

Copy to clipboard

Copied

Absolutely, can't wait to make good use of all them pixels with illustrator. Here's hoping they manage to resolve it soon.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 19, 2014

Copy to clipboard

Copied

at least they acknowledge/working on it.

same problem. 1 year old macbook pro. high spec. cc 2014.1

all applications seem to be fine. illustrator sluggish to the point it is unusable.

designer next to me on a slower machine has no such problem.

both on yosemite (this started happening to me right after installing yosemite. just updated with lastest version. no change in illustrator).

------ update -->

i use a triple monitor set up. i turned off the 2 extra monitors (only using one .. a cinema display). works (ALMOST) fine now. definitely usable. sometimes sluggish with certain functions (ie. start up, etc)

everyone who is having illustrator specific issues, are you using multiple monitors? try turning them off and see what happens.

--- > previous attempts in fixing with no change in illustrator problem

- reinstall illustrator

- install 2014 (not 2014.1)

- uninstall all extra fonts

- downgrade AND update java

- updated yosemite to newest patch (out today)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 19, 2014

Copy to clipboard

Copied

Hey folks,

Just wanted to report that I am having the same issue with Illustrator CC.


My specs are: Retina iMac 27" 4GHz i7 /  32 GB ram  /  Radeon R9 4095mb Card

I'd venture to say Illustrator is about 60% slower than it was on my mid-2010 27" iMac.

Also for clarification, I am not using additional monitors nor does it look like Adobe is using any excessive memory.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...