Illustrator CC 2019 extremely laggy

New Here ,
Feb 27, 2019 Feb 27, 2019

Copy link to clipboard

Copied

First of all, I am using the following machine:

iMac (Retina 5K, 27-inch, 2017)

Processor 4.2 GHz Intel Core i7

Memory 32 GB 2400 MHz DDR4

Graphics Radeon Pro 580 8192 MB

And everything feels like I am running Witcher 3 on Pentium 4... well maybe not that bad but it takes 5 seconds to open the new document window, everything seems so sticky, laggy, slow, stutter... the experience is simply horrible.

Is there any known solution to this laggy situation? Does anyone else have the same issue?

Views

6.9K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

New Here , Mar 03, 2019 Mar 03, 2019
I solved my own problem. Here's how:Go to preference ---> performance ---> click on the box next to GPU performance.Done. Everything is smooth sailing now.

Likes

translate

Translate

Translate
Adobe Community Professional ,
Feb 28, 2019 Feb 28, 2019

Copy link to clipboard

Copied

Try the suggestions from herryC in this thread.

After updating too illustrator cc 2019 its very slow

hth

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 01, 2019 Mar 01, 2019

Copy link to clipboard

Copied

Hi Brandon,

Sorry to hear about this issue. Please make sure that you have I-Cloud sync turned off from the system preferences:

turn of Icloud backup.jpg

If that does not help, I would request if you can try resetting preferences for Illustrator and let us know if that helps: How to set preferences in Illustrator.

Please note: Resetting preferences will remove all the custom settings and Illustrator will launch with default settings. You can also take a backup of the folder in case you want to. Location is mentioned in the article.

Regards,

Srishti

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 01, 2019 Apr 01, 2019

Copy link to clipboard

Copied

the solution is to turn off iCloud?

I am having this same problem, documents take an age to open, dragging even a simple box around looks like a computer from the 90s. (I am on a 2018 macbook pro with GPU enhancements turned on)

Can we get a real fix for this please? Illustrator became almost unusable in CC 2019!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 08, 2019 Apr 08, 2019

Copy link to clipboard

Copied

Hi,

We are extremely sorry to hear about this issue. I asked to turn off iCloud services because iCloud is a network-based service. Illustrator does not support network or removable drives as scratch disks, or folders of file sync services such as Dropbox, Google Drive, and iCloud (Illustrator support for networks and removable media ).

In case it does not work even after turning off iCloud services, do let us know, we are here to help.

Regards,

Srishti

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 03, 2019 Mar 03, 2019

Copy link to clipboard

Copied

I solved my own problem. Here's how:

Go to preference ---> performance ---> click on the box next to GPU performance.

Done. Everything is smooth sailing now.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 08, 2019 Apr 08, 2019

Copy link to clipboard

Copied

Doesn't make any difference on my machine. gtx570

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 15, 2019 Sep 15, 2019

Copy link to clipboard

Copied

Hello everyone,

here is my story.

I have a MBP 2016, which goes well but slow and heats up, so I decided to have a new desktop.I  bought a new pc (i9900k, 32 GB RAM, Nvidia 2060 OC 6 GB, m.2 1 TB)

The first month after installing Premiere was a nightmare. Laggy, slow, blue screen!. I tried everything from here and from youtube.

Well, the problem was not the pc or adobe, but the codecs of the videos in my iPhone XR.

Change settings on your phone from .mov to mp4  for the future. Pass your current videos through media encoder, create a new format. I used DNXHR. Use these videos in mp4 format. It goes really smooth. Hope it helps.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 14, 2019 Nov 14, 2019

Copy link to clipboard

Copied

Deactivate the voice dictation in macOS preferences work for me (illustrator 2020, macos Mojave, macbook pro 2019)

 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 03, 2020 Jan 03, 2020

Copy link to clipboard

Copied

I solved the problem, On Workspace setting change "Essentials" to "Layout" or others !

capturejpg.jpg

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 18, 2020 Feb 18, 2020

Copy link to clipboard

Copied

That worked for me as well. This is clearly a well-documented problem with an extremely simple fix. I cannot believe they are telling people to turn off iCloud. That did absolutely nothing but changing the setting under Preferences to Layout was all that needed to happen. I am super stoked that Adobe has taken the time to let people know about this solution... oh wait - nope - they haven't. Thank you @deedeecheung for helping us out.

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 18, 2020 Feb 18, 2020

Copy link to clipboard

Copied

double post... 

 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 03, 2020 Mar 03, 2020

Copy link to clipboard

Copied

Hi - Thanks butdidnt work. The change in Workspace from ESSENTIALS to LAYOUT did the trick.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 11, 2020 Dec 11, 2020

Copy link to clipboard

Copied

Thank you! Extremely helpful solution for a really frustrating lag. Grateful!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines