Stroke will not appear on object

Community Beginner ,
Jan 26, 2020

Copy link to clipboard

Copied

I'm runinng Ilustrator CC 23.0.1, and my workflow involves bringing very large vector objects into Illustrator via an SVG from QGIS 2.18.24. Every once in a while, the object I bring in will not appear to have a stroke, but Illustrator will claim it does have one. No matter what I do to manipulate the stroke, including removing and re-adding, changing width, etc., has no effect. It remains without a stroke in appearance. I've ungrouped the path, simplified it, expanded it (when set to no stroke), and made sure it wasn't a compound path. I've restarted Illustrator. None of these things have an effect. However, if I expand it when I have a stroke width set, it will expand properly, showing the outline of the non-existant stroke.

 

There is one intriguing little exception - when there is an extremely sharp corner in the path, a bit of stroke will appear. Strangely the shape of this fragment of corner is not affected by changing the corner, end, or stroke alignment, though it seems like there should be some effect.

 

[EDIT: Apparently the strange bit that did have an outline was an isolated separate bit of stroke, not just a sharp corner.]

 

This has happened before, but I'm against a wall in this case - I don't have a good workflow option to get around it.

 

I'm assuming there is some property in the SVG that is interpreted strangely by Illustrator, and is leading to this bug.  I was wondering if it had something to do with the direction of the stroke, so I reversed that, but no effect there either.

 

I attached a screenshot showing relevant settings in a very zoomed-in section with the strange corner effect.

TOPICS
Bug, Draw and design

Views

2.4K

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

2 Correct Answers

Adobe Community Professional , Jan 27, 2020
Ton Frederiks Adobe Community Professional , Jan 27, 2020
I downloaded your file and it was what I suspected, your stroke had an opacity setting of 0%.

Likes

Translate

Translate
Jump to answer Jump to answer
Community Beginner , Jan 27, 2020
bretwoodh77667362 Community Beginner , Jan 27, 2020
I found a solution! Fiddling with the appearance menu in an attempt to expand what it shows as suggested by Ton_Frederiks, I found that if I click "Clear Appearance" this removes whatever the offending attribute is. So to lay it out for anyone who googles into this thread in the future:Select the offending object.Open the appearance menu (e.g. by going to Window -> Appearance)Click the hamburger (little horizontal lines) at the upper right corner of the Appearance menu, and select "Clear Appeara...

Likes

Translate

Translate
Jump to answer Jump to answer
Adobe Community Professional ,
Jan 27, 2020

Copy link to clipboard

Copied

Hi Bret, what does your appearance panel look like with it selected?

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 27, 2020

Copy link to clipboard

Copied

Looks normal - says there is a stroke:

Screen Shot 2020-01-27 at 1.39.42 AM.png

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 27, 2020

Copy link to clipboard

Copied

can you upload that ai file?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 27, 2020

Copy link to clipboard

Copied

I can't seem to find a way to attach a file to a reply, but I put an example stroke with this issue online here:

http://www.groundtruthtrekking.org/static/uploads/files/Strokeless%20object%20example.aijtndXo/Strok...

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 27, 2020

Copy link to clipboard

Copied

Can you show us the expanded items of the stroke in the Appearance panel?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 27, 2020

Copy link to clipboard

Copied

There is an option in the appearance panel "Show All Hidden Attributes" but nothing happens when I click it. Not sure if that means there aren't any hidden attributes, or if there's some other issue surfacing here...?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 27, 2020

Copy link to clipboard

Copied

There is an option in the appearance panel "Show All Hidden Attributes" but nothing happens when I click it. Not sure if that means there aren't any hidden attributes, or if there's some other issue surfacing here...?

I was curious to see what would be seen when the arrow in front of the stroke item was clicked (maybe an opacity setting of 0%).

The "Show All Hidden Attributes" option turns on the visibility of effects that have been hidden by clicking the eye icon.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 28, 2020

Copy link to clipboard

Copied

Thanks Ton_Frederiks, now I see what you mean. I was not aware of the controls allowing separate control of the opacity of strokes and fills. So both a solution to my immediate problem, and learned something new that may be useful down the road...

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 28, 2020

Copy link to clipboard

Copied

🙂

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jan 29, 2021

Copy link to clipboard

Copied

Hello Ton,

I tried to do above mentioned things still I am not able to see the stroke for a picture.

I have attached the file here. Any help is really appreciated 🙂

Thank you very much.

Click here for the file 

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 29, 2021

Copy link to clipboard

Copied

Select your image (which is missing btw) 

In the Appearance panel add a thick stroke above the Contents item.

Select the stroke item in the Appearance panel and choose Effect > Path > Outline Object.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 27, 2020

Copy link to clipboard

Copied

I found a solution! Fiddling with the appearance menu in an attempt to expand what it shows as suggested by Ton_Frederiks, I found that if I click "Clear Appearance" this removes whatever the offending attribute is.

 

So to lay it out for anyone who googles into this thread in the future:

  • Select the offending object.
  • Open the appearance menu (e.g. by going to Window -> Appearance)
  • Click the hamburger (little horizontal lines) at the upper right corner of the Appearance menu, and select "Clear Appearance."
  • Assign the stroke and other sytles - in my case the problem was fixed.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 27, 2020

Copy link to clipboard

Copied

I downloaded your file and it was what I suspected, your stroke had an opacity setting of 0%.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 27, 2020

Copy link to clipboard

Copied

thats not really what you should be doing. correct the attributes rather as in opacity. but as long as you are happy.

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more