Acrobat does not follow the page numbers correctly when I export an InDesign file

New Here ,
Aug 02, 2022 Aug 02, 2022

Copy link to clipboard

Copied

Hi everyone, I will do my best to wrap up my question clearly and shortly.

 

I have an InDesign file that has the first 14 pages numbered in Roman numerals. After page XIV, it turns to numbers from Roman numerals and starts with page 1. I am having no problem in page order jumping from a page to another page in InDesign. However, when I export this file as pdf, Acrobat does not differenciate the Latin numerals from numbers. The pdf starts with 1 instead of i, and as a result, the page numbers get messy. Because the first 14 pages are in Roman numerals and they are disregarded by Acrobat, when I try to jump to page 18 for instance, it jumps to 4. And if I try to jump to page 5, it carries me to page v, instead of 5. Our design team also tried to export the same InDesign file. Even all of our export settings are perfectly the same, some succeeded to have the Acrobat follow the correct order and some had the same issue as mine. I added some screenshots with my notes in order to represent the situation visually.

 

Looking forward to hear if anybody knows why this is happening and how I can fix it.

 

Cheers!

TOPICS
Import and export

Views

136

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 02, 2022 Aug 02, 2022

Copy link to clipboard

Copied

Hi @oykubetul ,

when I create two sections in my Page panel in InDesign, the first one with roman numerals, the second one with latin numerals beginning with number 1 and export the PDF to PDF (Print) with a PDF/X-4 preset I see no issues with the numbering in Acrobat Pro or Adobe Reader. Tested with InDesign 2022 version 17.3.0 on Windows 10:

 

TwoSections-1-10 and 11-40-InDesign-PagePanel.PNG

 

TwoSections-1-10 and 11-40-Opened-with-AcrobatPro.PNG

 

Attached the InDesign document and the exported PDF.

Don't know what's going wrong on your side.

 

Regards,
Uwe Laubender
( Adobe Community Professional )

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 02, 2022 Aug 02, 2022

Copy link to clipboard

Copied

This. You have to use sections to break out different page numbering schemes, such as i-xvi for front matter and then 1-240 for body pages.

 

It sounds as if you used some other scheme, maybe even manual numbering? PDF doesn't know anything about text-number, only logical, automatic numbering.

 

|| Word & InDesign to Kindle (& EPUB): a Professional Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 02, 2022 Aug 02, 2022

Copy link to clipboard

Copied

One thing I noticed in your screen grabs is that you do not have "use logical page numbers" turned on in your Acrobat.

You SHOULD be seeing something like this when exported from ID:

Screen Shot 2022-08-02 at 2.03.02 PM.png

 Go to Preferences > Page Display > Use logical page numbers

 

see if this makes a difference

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 02, 2022 Aug 02, 2022

Copy link to clipboard

Copied

Hi Brad, Should it be checked or unchecked? I have it checked in my example

 

EDIT: Nevermind I read too fast, I can see you suggested it should be checked

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 02, 2022 Aug 02, 2022

Copy link to clipboard

Copied

Actually, that's an interesting question. Are "logical" page numbers the underlying sequence, or the ones assigned by sections? 🙂

 

|| Word & InDesign to Kindle (& EPUB): a Professional Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 02, 2022 Aug 02, 2022

Copy link to clipboard

Copied

I think unchecking Use logical page numbers is the same as InDesign’s Absolute page numbering preference

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 02, 2022 Aug 02, 2022

Copy link to clipboard

Copied

" it should be checked"

Yup.

 

Here's the difference on my sample booklet.

Screen Shot 2022-08-02 at 8.32.51 PM.png

 (Note: if you change the chebox, it doesn't change "live; you need to close and reopen the file for it to take effect)

If using either option is not changing it for you, I don't know what it is when you are exporting the file that's fouling it up for you.

In which case, you should look at the change page labels function of Acrobat, as others have mentioned. Just know that the "logical page number" setting will affect how those are displayed as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 02, 2022 Aug 02, 2022

Copy link to clipboard

Copied

Hi @oykubetul , Also, you can set the Acrobat page labels in the Page Thumbnails panel—choose Page Labels... from the drop down:

 

Screen Shot 26.png

 

You can select a page range and set the Page Numbering

 

 

Screen Shot 27.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 03, 2022 Aug 03, 2022

Copy link to clipboard

Copied

LATEST

Hi Brad and Rob,

after inspecting the first screenshot a little closer I definitely can see two sections in the visible pages of the document of @oykubetul :

 

NumberingIssues-OP-Screenshot-DetailsPlusComments.png

 

The numbering seems to be alright as far as I can tell.

What's a bit odd is page xiv that seems to be in landscape mode and the [1] on the next page.

Also that this document is not a facing-pages document.

 

Regards,
Uwe Laubender
( Adobe Community Professional )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines