Actual size is not the actual size, and there is no way to set it right

Contributor ,
Aug 28, 2018 Aug 28, 2018

Copy link to clipboard

Copied

Here is the situation

Dell 31.5 inc 4K monitor (actual PPI - 139.87)

Windows 10 - UI scale 150% (scaled PPI - 139.87/1.5 = 93.2)

Now

Acrobat Pro takes into consideration the OS UI scale, therefore, the resolution is set to custom 93 PPI.

Then 100% show the real-life print size

Photoshop doesn't take into consideration the OS scaling (for the actual canvas not for the UI) therefore the screen resolution is set to 139.87 PPI.

Then 100% show, the true-pixel size, and "View>Print size" show it in real-life size which in my case is 46.33% of 300DPI document.

Indesign don't have any of the options and set the screen to actual size just put it on 100% which is not the real-life size.

I have to change the Zoom Level to 97% the have it close to the real size.

I think it is a huge problem for a program that is only used for print.

Why don't we have a place to set hour own custom PPI. you should be ashamed this so basic

Ziv

Views

10.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Aug 28, 2018 Aug 28, 2018
I think it is a huge problem for a program that is only used for print.
Starting with CS6 InDesign changed the 100% view to actual print size. Prior to CS6 it was the same as Photoshop's 1:1 monitor to image ratio. On OSX there is no preference for changing the UI scaling, so by default 100% or Actual Print size is always accurate. Sounds like the UI scaling with Windows interferes with the 100% view as actual print size.There isn't a custom resolution setting in the preferences UI, but there is ...

Likes

Translate

Translate
Adobe Community Professional ,
Aug 28, 2018 Aug 28, 2018

Copy link to clipboard

Copied

If you have the UI scaling set to 150% you need to set your preferences to enable UI scaling.

And I take great issue with your statement that InDesign is only used for printing. That is an outrageously incorrect statement.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Aug 28, 2018 Aug 28, 2018

Copy link to clipboard

Copied

Well it is a pagination tool so whatever people doing with it it's their own issue but let's leave it aside

Since I describe my monitor and OS I thought it will be obvious that I set Indesign UI scaling to fit the same scaling.

With that said your point has no logic because as it says "UI Scaling" therefore only UI is scaled.100% is the same either way.

So we back at step one which is 100% not showing the real-life document size

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 28, 2018 Aug 28, 2018

Copy link to clipboard

Copied

I think it is a huge problem for a program that is only used for print.

Starting with CS6 InDesign changed the 100% view to actual print size. Prior to CS6 it was the same as Photoshop's 1:1 monitor to image ratio. On OSX there is no preference for changing the UI scaling, so by default 100% or Actual Print size is always accurate. Sounds like the UI scaling with Windows interferes with the 100% view as actual print size.

There isn't a custom resolution setting in the preferences UI, but there is one in the scripting API—I'm not sure why it hasn't been added to the UI.

So if you want to manipulate the custom monitor res it can be done via javascript

var customRes=93.2

app.generalPreferences.customMonitorPpi = customRes;

app.generalPreferences.useCustomMonitorResolution = true;

This sets the res back to the default:

app.generalPreferences.customMonitorPpi=app.generalPreferences.mainMonitorPpi;

app.generalPreferences.useCustomMonitorResolution = false;

For more on the change from 1:1 ratio as 100% to actual print size as 100% check this thread

Re: InDesign CS6 resolution for pixel documents not the same

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Aug 28, 2018 Aug 28, 2018

Copy link to clipboard

Copied

WOW !!!

Man, Amazing answer - solved it

Just want to say that the correct value was my true display dpi (139.87)

which means that it is not the OS scaling to blame just InDesign who somehow read my hardware wrong, or maybe my screen gave him the wrong information. put on start script to load by default

Anyway thank you for your help

Since you seem like a Pro User any chance to get help with illustrator scaling issues?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 28, 2018 Aug 28, 2018

Copy link to clipboard

Copied

Just want to say that the correct value was my true display dpi (139.87)

which means that it is not the OS scaling to blame just InDesign who somehow read my hardware wrong

If you want to check what your system is returning to InDesign for the main monitor res, then run this script:

app.generalPreferences.customMonitorPpi=app.generalPreferences.mainMonitorPpi;

alert("Main Monitor Res: "+app.generalPreferences.mainMonitorPpi);

Since you seem like a Pro User any chance to get help with illustrator scaling issues?

Illustrator uses the same 1:1 monitor to image ratio that Photoshop does—100% is not an actual print size preview.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 29, 2018 Aug 29, 2018

Copy link to clipboard

Copied

Illustrator works the way ID did before CS6, so you can calculate the print view by dividing your screen res by 72. Put this script in your AI scripts folder and it will show in the File>Scripts menu. The path to the scripts folder is /Applications/Adobe Illustrator CC 2018/Presets.localized/en_US/Scripts—you have to restart AI. Unfortunately I don't see a way to add a key command to it—InDesign's Scripting panel is much easier to deal with.

var printView = 139.87/72

app.documents[0].views[0].zoom= printView;

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 21, 2019 Nov 21, 2019

Copy link to clipboard

Copied

Actually, there is a way to display a document in InDesign at what I call “true actual size”, which means if you lay an 8.5x11 sheet of paper over the display of an 8.5x11 page, they will be the same size. Here is what I posted in previous years (last time was 2014), but apparently that has been culled with time. I have updated it for InDesign CC 2020 (Version 15).

 

How to display at true actual size (Mac)

November 21, 2019

 

The solution to achieving "true actual size" is a script written by Dave Saunders (and probably others) some time ago, If you're like me and don't really use scripts, here is what to do with it on a Mac (with apologies to Dave and other experts who know a helluva lot more about this than I do):

 

1. Copy the text for this script:

 

//by Dave Saunders. Replace the percentage number with the correct value for your screen

app.layoutWindows[0].zoomPercentage = 113;

 

2. Paste it into a text file (I used TextEdit) and leave the file open. You will save it later.

 

3. Go to Acrobat Pro>Preferences>Page Display and under Resolution note the number associated with "Use system setting". (On my system it is 81 pixels/inch. Note that enabling that setting also makes Acrobat display at true actual size. However, there is a long-standing bug with Acrobat that can make Acrobat slow to an agonizing crawl with multi-page PDF files when using this setting, so I use “Custom Resolution” as my default unless I need true actual size.)

 

4. Divide the number from Acrobat by 72, then multiply by 100. (This is essentially a percentage calculation of system resolution over the conversion value of 72 points/inch, which produces 112.5 in my example. I rounded it to 113.)

 

5. In the open text file, change the number 113 to what you got from the above step.

 

6. Save the file with the name “True actual size.jsx” to this location:

 

Users/[username]/Library/Preferences/Adobe InDesign/[version]/[language]/Scripts/Scripts Panel

 

Note that the file extension must be .jsx

  

7. Test the script in an open InDesign document by going to Window>Utilities>Scripts, then click on User and double click on your script. The display should now show your work at true actual size.

 

8. The Scripts panel is awkward at best, so the last step is to assign a keyboard shortcut to your script. I use Control-1. Go to Edit>Keyboard Shortcuts… and choose Scripts in the Product Area menu. Scroll down to the bottom, where you should see your script listed. Highlight it and enter Control-1 (or whatever you prefer) into the New Shortcut window and click Assign. Then click Save. (You won't be allowed to modify the Default set, but I just went with "Default copy”.)

 

Now whenever you want to view your work at true actual size, just hit Control-1 (or whatever you chose for a keyboard shortcut).

 

You might want to copy these instructions into a TextEdit file and save it where you will find it when the time comes to upgrade InDesign CC again, because it’s likely that you’ll need to achieve true actual size all over again.

 

Lastly and far from least, thank you for the script, Dave! If you or other pros come across this and see corrections or improvements, please set me straight.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 06, 2022 Jun 06, 2022

Copy link to clipboard

Copied

I'm currently using the latest version of InDesign: v 17.2.1.105, and this is the first time I've ever had the "actual size" (meaning the menu choice under View) NOT be the same as the actual size as measured with a ruler against the screen. Actual width of an 8.5" wide document is "actually" 10.5" by measurement. It's a fairly easy workaround, but for an application that is designed to produce documents from print, you'd think this bug would be fixed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 14, 2022 Jun 14, 2022

Copy link to clipboard

Copied

I'm also suddenly having this same problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 14, 2022 Jun 14, 2022

Copy link to clipboard

Copied

LATEST

Hi John, if your problem is the same as mine was, I fixed by going into Preferences (without a document open, so that the changes apply universally) and setting the User Interface Scaling slider up or down, depending on how your screen is drawing. My screen was drawing "Actual Size" at about 120% of actual size, as measured by a ruler against the monitor. So I moved the slider down (left) to the smallest setting, as you can see on this screen shot, and that fixed the problem. I suppose if your version is drawing Actual Size too small, then you should push the slider up (to the right). If smallest is still too big then I'm at a loss. 🙂 Hope that helps!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines