• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
3

Agh! Why does "use typographer's quotes" turn off all the time?!?!

Contributor ,
Dec 21, 2023 Dec 21, 2023

Copy link to clipboard

Copied

Just drives me crazy. Randomly "use typographer's quotes" in preferences... type... unchecks itself.

No clue why, but every time it does I get errors that have to be hunted down my hand. Someday something is going to go to print without typographers quotes.

Why does it happen?

Is there some keyboard shortcut that I'm unaware of that I keep accidentally hitting?

None of my other preferences change willy-nilly, why this one?

Any suggestions would be appreciated.

N.

TOPICS
Bug , Performance , Type

Views

370

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Dec 23, 2023 Dec 23, 2023

Totally guessing, but there is an obscure keyboard shortcut to Toggle Typographer's Quotes preference: 

macOS: Cmd+Option+Shift+' 

Windows: Ctrl+Alt+Shift+'

Votes

Translate

Translate
Community Expert ,
Dec 21, 2023 Dec 21, 2023

Copy link to clipboard

Copied

Some preferences are application wide, meaning the preferenec selection is remembered for all document. Some are document specific, meaning the preference can be different for different documents. Use Typographer’s Quotes is a document specific preference. So if you turn it on in one file it will only affect that file. If you turn iot on or off while no files are open then you will set the preferene or all new files.

 

I suspect the reason you are seeing the preference turn on and off is because you are seeing the option in different files.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 21, 2023 Dec 21, 2023

Copy link to clipboard

Copied

Hi @nealbridgens , Also, if you close all documents and check Preferences > Use Typographer's Quotes it will become the default setting for any new documents you create. If there are documents open when you change the Use Typographer's Quotes setting it becomes the setting for the front document only—all other documents keep their individual preference settings.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 22, 2023 Dec 22, 2023

Copy link to clipboard

Copied

A setting becomes an application setting when applied with no documents open, as Scott and Rob mention, but it is set as an application setting only when you quit InDesign. If InDesign quits unexpectedly (crashes), the setting is lost.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 22, 2023 Dec 22, 2023

Copy link to clipboard

Copied

If you inherit an InDesign document with straight quotes you can use the Edit > Find/Change  Query Preset to change them  to typographer's quotes.

Screenshot 2023-12-22 at 10.01.37.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 22, 2023 Dec 22, 2023

Copy link to clipboard

Copied

Someday something is going to go to print without typographers quotes.

 

Also, even when you change the Use Typographer’s Quotes preference for the active document the preference change only gets applied to future edits, so your document could have an unintended mix of straight and curly quotes.

 

As Derek suggests you might have to do a Find/Change to convert all the straight quotes in a document. The preference has to act this way because you might have a document where you want to use straight quotes or italicized straight quotes for inch or foot marks (in cases where the text font doesn‘t include actual prime glyphs), so a global find and change might not always work.

 

If your document doesn’t need both, it would be possible to script the changing of the preference for the the application, the open documents, along with a find and change.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 22, 2023 Dec 22, 2023

Copy link to clipboard

Copied

All good information. Thanks everyone. 

I only work with indesign documents created on two Macs, no outside indesign files coming in. Both are set to Typographer's Quotes on at the application level.

It feels like it get's turned off sporadically. Not from me selecting to turn it off. 

It's one of those things I want to have "just work" and not have to be constantly second guessing (or worse yet discovering its not been working late in a job).

I can't be alone in this? I really am suspicious of a key command that I trip accidentally but haven't been able to find one. Is there any other circumstance beyond going into setting that can change it to off?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 22, 2023 Dec 22, 2023

Copy link to clipboard

Copied

It feels like it get's turned off sporadically. Not from me selecting to turn it off.

 

Do you run any plugins or startup scripts?

 

You could force the application preference and all of the open document preference via a script—something like this:

 

 

app.textPreferences.typographersQuotes = true
var d = app.documents.everyItem().getElements()
if (d.length > 0) {
    for (var i = 0; i < d.length; i++){
        d[i].textPreferences.typographersQuotes = true;
    };   
} 

 

 

 

If you are having problems with documents containing both straight quotes and curly quotes you could include a find and change in the script, but you want to be careful with cases where you intentionally use straight quotes for primes (feet and inches):

 

 

app.textPreferences.typographersQuotes = true
var d = app.documents.everyItem().getElements()
if (d.length > 0) {
    for (var i = 0; i < d.length; i++){
        d[i].textPreferences.typographersQuotes = true;
    };   
    textSearch("^\"","\"")
    textSearch("^\'","\'")
} 

function textSearch(f,c){
    app.findTextPreferences = app.changeTextPreferences = app.findChangeTextOptions = null;
    app.findChangeTextOptions.properties = {includeHiddenLayers:true, includeLockedLayersForFind:true, includeLockedStoriesForFind:true, includeMasterPages:true} 
    app.findTextPreferences.findWhat = f;
    app.changeTextPreferences.changeTo = c;
    app.changeText( true )
}

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 22, 2023 Dec 22, 2023

Copy link to clipboard

Copied

You cannot set Use Typographers Quotes at the application level. It is a document level preference.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 22, 2023 Dec 22, 2023

Copy link to clipboard

Copied

I feel like I'm not getting across what I'm talking about. 
Today I was working on a document that yesterday had typographer's quotes turned on and when I typed a quote it came out as a proper curly quote. When I typed a quote today it was a straight quote. I had not changed the preferences. When I opened the preferences use typographers quotes was unchecked. 
I'm the only one who uses the document and it was on the same computer. Single document, nothing to do with application level/vs document level preferences. 
No startup scripts or plugins.
I guess what I'm really asking (for starters) is, does this happen to anyone else?

I must be doing something that turns it off, but I'll be damned if I know what. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 23, 2023 Dec 23, 2023

Copy link to clipboard

Copied

When I opened the preferences use typographers quotes was unchecked

 

So when it happens if you close all documents, is the preference still unchecked (the application default has also been changed)?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 23, 2023 Dec 23, 2023

Copy link to clipboard

Copied

LATEST

I'll check when next it happens. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 23, 2023 Dec 23, 2023

Copy link to clipboard

Copied

Maybe there's some corruption in the document. Export it to IDML, then open the IDML in InDesign and save it (under a different name to be on the safe side). See if that makes a difference.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 23, 2023 Dec 23, 2023

Copy link to clipboard

Copied

Totally guessing, but there is an obscure keyboard shortcut to Toggle Typographer's Quotes preference: 

macOS: Cmd+Option+Shift+' 

Windows: Ctrl+Alt+Shift+'

Mike Witherell

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 23, 2023 Dec 23, 2023

Copy link to clipboard

Copied

Ah! Mike! Now we're talking. 
That seems like the kind of thing I'd hit. 
wonder what I'm doing over there… trying to turn guides on and off like I'm in illustrator perhaps?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines