All text red squiggle underlines

Community Expert ,
Jun 22, 2020 Jun 22, 2020

Copy link to clipboard

Copied

I'm working on a long document that I brought in from Word. I just placed it. Most of the text has the red squiggles. If I retype the text, it goes away. Makes it impossible to find real errors. Everything is set to English - I did have one paragraph style oddly set to Arabic, but I fixed it. I tried another suggestion of saving as a .idml but that didn't work. Any ideas?

Screen Shot 2020-06-22 at 12.46.52 PM.png


Melissa Piccone | Adobe Trainer | Pluralsight Author | Fine Artist
TOPICS
How to

Views

2.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Jun 24, 2020 Jun 24, 2020

Hey Melissa:

 

I looked at the file and it's definitely an overrides issues. For example, all of the styles on page 22 are using multiple overrides, including Arabic for the language.

 

You will need to update one paragraph, redefine the style, then select all and use the clear overrides button to remove the overrides on the other paragraphs. Note that on page 22 the style is called Body (it seems like those paragraphs are labels or heads) so pay attention to what else changes when you redefine

...

Likes

Translate

Translate
Community Expert ,
Jun 22, 2020 Jun 22, 2020

Copy link to clipboard

Copied

Seems like spell check. Try Edit>Spelling>Dynamic Spelling and disable it

 

-Manan

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 22, 2020 Jun 22, 2020

Copy link to clipboard

Copied

Yes, it's spell check but why is it doing this? I don't want to just disable it, it's wrong, I want it to work correctly. There is something else that happend that is totally bizarre - I can't type an apostrophe. Throughout the text there are quotes, but no apostrophes. They are all represented with > but not really, it's like a special character that is not quite > and when I try and replace with an ' apostrophe, it literally just types the > character again. I am losing my mind with this project and it's a trade - not getting paid.


Melissa Piccone | Adobe Trainer | Pluralsight Author | Fine Artist

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Jun 22, 2020 Jun 22, 2020

Copy link to clipboard

Copied

"...when I try and replace with an ' apostrophe, it literally just types the > character again..."

Check out the paragraph overrides

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 22, 2020 Jun 22, 2020

Copy link to clipboard

Copied

Yeah, something really weird happening there. I'm working on it, think I solved it. Now for the dynamic spelling issue...


Melissa Piccone | Adobe Trainer | Pluralsight Author | Fine Artist

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Jun 22, 2020 Jun 22, 2020

Copy link to clipboard

Copied

I think if you select your paragraph that is still arabic language applied in language menu

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 22, 2020 Jun 22, 2020

Copy link to clipboard

Copied

Could be a Character Style that has a different language that is applied together with the Paragraph style. Set the cursor in the text, then holding down Alt and Shift click on the correct style name in the Paragraph styles panel to delete all overrides and character styles. Does that fix things?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 22, 2020 Jun 22, 2020

Copy link to clipboard

Copied

Nope. No character styles applied, either. The original document is a mess in Word. I don't know how to use word very well. 


Melissa Piccone | Adobe Trainer | Pluralsight Author | Fine Artist

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Jun 22, 2020 Jun 22, 2020

Copy link to clipboard

Copied

Can you share one page of your indesign file, with a couple of paragraphs, as in your screenshot, with us?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 22, 2020 Jun 22, 2020

Copy link to clipboard

Copied

If the styles are set correct and the final language set is English then i suspect the document is corrupted. If IDML export is also not correcting it, things may be risky. Did you try to copy over the content from this document on to a new one and then see if the problem still persists. If it does then it should be something in the settings, if it does not then maybe the corruption theory is right. Anyways if you could share the document, we could brainstorm more on that

 

-Manan

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 22, 2020 Jun 22, 2020

Copy link to clipboard

Copied

The language of your text is not English. Language is used to determine the correct hyphenation dictionary and spelling dictionary. Incorrectly spelled words are highlighted. Your English language words are not words in the selected language. Check the Language section in the Character panel. If you are using Paragraph Styles make sure the language is English (and the correct English).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 23, 2020 Jun 23, 2020

Copy link to clipboard

Copied

Melissa, you can email me the file.

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 24, 2020 Jun 24, 2020

Copy link to clipboard

Copied

Hey Melissa:

 

I looked at the file and it's definitely an overrides issues. For example, all of the styles on page 22 are using multiple overrides, including Arabic for the language.

 

You will need to update one paragraph, redefine the style, then select all and use the clear overrides button to remove the overrides on the other paragraphs. Note that on page 22 the style is called Body (it seems like those paragraphs are labels or heads) so pay attention to what else changes when you redefine style/clear overrides if Body is in use on the other pages.

 

~Barb 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 24, 2020 Jun 24, 2020

Copy link to clipboard

Copied

Whew... that was a challenge. So I selected all, cleared overrides. These overides were not showing up in the paragraph panel. That fixed about 70% of it. Then I had to go in and break link to style and reselect the style. That fixed the rest of them. And some, like Barb said, I had the wrong styles applied but it looked correct. I literally applied all styles by hand, one page at a time so not sure how that happened. I finished this project and I'm hoping there will never be changes or updates because fixing everything adjusted the layout which will take a while to fix. Thanks all for your help. 


Melissa Piccone | Adobe Trainer | Pluralsight Author | Fine Artist

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 22, 2022 Aug 22, 2022

Copy link to clipboard

Copied

Two years too late, but had the same issue today and I found that under conditional text Indicators was turned on to show. The squiggles went away when I changed to hide. That might not have fixed this but for anyone else looking that could be the issue. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 22, 2022 Aug 22, 2022

Copy link to clipboard

Copied

LATEST

Hi @Brad66:

 

This can be confusing—InDesign uses red squiggles to indicate words not recognized by the assigned dictionary and green swiggles to indicate duplicate words, uncapitalized sentences, etc. This is called Dynamic Spelling and was the issue in Melissa's situation (she sent me the file).

 

InDesign uses lines (wavy, solid or dashed) as a condition indicator. If someone were to choose wavy lines and use red or green they will look exactly like the Dynamic Spelling indicators. Seems like an excellent reason never to choose red or green for condition indicators!

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines