Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Alternating Row Fills is not Working

New Here ,
Jul 06, 2017 Jul 06, 2017

Copy link to clipboard

Copied

When I create a table and go to table options for alternating pattern, I will select every other (or any other pattern) and it defaults back to none.

It used to work just fine, but doesn't anymore.  Indesign CC 2017 - latest upate.

Does anyone else have this problem?

thanks!

Views

5.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Aug 13, 2018 Aug 13, 2018
Here's the solution: In all 'Cell Styles' in which you want to have alternating fills, set the 'Fill' color to '(Ignore)'. '(Ignore)' appears at the bottom of the swatch list. Then go into 'Alternating Fills' and adjust as desired.

Likes

Translate

Translate
Adobe Community Professional ,
Jul 06, 2017 Jul 06, 2017

Copy link to clipboard

Copied

Have you tried deleting your preferences?

To do so:

For Macintosh Users: With InDesign closed launch a Finder Window in column view and click on your home folder. With the Option Key pressed choose Library from the Finder Go Menu. Within the Library folder find the following two files and delete them: “Adobe InDesign” and “com.adobe.InDesign.plist”. When InDesign is next launched it will create new preference files and the program will be restored to its defaults.

After you’ve reset up the program (make sure that no document window is open) to your liking, it is a really good idea to create copies of your personalized “mint” preference files (make sure that you quit the program before copying them—that finalizes your customization) and use them in the future to replace any corrupt versions you may need to delete.

For Windows Users: Hold down Ctrl + Alt + Shift when launching InDesign and respond affirmatively when asked if you want to reset.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 29, 2017 Dec 29, 2017

Copy link to clipboard

Copied

https://forums.adobe.com/people/Bill+Silbert  wrote

Have you tried deleting your preferences?

I search my computer for "com.adobe.InDesign.plist" and there is no file with this name. I deleted any file that ends .plist and included "InDesign", but this was not a solution.@

Searching for a file named "Adobe InDesign" only brings up folders and not a delete-able file.

After 4 hours of looking online for solutions, removing or breaking all table and cell styles to, clearing overrides, clearing attributes not defined by style, down-saving to ID 17, creating a .IDML file and reopening and saving a the file... I've decided impossible to create a chart, in InDesign, with alternating row fills, automatically. You have to select each row and coloring it manually. Really bites the big one!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 29, 2017 Dec 29, 2017

Copy link to clipboard

Copied

Sorry. That version of the deleting preferences (which I fixed months ago) had a typo which omitted the place where those files could be found on a Mac (The preferences folder). The corrected version is:

With InDesign closed Launch a Finder Window in column view and click on your home folder. With the Option Key pressed choose Library from the Finder Go Menu. Within the Library folder find the folder called Preferences and within it find the following two files and delete them: “Adobe InDesign” and “com.adobe.InDesign.plist”. When InDesign is next launched it will create new preference files and the program will be restored to its defaults.

I'm also including a screen shot to be extra clear:

Screen Shot 2017-12-29 at 6.17.25 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 29, 2017 Dec 29, 2017

Copy link to clipboard

Copied

I did find the files after deleting files and restarting ID. I deleted the newly create ID files. Rebooted my computer and restarted ID. It isn't fixing the problem. I've set up Table and Cell Styles, and still cannot create a chart with Alternating Row Fills. For some reason, a cell style is removing any Alternating Row specification.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 29, 2017 Dec 29, 2017

Copy link to clipboard

Copied

Now that I have colored each row alternatively on a chart with 150 rows, InDesign has decided to crash my file when I edit text in this chart. I even saved the file as an .imdl file and reopened and saved it!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 29, 2017 Dec 29, 2017

Copy link to clipboard

Copied

Armadillo77  wrote

For some reason, a cell style is removing any Alternating Row specification.

Cell attributes always win over table attributes.

If you have Fill settings as a cell style, you will need to delete that setting from the cell styles if you want to see the settings you set for the entire table.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Dec 29, 2017 Dec 29, 2017

Copy link to clipboard

Copied

Cells Settings, Rows settings - overrides table settings (like CSS in HTML)

Be sure your table is prepared without any fills.

Use fills only from Alternating settings of your table

pawel

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 13, 2018 Aug 13, 2018

Copy link to clipboard

Copied

@jane-e This is what I'm seeing too. As soon as I deleted the cell style, my row fills worked as expected. That is a failure on Adobe's part. Cell styles are supposed to be integral to table styles, but instead they usurp them.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 13, 2018 Aug 13, 2018

Copy link to clipboard

Copied

That's incorrect. As pointed out, cell styles take precedent, the same way character styles will override paragraph setting.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 13, 2018 Aug 13, 2018

Copy link to clipboard

Copied

BobLevine​​, Table style setup calls for preset cell styles, but when I use those cell styles, the table styles get overridden. That's not very logical.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 13, 2018 Aug 13, 2018

Copy link to clipboard

Copied

markh16894458  wrote

BobLevine , Table style setup calls for preset cell styles, but when I use those cell styles, the table styles get overridden. That's not very logical.

Hi markh16894458,

I respectfully disagree.

Microsoft Word works the same way. Although Word does not have table and cell styles, all cell formatting "wins" over table formatting. This is logical. First you format your table. Then you format any cells that are different.

If you use the Table feature of Excel, again, it is the same. You can do Table formatting, but if you do local formatting in addition to the Table formatting, the local formatting *wins".

Can you think of one application where it is the opposite?

Anyway, regardless of what any of us thinks, all we can tell you is how InDesign is programmed. This is a user forum, and except for those with the red STAFF badge, the rest of us are volunteers.

I hope this helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 13, 2018 Aug 13, 2018

Copy link to clipboard

Copied

Here's the solution: In all 'Cell Styles' in which you want to have alternating fills, set the 'Fill' color to '(Ignore)'. '(Ignore)' appears at the bottom of the swatch list. Then go into 'Alternating Fills' and adjust as desired.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 14, 2018 Aug 14, 2018

Copy link to clipboard

Copied

JebusRidesUnicorns​, that's a very clever thing you've pointed out. I've never seen that in the list before. I think that does solve the problem. It allows me to set other cell properties without affecting the color. Thank you all for your input!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 13, 2021 Apr 13, 2021

Copy link to clipboard

Copied

LATEST

THANK YOU

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines