• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Apostrophe displaying incorrectly in InDesign

Explorer ,
Jun 21, 2022 Jun 21, 2022

Copy link to clipboard

Copied

I have basic InDesign skills but nothing advanced. I'm creating a document and whenever I type an apostrophe (') InDesign displays it as a tiny greater than symbol. It does this no matter what font I'm using. I can type the same text in Illustrator and it looks fine. If I then paste it into InDesign it is correct. But if I type it directly into InDesign it never displays as an apostrophe.

 

I've tried checking my character and paragraph settings and tried multiple fonts to no avail. Any guidance would be much appreciated!

TOPICS
Type

Views

7.0K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Jun 22, 2022 Jun 22, 2022

Hi Tom,

select the character and look it up in the Glyphs panel.

Hover your cursor over the glyph in the Glyphs panel. What is the name of that glyph?

APOSTROPHE ?

 

Could be that the language fromatting of the text is set to [No Language]. I tested this:

Apostrophe-vs-RightSingleQuotationMark.png

 

If your language for the text is set to e.g. English: USA and this still happens, look up your settings under Typographer Quotes in the Preferences.

Preferences > Type > Type Options >

[ x ] Use Typographer's Quotes

 

Make sure Use Typograph

...

Votes

Translate

Translate
Community Expert ,
Jun 21, 2022 Jun 21, 2022

Copy link to clipboard

Copied

A screen shot would help...

When you highlight the text, waht language is applied?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 21, 2022 Jun 21, 2022

Copy link to clipboard

Copied

Also, check your preferences under dictionary to see what type of quotation marks are specified...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 21, 2022 Jun 21, 2022

Copy link to clipboard

Copied

  1. Language correct 
  2. preferences > Dictionary > Each language and language flavor has to be selected for correct apostrophe  

 

Be aware, microtypography is in every country different. E. g. Germany and Austria haven the same rules for their German, but Switzerland has different. 

But be also aware, InDesign uses always the single closing apostrophe for the missing letter symbol, which should always be like a comma up. But in German or French it is not. I have written a find & replace to repair it at the end. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 22, 2022 Jun 22, 2022

Copy link to clipboard

Copied

Hi Tom,

select the character and look it up in the Glyphs panel.

Hover your cursor over the glyph in the Glyphs panel. What is the name of that glyph?

APOSTROPHE ?

 

Could be that the language fromatting of the text is set to [No Language]. I tested this:

Apostrophe-vs-RightSingleQuotationMark.png

 

If your language for the text is set to e.g. English: USA and this still happens, look up your settings under Typographer Quotes in the Preferences.

Preferences > Type > Type Options >

[ x ] Use Typographer's Quotes

 

Make sure Use Typographer's Quotes is selected when the document is open.

This preference is a document preference; it could vary from document to document!

 

Regards,
Uwe Laubender
( Adobe Community Professional )

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 13, 2023 Mar 13, 2023

Copy link to clipboard

Copied

this worked! thank you so much.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 01, 2023 May 01, 2023

Copy link to clipboard

Copied

LATEST

Is there also a solution where I can keep the language? This is very difficult. This should not happen with Adobe ...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 22, 2022 Jun 22, 2022

Copy link to clipboard

Copied

There is lots of good advice in this thread, but I wonder what language you are currently set up to type in your operating system. Do you have multiple languages installed? It can be awfully easy to have a secondary language installed and not know it. If you share your OS version, I could tell you exactly where to look to check. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 22, 2022 Jun 22, 2022

Copy link to clipboard

Copied

Hi Joel—thanks for your offer, I am on Windows 10 Pro.

I checked all the other things people suggested in this thread—and yes, a great education for me! I'm set to English-USA in Indesign. Typographer's Quotes is selected for this document. However, I found that in Paragraph Styles for the Normal paragraph style, the language was set to Arabic. Changing it to English-USA solved the problem.

If you would be so kind as to tell me how to check Win10 for language setup I would be appreciate that. 

Thanks!

 

Tom

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 23, 2022 Jun 23, 2022

Copy link to clipboard

Copied

"However, I found that in Paragraph Styles for the Normal paragraph style, the language was set to Arabic."

 

Ah! That's perhaps an indication for a bug with the Word import options.

Could you share details? Did you import a doc or a docx file perhaps?

And could you share the contents of a sample paragraph with the Word document perhaps?

 

Regards,
Uwe Laubender
( Adobe Community Professional )

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 30, 2022 Jun 30, 2022

Copy link to clipboard

Copied

Thanks for your suggestion! I did not import a Word doc. However, I did copy something from OneNote and paste it into the document. This was a new document I was creating based on an old document I'd used. So I ran some tests after resading your note:

  • When I open that document and paste from OneNote with an apostrophe it comes in correctly, and the language is set correctly.
  • When I create a new document now the language is set correctly and text with an apostrophe both pastes correctly from OneNote and shows up correctly when I just type it in.

So it seems to be a mystery. If you have anything else you'd like me to test let me know, I'm happy to do that.

Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 29, 2023 Mar 29, 2023

Copy link to clipboard

Copied

Hi, I have the same problem. Can someone help me out asap? I have a deadline in two days! I tried everything suggested here but nothing seems to work. However, this problem is only there in the indesign file shared by my teammates. When I create a new document from scratch, everything is fine. I would be so grateful if someone could help me out!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 29, 2023 Mar 29, 2023

Copy link to clipboard

Copied

Hi @elisheba ,

I'm not sure if your problem is caused by the ones discussed here.

My suggestion: open a new thread, show some screenshots with the text where hidden characters are showing.

With some text selected and the Language property visible.

 

Hm. Could also be that you and your teammates are using a different version of the applied font.

 

Regards,
Uwe Laubender
( Adobe Community Expert )

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines