Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Automatic hyphens randomly have letters in them

Community Beginner ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

I have never seen this error. There are a few places in a PDF I made from InDesign where an automatic hyphen has another letter superimposed on it. This is not visible in InDesign, only the PDF output. Fonts are fine. I've been making good print-ready PDFs up until now.

I'm going to try uploading screen shots and the PDFs with a comment on an example. If you want to dig into the ID file, I can send you a link to DropBox. I may have to make a support ticket.

 

This is a scan of a page, where the hyphen in "divinely-ordained" has an a over the hyphen.

divinely-ordained has an a on hyphen.png

I worked with this footnote to replace auto with hard hyphens, which of course i cannot do everywhere, and it isn't a problem everywhere....

 

1 Screen shot of ID with two automatic hyphens in footnote 16.

 

1- ID file with automatic hyphens 1.png

Screenshot of PDF with a letter t over a hyphen. Not in ID at all.

2- PDF with t over first hyphen.png

I replaced the first with a hard manual hyphen...

 

3- I put a hard hyphen in line 1.png

   Resulting PDF has t over second hyphen.

4- t over hyphen in line 2.png

 This is obviously terrifying, as I design books that are proofread and checked in great detail, and then I send print-ready PDFs, which, it appears, could have random errors after proofing.  I can't really send print PDFs until this is solved.

Thanks for reading,

Carol

 

TOPICS
Type

Views

145

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jul 20, 2021 Jul 20, 2021
Hi Carol, seen that recently here in the forum. The workaround reported was to use a PDF Export Preset where the feature Tagged PDF is disabled. I cannot recreate the issue with my German InDesign on Windows 10; so please share a sample document, one single page would be enough, where you see the issue. I'd like to test that. Put a document on Dropbox or a similar service and post the link. Thanks, Uwe Laubender ( ACP )

Likes

Translate

Translate
Adobe Community Professional ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

Hi Carol,

seen that recently here in the forum.

 

The workaround reported was to use a PDF Export Preset where the feature Tagged PDF is disabled.

I cannot recreate the issue with my German InDesign on Windows 10; so please share a sample document, one single page would be enough, where you see the issue. I'd like to test that.

 

Put a document on Dropbox or a similar service and post the link.

 

Thanks,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

Thank you Uwe.

I packaged the doc as-is so fonts would be included. You can jump to page xi as I described in the post.

 

https://www.dropbox.com/sh/nouxe0agah4wo3o/AACkAVRkb12oBN4ZfAJDURula?dl=0

 

I can confirm that, at least in this file in this location, a preset without Tagged did give me clean output. Thanks for saving me headaches!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

Found this:

Random character superimposed on hyphen
Pascal Garin, Jan 29, 2021

https://community.adobe.com/t5/indesign/random-character-superimposed-on-hyphen/td-p/11792704

 

Alright: What exactly is the PDF Export preset you used?

Could you share this as well? Save that preset with a custom name if you export to Adobe PDF (Print).

I could guide you to the installed custom *.joboptions files if I know the operating system you are using.

 

Regards,
Uwe Laubender

( ACP )

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

Hi have many many presets made specifically for clients who want certain settings for crop, bleed, slug, preview, etc.

With your input, I used the same preset but I unchecked Tagged PDF.

Screen Shot 2021-07-20 at 3.15.18 PM.png

Attached are two PDFs and the only difference is output with and without that checkbox.

I have to put the joboptions file in the Dropbox folder I shared previously, as I cannot attach it here.

I'm on a Mac, OS 10.14.6, InDesign 16.2.1.

I am not sure what caused this problem to start, as I have been using this same preset for the last 9 months.

 

Thank you,

Carol

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

Thank you very much for the test document!

I can recreate your issue with InDesign 2021 version 16.3.0.24, that's the latest version for now on Windows 10.

Used Adobe PDF (Print) > One of my PDF/X-4 export presets. Turned on Create Tagged PDF, the issue is visible. Turned off Create Tagged PDF, the issue went away. That's no good sign if you want to create a tagged PDF.

 

Now for the reason:

I have to investigate this. But one thing is sticking out: The used paragraph composer!

The "Adobe World-Ready Composer", in my German InDesign named "Globaler Adobe-Absatzsetzer".

 

What would happen, if I change the composer setting from the "Adobe World-Ready Composer" to the "Adobe Paragraph Composer"? Would that change anything? Because the applied paragraph style is based on a paragraph style that itself is based on the [Basic Paragraph Style] where also changes are made from a default that comes with every fresh installed InDesign, I changed the [Basic Paragraph Style]'s composer to the "Adobe Paragraph Composer".

 

That trickled down to the applied paragraph style of the footnote. No change in composition happened immediately.

And yes, that did the trick. I could include PDF Tags with the PDF Export preset and the issue was NOT visible in the exported PDF!

 

To sum this all up:

The issue is a bug in the used "Adobe World-Ready Composer" !

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

Uwe, that's very interesting. I honestly have no idea what "Adobe World-Ready Composer" is but I must have switched to it for this document. I have been experimenting with setting the Language to whatever language the text is in (French, German, Italian) to see if the hyphenation changed from Englih. Perhaps I change to World-Ready Composer, since it sounds so ready for many languages!

 

If you look at the Grep styles for body text and foonote text, you'll see a workaround that I found online for compound adjectives, which are two words with a manual hyphen. My client does not want either word to auto-hyphenate. I was afraid that this workaround was causing the problem, but it seems not.

 

Thank you for all your help. I will fix my documents today!

Carol

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

But this is not the end of the story, I think.

It could be that the applied paragraph style override, the setting for the language where the hyphenation happens, is a contributing factor perhaps.

 

Have to do some more tests…

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

You'd need the "Adobe World-Ready Composer" if you want to set type for Hebrew or Arabic or a mix of that with any other "western" language. There are six paragraph composers available with InDesign CC to cover all international typesetting that is available in InDesign:

 

Adobe Paragraph Composer

Adobe Single-line Composer

 

Adobe World-Ready Composer

Adobe World-Ready Single-line Composer

 

Adobe Japanese Paragraph Composer

Adobe Japanese Single-line Composer

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 21, 2021 Jul 21, 2021

Copy link to clipboard

Copied

Hi Carol,

I did some more tests.

 

There are two overrides on the text with the first incident of that bug:

A character override with language and a paragraph override where Hyphenate Capital Words is enabled.

( Feature Style Overrides Highlighter enabled; the blue underline is indicating character overrides, the blue bar at the outer edge of the text frame is indicating paragraph overrides. )

 

TwoOverridesOnHyphenatedText.png

 

If I create and apply a new paragraph style based on the applied Footnote First style with Hyphenate Capital Words enabled, still the issue is not gone.

 

OneOverrideOnHyphenatedTex-NoParagraphOverridet.png

 

I also have to remove the character override:

NoOverridesOnHyphenatedText.png

 

NoOverridesOnHyphenatedText-ExportedPDF-Acrobat.png

 

So it was the "Adobe World-Ready Composer" plus the paragraph override that enabled Hyphenate Capital Words which caused this issue.

 

Would an applied character style with the language set to "German Reform 2006" help? Also tested this:

NoOverridesOnHyphenatedText-CharacterStyleLanguage-Applied.png

 

The nasty result:

The issue is back again:

 

EDIT: Oh. Just seeing this. The second line is also affected.

There is an "e" stacked over the hyphen now.

 

NoOverridesOnHyphenatedText-CharacterStyleLanguage-Applied-Acrobat.png

 

Regards,
Uwe Laubender

( ACP )

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 21, 2021 Jul 21, 2021

Copy link to clipboard

Copied

Some questions:

Will any paragraph override enforce this hyphenation issue?

( Perhaps not. Unlikely. )

Will any paragraph override with the hyphenation settings enforce this issue?

( More likely. )

Will any character override with language enforce this issue?

( Very likely. I do not think it's "German Reform 2006" only. )

Will any applied character style with language enforce this issue?

( Very likely. I do not think it's "German Reform 2006" only. )

 

Or does it need a combination of things?

 

It's a very nasty bug, because you cannot see it on the InDesign document's pages. Only with PDF Export.

And who doesn't need to enable Tagged PDF these days where accessibility becomes more and more important.

 

I leave all that testing to the developers who should find a fix.

But for that we have to report the bug and advertise for a vote of fixing it at InDesign UserVoice:

https://indesign.uservoice.com/forums/601180-adobe-indesign-bugs

 

Regards,
Uwe Laubender

( ACP )

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 21, 2021 Jul 21, 2021

Copy link to clipboard

Copied

Well, and I can see the bug already with InDesign CS6 version 8.1.0. Just tested that.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 21, 2021 Jul 21, 2021

Copy link to clipboard

Copied

Hi Uwe,

I should have clarified that this occured in other places in the document as well. Places where the German was not applied, nor hyphenate capitals. The errors were marked by my client on their proof in three locations. Two times it occured in the compound adjectives that had the Grep style "No Language No Hyphen" applied, but a third time it occured in a regular auto-hyphenated word. The Grep style was not working correctly, so I fixed it, so those hyphenations were no longer there in subsequent PDFs (so they couldn't show more errors). However, in the third location, the auto-hyphen location, the error did not re-occur, even though I did nothing to fix it. And obviously there are lots of automated hyphens that created no problems, and World Ready Composer was used throughout.   

I am going to upload screenshots of the client proof in the 3 locations and you can compare to the document I sent you, which was after I fixed the Grep style.

In footnote 16, the client wanted the long German word to hyphenate, so I turned on Hyphenate Capital Words in that location only. I only turn that on when there are problems in a paragraph, and I do not want it on globally.

So I was glad to know that the problem was not related to the Grep style or Character style, even though 2/3 of the original errors used that technique.

I have now changed to Adobe Paragraph Composer in all my styles.

 

Screen Shot 2021-07-21 at 10.10.05 AM.png

Screen Shot 2021-07-21 at 10.09.47 AM.png

Screen Shot 2021-07-21 at 10.09.36 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 21, 2021 Jul 21, 2021

Copy link to clipboard

Copied

Hi Carol,

thank you for the screenshots!

FWIW: There is another incident of the bug on page XII that your client did not catch.

First column, line 3.

 

"I have now changed to Adobe Paragraph Composer in all my styles."

That's the best thing you could have done with all this mess!

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 21, 2021 Jul 21, 2021

Copy link to clipboard

Copied

Hi Uwe,

Yes, I did catch that error that they missed, and thanks for your good eyes!

Now I know that World-Ready is only for right-to-left text and I do not need that (yet).

I appreciate your quick help in solving this. I would not have thought about that at all.

Carol

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 21, 2021 Jul 21, 2021

Copy link to clipboard

Copied

What also could contribute: Two hyphens in a row in the same paragraph.

Perhaps also the width of the line of text. I'm not sure…

There is always a new surprise if I am testing on and change parameters.

 

In this sample below I used Carol's text with a different font, I had no first line indent, applied a character style with language "German Reform 2006" to the selected text and finally had two incidents of the bug in a row. First line a "b", second line an "i" stacked over the hyphen:

 

HyphenationBug-2021-Page-8.PNG

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 21, 2021 Jul 21, 2021

Copy link to clipboard

Copied

LATEST

Hi Carol,

found a bug report from Febuary 2019 on InDesign UserVoice where this issue is described.

I voted for fixing the issue, also commented and left a link to this discussen there:

 

PDF Hyphenation Bug when line has cross-reference, hyphenated word, and option is to create Tagged PDF
Sonny Rafael, February 13, 2019

https://indesign.uservoice.com/forums/601180-adobe-indesign-bugs/suggestions/36835285-pdf-hyphenatio...

 

EDITED: Now adding a screenshot by Sonny Rafael who craeted the report.

Screen Shot 2019-02-12 at 5.32.23 PM.png

 

One can clearly see a "u" over that hyphen in "analo- ".

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines