• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Barcode-font 2of5.ttf X InDesign

New Here ,
Jun 11, 2024 Jun 11, 2024

Copy link to clipboard

Copied

The Font 2of5.ttf does not work in InDesign, but it work in Illustrator. How can this be. And how can I fix the problem in InDesign?

TOPICS
Bug

Views

268

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 11, 2024 Jun 11, 2024

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 12, 2024 Jun 12, 2024

Copy link to clipboard

Copied

TTF-Fonts will be supported, so that post about at least Type1-Fonts does not help

 

https://community.adobe.com/t5/indesign-discussions/font-support/m-p/12051424#M430049

On behalf of Adobe, yes, support for TrueType fonts will continue for the indefinite future. As @John Mensinger explains, OpenType, both the CFF and the TTF flavours, are effectively extensions of the original TrueType format in terms of file format.

(Dov Isaacs, former Adobe Principal Scientist (April 30, 1990 - May 30, 2021))

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 12, 2024 Jun 12, 2024

Copy link to clipboard

Copied

I installed the font - and from a another source too

It shows in the menu.

But characters don't show.

 

I've no other explanation - I've tried a lot of things.

 

 

EugeneTyson_0-1718188641347.png

https://helpx.adobe.com/ie/fonts/kb/postscript-type-1-fonts-end-of-support.html

 

 

If it woks in Illustrator
Do it in Illustrator - and then save it to .ai file - then place it in InDesign?

Sorry I don't really have an answer for you.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 19, 2024 Jun 19, 2024

Copy link to clipboard

Copied

Hello Eugene,

 

this font only has Ligatures as characteres (pairs of digits). But inDesign wont recognize them as Ligatures. 

It works in Illutrator, but i need it in InDesign in Datamerging to generate individual codes on vouchers. It has to be this font, because the codes must be readable with our cash register system.

 

So maybe you have an idea how to get indesign to show ligatures?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 19, 2024 Jun 19, 2024

Copy link to clipboard

Copied

I looked to see if it was ligatures - I think I did anyway.

 

I can't get the font to work in InDesign at all.

 

Perhaps 

@rob day @Peter Kahrel 

Might have ideas?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 19, 2024 Jun 19, 2024

Copy link to clipboard

Copied

Hi @beatrix_swh_32049 , Did you check InDesign’s Glyph panel? I can’t check with CC2024 at the moment, but here is CC2021’s Glyph panel, where I can set glyphs and see the Unicodes:

 

bc.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 19, 2024 Jun 19, 2024

Copy link to clipboard

Copied

Thank you for your helbp! Looks nearly same in CC2024 Glyphs Panel. But I can't change anything. Is there a way that InDesign recognizes that two digit are one ligature?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 19, 2024 Jun 19, 2024

Copy link to clipboard

Copied

This is what I get in CC2024—I can access the font’s glyphs from the keyboard via numbers, or I can double-click a glyph in the panel:

 

Screen Shot 15.pngScreen Shot 16.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 19, 2024 Jun 19, 2024

Copy link to clipboard

Copied

Also, looks like you have to have Ligatures on for the insertion point to use the keyboard. Here I’m typing the GID number 33:

 

Screen Shot.pnged3.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 19, 2024 Jun 19, 2024

Copy link to clipboard

Copied

Actually, I’m not sure how the keyboard mapping is working—I’m getting inconsistent results.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 19, 2024 Jun 19, 2024

Copy link to clipboard

Copied

Looks like the glyph panel is ordered from 00 to 99?

 

Screen Shot 1.pngScreen Shot 2.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 19, 2024 Jun 19, 2024

Copy link to clipboard

Copied

Got the clicking the glyph to work sometimes but couldn't get it to work again.

 

I converted the font to another font type also, tried a few, and then it loses the mapping of the characters.

 

It's so strange it works fine in illustrator.

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 19, 2024 Jun 19, 2024

Copy link to clipboard

Copied

LATEST

Make sure you have Ligatures on for the insertion point, then type the ligature pairs which are pairs of numbers 01, 02, 03, ... 98, 99. Also from the Glyph panel it’s a double, not single-click, to insert the glyph.

 

I don’t set a lot of type in Illustrator, but the Ligature setting is in the Open Type not the Character panel—Standard Ligatures. Looks like Standard Ligatures is on by default, if I uncheck it the barcode glyphs dissappear.

 

Seems to be the same in InDesign. For the 2of5 font—there are 100 number ligature pairs, plus 2 glyps mapped to ; & :

 

Screen Shot 3.png

 

Ligatures unchecked:

 

Screen Shot 4.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines