• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Can I prevent a line break after the end-bracket characters?

New Here ,
Mar 04, 2024 Mar 04, 2024

Copy link to clipboard

Copied

I use a special font, on which the two end-bracket characters ] } have a different image, which fits with others, and I do not want a line break after these symbols.

But Indesign seems to consider that this is an ideal spot to start a new line.  Inserting a discretionary hyphen (before or after the sequence that I want unbroken) does not prevent it.  If there is a regular hyphen just one character later, InDesign nonetheless wants to break after the bracket. For example:

  Hfh-RNa-B]b-Ga-

is broken

  Hfh-RNa-B]

  b-Ga-

(In this case, another couple characters could fit on the top line.)

I have fiddled with hyphenation, turned it off, that doesn't fix it. (INDD doesn't add a hyphen, it doesn't think it is hyphenating a word.) I tried adding B]b to the user dictionary, that didn't help. Resetting language to All Languages didn't help.

 

It does not happen with opening brackets, nor with < >

Earlier INDD versions did not do this.

But for now, is there any way to prevent it? Ideally, within preferences or paragraph style, but even a way to fix individual cases would be helpful.

And REQUEST: Can this feature be dropped? Even people using normal brackets, sometimes will not want a new line there unless there is a space after the bracket.

TOPICS
Feature request , Type

Views

125

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Mar 05, 2024 Mar 05, 2024

You could add it to.tje grep styles too to apply no break 

 

Or add an invisible character called a non-joiner after them by doing search and replace.

Votes

Translate

Translate
Community Expert ,
Mar 04, 2024 Mar 04, 2024

Copy link to clipboard

Copied

Apply no-break to the sequence you want to keep together and see whether that fixes the problem.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 05, 2024 Mar 05, 2024

Copy link to clipboard

Copied

Thanks for the fast reply. I had not known about the No Break feature, and that is VERY helpful for individual cases.

But this comes up a lot. I'd like to find a way to over-ride the InDesign property (or whatever it's called) which makes the program downright eager to put a line break after the two end-bracket symbols. Any suggestions?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 05, 2024 Mar 05, 2024

Copy link to clipboard

Copied

I don't think there's a setting for this, but you can apply n-break to those two characters with a single replacement. In the GREP tab of the Find/Change dialog, look for [}\]] and set no-break in the Change Format panel.

 

As to requests, submit them at https://indesign.uservoice.com

 

P.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 05, 2024 Mar 05, 2024

Copy link to clipboard

Copied

You could add it to.tje grep styles too to apply no break 

 

Or add an invisible character called a non-joiner after them by doing search and replace.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 05, 2024 Mar 05, 2024

Copy link to clipboard

Copied

Thank you very much. Adding the non-joiner character AFTER the end-bracket
fixed the problem. Moreover, I can do a search-and-replace throughout the
document. (the character is ^j ) For my particular problem, this is working
better than using the no-break.

<>
Virus-free.www.avast.com
<>
<#DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 05, 2024 Mar 05, 2024

Copy link to clipboard

Copied

LATEST

Great glad it worked for you

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines