• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Can't type a question mark

Explorer ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

I'm editing an InDesign document created by someone else, and I'm unable to type certain characters, including ? @ # $ % ^. When I type a question mark (or any of the others), nothing happens. Other standard keyboard punctuation marks and special characters work fine.

 

Some of them seem to be keyboard shortcuts for applying styles. For example, if I type #, the paragraph style changes (and if I go to Edit > Undo, I see "Undo Style"), but if I search the keyboard shortcut set (Edit > Keyboard shortcuts - Show Set), Shift+3 comes up empty. (If I just search for Shift+ there are 186 instances.)

 

I am able to enter them through glyphs, but I'd really like to just type a question mark. Any ideas?

TOPICS
How to , Type

Views

53

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Nov 13, 2022 Nov 13, 2022

It sounds like we are on the right track. Check:

Window > Styles > Object Styles, Table Styles and Cell Styles too.

 

~Barb

Likes

Translate

Translate
Explorer ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

Edit - In paragraph 1, when I said "nothing happens," I was referring to Notes mode, where I originally discovered the issue. In paragraph 2, I realized that in regular text mode, some of those characters appear to be undocumented keyboard shortcuts (at least in this document).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

Hi Stu:

 

Let's start by checking your Paragraph Styles panel. Are there Shift + numbers assigned as shortcuts? How about Shift+/? These are user-assigned, so you will not find them in the shortcut list. (Actually, check all of the styles panels: all can be assigned these keyboard shortcuts.)

 

shortcut.png

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

And the same for character (and other) styles.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

Thank you! Shift + the numbers between 2 and 6 are indeed assigned as paragraph styles. But no luck finding found Shift+/  in any of the paragraph or character styles.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

It sounds like we are on the right track. Check:

Window > Styles > Object Styles, Table Styles and Cell Styles too.

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

That did it!!

StuJanis_0-1668351344874.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

LATEST

Aha! Glad it was so straightforward. 

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

Does copy/paste work for the characters in question? Which language are you using (keyboard shortcut sounds like English International but OS / InDesign preferences may differ) and the one who created the document — maybe a different language interferes here with other shortcuts?

 

Finally, which OS and hardware are you on — is this only happening in InDesign or maybe a hardware (keyboard) issue? I know it from Macbooks where keys break easily and resulted in very weird issues similar to your reported one.

 

I couldn’t reproduce easily any of your reported issues so I think it has something to do with custom shortcuts, or local/custom settings in InDesign or the Computer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

I'm using US English, Mac OS 11.7.1. I have no trouble with question marks in any other application. The question marks in my original post was typed the usual way. It's been several years since I've used InDesign (I think the last time was 2020), and I don't remember having that trouble before. However, the documents I worked on back then may not have had any question marks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines