• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Choosing Workspace from Application Bar Not Working

Contributor ,
Nov 14, 2022 Nov 14, 2022

Copy link to clipboard

Copied

After my upgrade to the latest version of InDesign CC on Mac (in both Big Sur and Monterey), I can no longer change or reset my Workspaces using the Application Bar dropdown.The Dropdown shows my currect workspace, but no drropdown list. Window>Workspace works fine and shows all my options.

 

Changing workspaces from all my other Adobe Apps (from application bars) appears to be working fine.

TOPICS
Bug

Views

264

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Nov 14, 2022 Nov 14, 2022

Try resetting your preferences:

Windows: Start InDesign, and then press Shift+Ctrl+Alt. Click Yes when asked if you want to delete preference files.
macOS: While pressing Shift+Option+Command+Control, start InDesign. Click Yes when asked if you want to delete preference files.
A dialog will appear asking to delete the InDesign Preferences, select 'Yes' on this dialog.
Further info and instructions here if needed:
https://helpx.adobe.com/in/indesign/kb/indesign-preferences-support-file-locations.html

Likes

Translate

Translate
Community Expert ,
Nov 14, 2022 Nov 14, 2022

Copy link to clipboard

Copied

Try resetting your preferences:

Windows: Start InDesign, and then press Shift+Ctrl+Alt. Click Yes when asked if you want to delete preference files.
macOS: While pressing Shift+Option+Command+Control, start InDesign. Click Yes when asked if you want to delete preference files.
A dialog will appear asking to delete the InDesign Preferences, select 'Yes' on this dialog.
Further info and instructions here if needed:
https://helpx.adobe.com/in/indesign/kb/indesign-preferences-support-file-locations.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 18, 2022 Nov 18, 2022

Copy link to clipboard

Copied

I found the culprit (I think). I run multiple monitors, but that does not seem to affect the issue.

 

I trashed the prefs as advised and repositioned all my panels on my secondary monitor (as I have for years). Went to the Control Bar to save the custom Workspace and it would not respond. I then turned on the Application Frame (which I usually do not activate) and the workspace dropdown DID start working in the Control Bar.

 

SO with the Application Frame OFF, the Workspaces dropdown does not work. This is new behavior. Also, the top of a New Window is partially obscured by the Contro Bar if Application Frame is off.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 22, 2022 Nov 22, 2022

Copy link to clipboard

Copied

I also noticed tat when I did the procedure to reset the Prefs in InDesign, that somehow all my Prefs were also trashed in all my other Adobe Apps??? (Photoshop, Illustrator, etc,)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 18, 2022 Nov 18, 2022

Copy link to clipboard

Copied

Hi @johnd59898678,

 

Thank you for reaching out. In addition to what our expert has suggested. Please note that resetting preferences will remove all the custom settings, and InDesign will launch with default settings. This way, all your old settings will be saved in .old folders, and InDesign will recreate new folders with default settings. 

 

If reset preference doesn't work, please share the screen recording of the issue so we can investigate further.

 

Thanks,

Harshika

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 15, 2022 Dec 15, 2022

Copy link to clipboard

Copied

Looks like this issue still persists? have to activate Application Frame for Workspaces to show up in menu bar at top right?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 29, 2022 Dec 29, 2022

Copy link to clipboard

Copied

Hi @johnd59898678 ,

what's your exact version of InDesign on what OS version?

 

Thanks,
Uwe Laubender
( Adobe Community Expert )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 29, 2022 Dec 29, 2022

Copy link to clipboard

Copied

InDesign 18.1

Mac OS Monterey 12.6.2 (Mac Pro 2019)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 29, 2022 Dec 29, 2022

Copy link to clipboard

Copied

Hi @johnd59898678 ,

thanks for that. Currently I cannot test this because I'm with InDesign 2023 version 18.1 on a Windows 10 PC.

Hope someone else with a Mac would stop by for testing. No issues with workspaces, custom ones or not, on my side.

 

Hm. Maybe you could try the following:

Change InDesign's default preferences under tab General:

Uncheck this option:

[  ] Show Home Screen When No Documents Are Open

 

Just a shot in the dark…

 

Thanks,
Uwe Laubender
( Adobe Community Expert )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 29, 2022 Dec 29, 2022

Copy link to clipboard

Copied

I just tested InDesign on my M1 2021 16" Macbook Pro (same InDesign version and OS version) and I do not see the issue. So it is just on my main workstation (the Intel Mac Pro with 3 monitors)? Also just in InDesign, all other Adobe apps work as expected. Not a big problem as I never change workspaces in InDesign. The reason it is a nuisance is because I keep my palettes on my left and right monitors and none of my Adobe app workspaces remember the multiple monitor positions, so every time I launch any Adobe app, I have to start by resetting the workspace. Real PITA!

 

Note: I never have the Home Screen checked in Prefs

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 29, 2022 Dec 29, 2022

Copy link to clipboard

Copied

LATEST

Hi @johnd59898678 ,

maybe it's the 3 monitors configuration that is causing the issue?

 

Thanks,
Uwe Laubender
( Adobe Community Expert )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines