• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit Search
0

Colored Rectangle Will Not Export

Community Beginner ,
Jan 26, 2022 Jan 26, 2022

Copy link to clipboard

Copied

I would like my background to be Black so I created a rectangle and sized it to the page and changed FILL to BLACK (not Registration). However, when I go to Export the rectangle/black background does not appear.

All three images that I have placed do appear, but on a white background.

I started testing this by drawing a new box (BLACK and I tried it as BLUE) on a new page and both colors Exported to PDF if the box was not touching the edges. Yet when I size it to be the background it Exports as transparent.

How do I create a colored background that will Export to PDF?

I am in Windows. I read a similar thread on this issue and made sure Window>Outpu>Attributes and Nonprinting is not selected. That other thread didn't get resolved. Any new ideas?

TOPICS
Import and export

Views

168

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 26, 2022 Jan 26, 2022

Copy link to clipboard

Copied

That's strange, @KSymoK. It's working correctly for me. I'm running a rectangle shape to the full trim size (touching all edges). Changing the size of the shape alone should not affect the output. What ID version are you using? Have you shut everything down and tried moving or deleting your Caches file? 

 

JainLemos_0-1643240052570.png

JainLemos_1-1643239792245.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

I'm using ID 17.0.1... you?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

I'm using v.17.0 on Windows 10 Pro.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

Ok, I am on Windows 11. It's very odd. I will try to clear my cache like you recommend.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

Are you using Acrobat or Adobe reader to view the PDF?

Any chance you have enabled Replace Colors in the prefs?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

I am using Acrobot Pro DC. I checked and I did not enable "Replace Colors". Thank you for the idea though.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

WAIT! I was looking at the wrong thing and I did have Replace Colors enabled. When I turned it off, the background color appears. 

Why would Replace Colors be a thing? I hope whoever views my file doesn't have it enabled too.

Thank you so much  @Peter Spier (and @J E L)!

May others not run afoul of this issue themselves. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

Replace colors is a user preference designed to help visually impaired users.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 28, 2022 Jan 28, 2022

Copy link to clipboard

Copied

Oh dear. I feel badly for asking. Thank you again @Peter Spier.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 28, 2022 Jan 28, 2022

Copy link to clipboard

Copied

If we don't ask we never learn new things.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 28, 2022 Jan 28, 2022

Copy link to clipboard

Copied

I'm glad you did because I was focusing on InDesign and not Acrobat as the source and didn't even think to look at this setting. Peter goes to the head of the class!

 

JainLemos_0-1643387146442.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 28, 2022 Jan 28, 2022

Copy link to clipboard

Copied

LATEST

I could swear that at one time there was a checkbox to ignore background color in Acrobat, but I sure can't find it now. Might be in the print dialog as a way to save ink...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines