• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

Contents subheadings displaying under wrong heading

Community Beginner ,
Nov 21, 2023 Nov 21, 2023

Copy link to clipboard

Copied

Hello there,

I am trying to complete the table of contents for a style guide and I am happy with how it looks, however I encountered one frustrating problem (marked in red). How do I ensure my level 3 headings display in their correct level 2 group? e.g. "Secondary", "PANTONE" and "Primary" should sit with "Tertiary" in 4  Colours...

 

Marc32014716m6i6_1-1700626219706.png

 

And bonus question marked in green...
Every time I reopen the table of contents pop-up, inDesign adds a tab indent (^t), when I want it to remain only as a right indent tab (^y). Is there a setting I can turn off/change to stop it from reloading with ^y^t?

Please help, I would be much appreciative!

 

TOPICS
Bug , How to

Views

124

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Nov 21, 2023 Nov 21, 2023

You Wort obviously with several not linked frames. The best way is to have one single text frame for the main story. The second best way is to link the several text frames into one linked story. With the replacement of y to t look into, if you have defined it correctly for all entry styles in your toc. If you do it in one entry style it does not mean all other styles have it correctly now.

Votes

Translate

Translate
Community Expert , Nov 22, 2023 Nov 22, 2023

@Willi Adelberger meant is that your main story/article should be in one threaded series of text frames to guarantee that the sequence of the elements in your TOC will reflect their visual layout sequence in your main story pages.

 

 

You can try to correct this in the layout:

  1. Manually thread/stich your frames together into the correct reading order. Click the OUTport of the first frame in the series, hover and click over the next frame in the series, and so on.
     
  2. Or manually adjust the sequenc
...

Votes

Translate

Translate
Community Beginner ,
Nov 21, 2023 Nov 21, 2023

Copy link to clipboard

Copied

(Contents = Table of Contents/TOC)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 21, 2023 Nov 21, 2023

Copy link to clipboard

Copied

Here is the ideal dynamic outcome (here, I have manually reordered the subheadings)toc correct_manually.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 21, 2023 Nov 21, 2023

Copy link to clipboard

Copied

You Wort obviously with several not linked frames. The best way is to have one single text frame for the main story. The second best way is to link the several text frames into one linked story. With the replacement of y to t look into, if you have defined it correctly for all entry styles in your toc. If you do it in one entry style it does not mean all other styles have it correctly now.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 22, 2023 Nov 22, 2023

Copy link to clipboard

Copied

Thank you for replying to my post. I'm sorry but I don't understand what you mean by single text frame. What I have done so far is create the toc in a single text frame...

 

And the y to t has different entry style settings for the two levels. So I'm not sure if it would be correctly defined if it is different?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 22, 2023 Nov 22, 2023

Copy link to clipboard

Copied

@Willi Adelberger meant is that your main story/article should be in one threaded series of text frames to guarantee that the sequence of the elements in your TOC will reflect their visual layout sequence in your main story pages.

 

 

You can try to correct this in the layout:

  1. Manually thread/stich your frames together into the correct reading order. Click the OUTport of the first frame in the series, hover and click over the next frame in the series, and so on.
     
  2. Or manually adjust the sequence on each page in the Layout panel. This panel is processed from bottom-up, so the bottom-most element is read first in the file's code, then the next. Set this on every page. Also set articles reading order in the Articles panel. Create an article for each major section of your project and drag the elements (text and graphics frames) into it. This reading order is top-down: the top-most elment is read first, etc.

 

Let us know if this helps with the TOC problems.

 

|    Bevi Chagnon   |  Designer & Technologist for Accessible Documents
|    Classes & Books for Accessible InDesign, PDFs & MS Office |

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 22, 2023 Nov 22, 2023

Copy link to clipboard

Copied

LATEST
quote

 

And bonus question marked in green...
Every time I reopen the table of contents pop-up, inDesign adds a tab indent (^t), when I want it to remain only as a right indent tab (^y). Is there a setting I can turn off/change to stop it from reloading with ^y^t?
Please help, I would be much appreciative!

By @Marc32014716m6i6

 

The tab stops and their alignment are controlled in the paragraph style, not in the TOC Styles. Therefore:

  • Have the ^t in the TOC Style (regardless of how it will look).
  • In its matching Paragraph formatting style (Contents/Level 3) set the tab position, tab alignment, and whatever character you want for the leader (in your sample . . . . . .).

 

|    Bevi Chagnon   |  Designer & Technologist for Accessible Documents
|    Classes & Books for Accessible InDesign, PDFs & MS Office |

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines