• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Dictionary changes language for Check Spelling?

Explorer ,
Oct 01, 2021 Oct 01, 2021

Copy link to clipboard

Copied

Hello, using InD 16.4 on Big Sur 11.6. I have a document where I've set the dictionary in Preferences to English USA, and all the paragraph & character styles also have English USA set as the language. However, when I run Check Spelling, it's searching in Arabic. (The text was imported from Word but reformatted with new paragraph styles.)

 

Any suggestions on how to fix this?

 

Screen Shot 2021-10-01 at 5.37.17 PM.pngScreen Shot 2021-10-01 at 5.36.51 PM.pngScreen Shot 2021-10-01 at 5.36.34 PM.png

TOPICS
Bug , Type

Views

2.0K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Oct 02, 2021 Oct 02, 2021

I can reproduce this problem by assigning an incorrect language to the text (language is a text attribute). The dictionary used by spell check will match the language actually assigned to any word. If in fact your styles are set to English, then the language is probably applied as a local override.

One way to correct this would be to use a GREP Find/Change.

 

Find .+  (which will find every character)

In the change format area click the magnifier icon to the right, then choose Advanced Character

...

Votes

Translate

Translate
Community Expert ,
Oct 02, 2021 Oct 02, 2021

Copy link to clipboard

Copied

I can reproduce this problem by assigning an incorrect language to the text (language is a text attribute). The dictionary used by spell check will match the language actually assigned to any word. If in fact your styles are set to English, then the language is probably applied as a local override.

One way to correct this would be to use a GREP Find/Change.

 

Find .+  (which will find every character)

In the change format area click the magnifier icon to the right, then choose Advanced Character Formats from the list in the left of the dialog, and finally select English from the Language dropdown.

 

The downside of this is it will change everything to be assigned English as the languiage, so if there happen to be any words that SHOULD be in another language, they will now be incorrect.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 02, 2021 Oct 02, 2021

Copy link to clipboard

Copied

An additional downside is that the .+ search doesn't find paragraph or line breaks, so they will remain in Arabic, though that won't affect spell checking since they are not part of a word, but it could potentially lead to the wrong language cropping up again in later editing I suppose.

Using (.|\n|\r)+ instead of .+ would solve that.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 03, 2021 Oct 03, 2021

Copy link to clipboard

Copied

That worked, thank you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Dec 07, 2022 Dec 07, 2022

Copy link to clipboard

Copied

That may work but this is stupid and a basic flaw in the program. Why can't one select the desired language? Another factor driving me away from Indesign to an alternate program.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 07, 2022 Dec 07, 2022

Copy link to clipboard

Copied

It is not a flaw to have Language be a character-based attribute; it is quite common to have more than one language present in the same document. For example: I design multi-lingual pacakging. So I may need to be able to assign some text to be English and some to be French within the same document. 

The desired language is selected when setting up Paragraph Styles and Character Styles.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Dec 07, 2022 Dec 07, 2022

Copy link to clipboard

Copied

Really? I never set it up to be French Canadian. The basic Preference should change when a language is selected. Period.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Dec 07, 2022 Dec 07, 2022

Copy link to clipboard

Copied

OK I've checked my character styles and English USA is in fact selected as the dictionary in the style, but the actual text is mysteriously set to Frenc Canadian (not by me). More to the point, if the Preferences selection is a particular dictionary, why doesn't it work? If the character section of the paragraph style is set to a particular dictionary, why does it change?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 07, 2022 Dec 07, 2022

Copy link to clipboard

Copied

quote

OK I've checked my character styles and English USA is in fact selected as the dictionary in the style, but the actual text is mysteriously set to Frenc Canadian (not by me). More to the point, if the Preferences selection is a particular dictionary, why doesn't it work? If the character section of the paragraph style is set to a particular dictionary, why does it change?

 

Well, there are a few different things going on, here. 

 

You can set a default dictionary in the Preferences, it's true, but that only affects new documents that you create; old saved documents won't have their default dictionary changed. Similarly, you can go into the Type menu when you have no documents open, and pick a language there; if you start a new document, then new text frames that you make will have their text contents marked with the language you selected with no documents open.

 

That is basically how defaults work all throughout InDesign. Changing the menus with no documents open will affect all new documents started going forward, but it won't affect old documents. It is quite easy to go back to old documents and change all of the text in them to be marked with a new language, but just picking new default language won't affect those old documents. 

 

I am not sure why your documents have French Canadian as a default. You can go to the Type menu, when you have no documents open, and pick a different language, meaning that all new documents will have that language as default for text in frames that you create. You might want to check in the language preferences of your Creative Cloud app, to see if you're set to French Canadian by default there as well. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Dec 07, 2022 Dec 07, 2022

Copy link to clipboard

Copied

Thanks. I tried changing the dictionary with nothing open. I'm using the
Creative Cloud version of InDesign; is that what you meant?
View my works on paper at andrewogus.com

and in the book "100 Artists of the Male Figure"

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 08, 2022 Dec 08, 2022

Copy link to clipboard

Copied

Thanks. I tried changing the dictionary with nothing open. I'm using the
Creative Cloud version of InDesign; is that what you meant?

 

Hi @Grundoon Groundhog, It isn’t the dictionary that sets the language—it’s the default text setting. Because language is a character property, it can be hard to change a document with mixed languages to a single language without resetting your Preferences.

 

Language is scriptable, you can try this javascript which sets all of the text, and styles in a doc to the chosen language, and gives you the option to make the language your application default:

 

https://shared-assets.adobe.com/link/98453a4b-80c7-49d0-7702-e507d8404479

 

 

Dialog:

 

Screen Shot 15.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 17, 2023 Dec 17, 2023

Copy link to clipboard

Copied

Hi Rob,

I just tried your link above but it came up as an error. I am trying to set our computers to English UK as a language default.  Regards, Leanne

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 17, 2023 Dec 17, 2023

Copy link to clipboard

Copied

LATEST

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 08, 2022 Dec 08, 2022

Copy link to clipboard

Copied

Actually, the dictionary selection in the the prefernces has nothing at all to do with language assignment in the text. That preference allows you to choose which dictionary to use, when more than one is installed, like Hunspell or Proximity, for any language.

 

The ONLY place that language is assigned is at the character level of the actual text, and that can be set as a default, like any other character attribute, by making a language assignment choice with no text selected, or it can be set in a paragraph or character style, but there is no guarantee that the style won't get manually overridden.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 08, 2022 Dec 08, 2022

Copy link to clipboard

Copied


@Grundoon Groundhog wrote:

The basic Preference should change when a language is selected. Period.


That would not work well for anyone who uses more than one language within a single document (I do this all the time), or even works with different languages across documents. I would not want my global preference to change every time I marked a single paragraph as a different language. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Dec 08, 2022 Dec 08, 2022

Copy link to clipboard

Copied

It makes more sense to me to have a basic preference that can be changed paragraph by paragraph. And for the language not to change of its own accord, which it apparently did in my document.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 08, 2022 Dec 08, 2022

Copy link to clipboard

Copied

Paragraph by paragraph does not work - sometimes more than one language can exist in a single paragraph - for instance when I have a paragraph that lists the country of origin of a product repeated within the paragraph for each language used on the package. -- It is a character attribute because that is what works best for most people. 

The language did not change of its own accord; chances are, that attribute was ported from Word when the text was brought in. (I sometimes see this - my text will be set to UK English, and it's always on text imported from Word)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 08, 2022 Dec 08, 2022

Copy link to clipboard

Copied

This discussion illustrates why it is so important to work by means of clean paragraph styles. The main language should be set in all the paragraph styles. 

 

Thereafter, whenever there is a foreign-language word or phrase or sentence or paragraph, it should have a Character Style made and applied to that text where the only thing the Character Style declares is the other language.

 

Publications that don't try to clean up paragraph styles end up having a confusing mixture of paragraph styles overridden by character styles overridden by directly-applied local formatting (where you see the + sign in the styles panels). It makes so much more work trying to untangle these three players.

Mike Witherell

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Dec 08, 2022 Dec 08, 2022

Copy link to clipboard

Copied

Exactly. But if there is a "global" preference, surely it should override. I did not make a change to "French Canadian" from English. Perhaps the authors of various articles in the publication did for reasons of their own, though they were all writing in English.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines