• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

Disable hyphenation by default?

Community Beginner ,
Mar 05, 2019 Mar 05, 2019

Copy link to clipboard

Copied

Hi all.

I'd like indesign to NEVER hyphenate a word for me. It seems I'm having to uncheck the hyphenation box for every text box.

I've tried turning hyphenation off and closing / quitting. When I start a new file it's checked again.

Any ideas?

Many thanks

Views

15.4K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Mar 05, 2019 Mar 05, 2019

Hi Alex,

You should never edit the Basic Paragraph Style, it will cause more trouble for you. As i mentioned you just need make sure that no documents are open and then change the hyphenation to off from the Paragraph panel. Alternatively you could also create a new paragraph style with hyphenation off and make it the default paragraph style for your new documents.

Have a look at the link below for a description on why editing Basic Paragraph Style is a bad idea and how to make a paragraph style a

...

Votes

Translate

Translate
Community Beginner , May 10, 2024 May 10, 2024

Yes, you can turn off hyphenation so that the box is unchecked for every new text box. 
Screenshots at end…

1. If you haven't already, in Preferences > General, uncheck Show Home Screen When No Documents Are Open. (You can turn this back on later if you use its features.)
2. With no documents open, use CMD+OPT+T to open the Paragraph panel. (Alternatively, find it in Window > Type & Tables > Paragraph, OR type "paragraph" in the Help menu search field to jump to that menu item.)
3. Uncheck the Hyphe

...

Votes

Translate

Translate
Participant ,
Oct 23, 2020 Oct 23, 2020

Copy link to clipboard

Copied

As soon as you close all docs, I no longer have access to the palettes. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 25, 2021 Mar 25, 2021

Copy link to clipboard

Copied

You should still have access to the menu bar. Select Window > Type & Tables > Paragraph menu and this should pop the palletes back in. You should be able to make changes to the defaults without an open document from there.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 07, 2022 Apr 07, 2022

Copy link to clipboard

Copied

100% correct. Ive been trying to say the exact same thing! Once all documents are closed....we have no access even when using the menu bar - "Select Window > Type & Tables > Paragrah. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 07, 2022 Apr 07, 2022

Copy link to clipboard

Copied

You can still use the Window menu to switch to your workspace. Then the panels will appear as usual.

 

One way to avoid editing the Basic Paragraph is to create a new paragraph style with no document open (I simply call mine Body). Leave the Basic Paragraph style alone and edit the Body style--then treat it as the Basic Para. replacement. Note that when you make or change settings with no document open, it affects all new documents--not existing ones.

 

Also, consider restricting the hyphenation settings rather than turning them off completely. For example:

image.png

David Creamer: Community Expert (ACI and ACE 1995-2023)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 14, 2021 Oct 14, 2021

Copy link to clipboard

Copied

I heartily disagee with Manan. If you can turn something off, you can always turn it back on. Too bad I've tried to disable it as well to no avail. It's annoying. It slows me down. I have been in the biz successfully for nearly 40 years and have never utilized hyphenation. I sure wish Adobe would make it so we could turn it off permanently.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 07, 2022 Apr 07, 2022

Copy link to clipboard

Copied

Any updates on this? Please do not respond with a paragraph of irrelevant information like the last "correct answer" and please do not respond with "close all your documents" then uncheck the hyphen box because the hyphen box is inaccessible when in fact we close all the documents. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 07, 2022 Apr 07, 2022

Copy link to clipboard

Copied

[…] the hyphen box is inaccessible when in fact we close all the documents.

This is absolutely untrue…

Capture d’écran 2022-04-07 à 19.46.14.jpg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 07, 2022 Apr 07, 2022

Copy link to clipboard

Copied

Absolutely is true sir. Stop the arguments please. 

 

Check out my screenshots sir....posted two of them where it shows the screenshot where the options are greyed out after closing all documents. It is a fact that will all documents closed.......my boxes are greyed out and unaccessible.

 

Show me where it works please good sir! I could certainly use your help. Provide screenshots so we can actually follow your progress in this area!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 07, 2022 Apr 07, 2022

Copy link to clipboard

Copied

Just to make it easier for you.....il post it again in your thread!

 

As you can see......all documents are closed....and all options get greyed out! Thank you!

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 07, 2022 Apr 07, 2022

Copy link to clipboard

Copied

Just to be clear.....we are not talking about InDesign. We are talking about Adobe Illustrator. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 08, 2022 Apr 08, 2022

Copy link to clipboard

Copied

Here are the compiled hyphenation off scripts for both ID and AI:

 

https://shared-assets.adobe.com/link/48e76755-5be4-4d07-752e-ed90bcc8e951

 

To install in Illustrator:

Applications⁩ ▸ ⁨Adobe Illustrator 20XX ▸ ⁨Presets⁩ ▸ ⁨en_US⁩ ▸ ⁨Scripts⁩

 

InDesign:

Applications⁩ ▸ ⁨Adobe InDesign 20XX⁩ ▸ ⁨Scripts⁩ ▸ ⁨Scripts Panel⁩

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 08, 2022 Apr 08, 2022

Copy link to clipboard

Copied

I think it’s worth clarifying that in both InDesign and Illustrator, hyphenation is a paragraph property—it can’t be set as an application or document property. You can turn it off in a Paragraph Style definition, but that would not affect an overridden paragraph or a paragraph with no style applied.

 

Document hyphenation is scriptable—this InDesign script would turn off hyphenation for all of the active document’s text and styles. The same could be done for Illustrator:

 

 

 

//turn off hyphenation in active InDesign document
var d = app.activeDocument;
var ps = d.allParagraphStyles;
var s = d.stories;
var t;
    
for (var i = 1; i < ps.length; i++){
    ps[i].hyphenation = false;
};   

for (var k = 0; k < s.length; k++){
    s[k].hyphenation = false;
    if (s[k].tables.length > 0) {
        t = s[k].tables;
        for (var l = 0; l < t.length; l++){
            t[l].cells.everyItem().paragraphs.everyItem().hyphenation = false;
        };   
    } 
}; 

 

This should work for Illustrator:

 

//turn off hyphenation in active Illustrator document
var d = app.activeDocument;
var ps = d.paragraphStyles;
var s = d.stories;
var sp;

for (var i = 1; i < ps.length; i++){
    ps[i].paragraphAttributes.hyphenation = false;
};   

for (var j = 0; j < s.length; j++){
    sp = s[j].paragraphs;
    for (var k = 0; k < sp.length; k++){
        sp[k].paragraphAttributes.hyphenation = false;
    };   
}; 

 

 

 

 

 

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 10, 2024 May 10, 2024

Copy link to clipboard

Copied

LATEST

Yes, you can turn off hyphenation so that the box is unchecked for every new text box. 
Screenshots at end…

1. If you haven't already, in Preferences > General, uncheck Show Home Screen When No Documents Are Open. (You can turn this back on later if you use its features.)
2. With no documents open, use CMD+OPT+T to open the Paragraph panel. (Alternatively, find it in Window > Type & Tables > Paragraph, OR type "paragraph" in the Help menu search field to jump to that menu item.)
3. Uncheck the Hyphenate option. 
Hyphenation is now off by default for all new text boxes and will "stick" when you close InDesign and restart.
Instructions applicable for InDesign 2023 and 2024.
Screen Shot 2024-05-11 at 09.37.03.png


Screen Shot 2024-05-11 at 09.45.56.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines