• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Enabling Background Tasks

New Here ,
Nov 10, 2020 Nov 10, 2020

Copy link to clipboard

Copied

There used to be a preference to enable and disable background tasks. I historically keep this on. Now when I save, I can't move on to export until the save is complete and vice versa. I'm stuck waiting. Has something changed? I've searched for an answer and have only found something about disabling Background Export in the File menu, but I don't have that in my menu.

 

Mac OS 10.13.6

InDesign 2020

TOPICS
How to , Import and export , Performance

Views

406

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Advisor , Nov 10, 2020 Nov 10, 2020

Hi Acox,

It seems to be working fine on my Mac Book Pro running InDesign 2020, check out the blog post below to see if it helps resolve your issue.

https://creativepro.com/a-new-workaround-for-that-pesky-background-export-issue/

 

Regards,

Mike

Votes

Translate

Translate
Community Expert , Nov 11, 2020 Nov 11, 2020

Hi acox,

even with InDesign 2020 using a text file named DisableAsyncExports.txt should work to disable all exports that work as background tasks and work with a "foreground" task approach that blocks all other things while exporting. Mike showed you an article where the specifics are discussed by Bob Levine. Note: This text was transferred from InDesign Secrets to Creative Pro, because both websites were merged recently. Could be that something went wrong and a question mark was added to the te

...

Votes

Translate

Translate
Advisor ,
Nov 10, 2020 Nov 10, 2020

Copy link to clipboard

Copied

Hi Acox,

It seems to be working fine on my Mac Book Pro running InDesign 2020, check out the blog post below to see if it helps resolve your issue.

https://creativepro.com/a-new-workaround-for-that-pesky-background-export-issue/

 

Regards,

Mike

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 11, 2020 Nov 11, 2020

Copy link to clipboard

Copied

Hi acox,

even with InDesign 2020 using a text file named DisableAsyncExports.txt should work to disable all exports that work as background tasks and work with a "foreground" task approach that blocks all other things while exporting. Mike showed you an article where the specifics are discussed by Bob Levine. Note: This text was transferred from InDesign Secrets to Creative Pro, because both websites were merged recently. Could be that something went wrong and a question mark was added to the text here and there.

 

To make it clear; the mentioned text file's name must be exactly:

DisableAsyncExports.txt

 

So you may have "installed" this file in the past if all your exports are done in the "foreground". After reading Bob's article you should know where to look after it in the InDesign app package.

 

Other reason: You once installed an extension by Marijan Tompa [tomaxxi] that also forces InDesign to use export in "foreground" where possible. You may uninstall that extension to go back to the default behavior of InDesign.

 

Regards,
Uwe Laubender

( ACP )

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 13, 2023 Jan 13, 2023

Copy link to clipboard

Copied

Hi,

 

I'm looking for a solution to enable background tasks in Indesign 2023. Thank you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 13, 2023 Jan 13, 2023

Copy link to clipboard

Copied

Hi @yllinor ,

when did you disable it and how did you do it?

If by using an extension you have to uninstall the extension.

 

Regards,
Uwe Laubender
( Adobe Community Expert )

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 13, 2023 Jan 13, 2023

Copy link to clipboard

Copied

Hi Uwe,

 

Never. No script or extension. However, I just noticed that print/press pdfs have a background task, and interactive pdfs do not. How is that possible?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 13, 2023 Jan 13, 2023

Copy link to clipboard

Copied

Shame that the old start up script does not work anymore (in 2023 Dutch version I get a script error, in earlier version it added the menu but simply did not do anything)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 13, 2023 Jan 13, 2023

Copy link to clipboard

Copied

Background export tasks do not work on book files using the options from the Book panel to export. Only on documents.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 13, 2023 Jan 13, 2023

Copy link to clipboard

Copied

A simple document, not a Book. That's the difference between print and interactive in pdf.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 13, 2023 Jan 13, 2023

Copy link to clipboard

Copied

Hi @yllinor ,

what is your operating system?

Did you try a clean installation of your current version of InDesign?

 

Regards,
Uwe Laubender
( Adobe Community Expert )

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 13, 2023 Jan 13, 2023

Copy link to clipboard

Copied

I installed the 2023 version when it was released, i.e., recently. I have not reinstalled it since.
Win 10. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 13, 2023 Jan 13, 2023

Copy link to clipboard

Copied

LATEST

You could try to trash your InDesign preferences.

 

Quit InDesign, navigate to:

User > YourUserName > AppData > Roaming > Adobe > InDesign

 

There you have the Version 18.0 folder that contains all your preferences for InDesign 2023.

Backup the folder, e.g. zip it, then remove it. InDesign will create a new one from scratch the next time you start up the application.

 

Note: AppData is a invisible folder in your user's folder.

To see it you have turn on the option to see invisible files and folders in Windows Explorer.

 

Regards,
Uwe Laubender
( Adobe Community Expert )

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines