• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Excel csv not recognized in data merge

Community Beginner ,
Jan 09, 2017 Jan 09, 2017

Copy link to clipboard

Copied

I recently updated my Excel and since then the .csv files won't merge into indesign. The indesign and Excel are both updated. When I go to merge the data none of the data fields show in the data merge window to click and insert into the document. When I close the file and reopen in indesign, it says that "the data source cannot be opened." I am only importing .csv files and have not had this problem before. In fact, I used an older .csv file created with the older version of Excel and it uploads just fine into indesign. Does anyone know what is going on and how to fix this?

Views

19.3K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Jun 06, 2017 Jun 06, 2017

You can also open Excel-generated CSVs in Text Edit and save (no changes, just open and press CMD+S). That removes any extraneous Excel encoding and makes the CSV fully InDesign Data Merge-compatible.

Votes

Translate

Translate
Guide ,
Jan 09, 2017 Jan 09, 2017

Copy link to clipboard

Copied

It might help us to know the versions of Excel, InDesign and your operating system. The more specific you can be, the better.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 09, 2017 Jan 09, 2017

Copy link to clipboard

Copied

Sorry it is excel for MAC 15.29.1 and indesign CS6 8.1

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 09, 2017 Jan 09, 2017

Copy link to clipboard

Copied

Can we see a screen shot of the data merge panel? I saw a situation like this not long ago and it was fixed by trashing preferences?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 09, 2017 Jan 09, 2017

Copy link to clipboard

Copied

Sure, I hope this helps!Screen Shot 2017-01-09 at 4.17.38 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jan 09, 2017 Jan 09, 2017

Copy link to clipboard

Copied

Maybe you done some mistakes with data?

To many variables names, wron variables (header) name, empty column, to many empty rows, even alone Enter character in the END of your document? Please try tu use UTF-16 encoding data

Pawel

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 09, 2017 Jan 09, 2017

Copy link to clipboard

Copied

I will try that, the data seems okay it is the format that isn't being recognized which is strange.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jan 09, 2017 Jan 09, 2017

Copy link to clipboard

Copied

Be sure that you close Excel before import data

You can also try to export data to Tabbed text file from Excel and import as data to inDesign Data Merge

Be Sure text file is closed

Pawel

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 29, 2023 Aug 29, 2023

Copy link to clipboard

Copied

I didn't realize you had to make sure excel was closed. I closed it and then it worked right away. Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 12, 2017 Jan 12, 2017

Copy link to clipboard

Copied

I had the same issue this morning and found that if you first go to "Content Placement Options" in the Data Merge Panel, you can check "Remove Blank Lines for Empty Fields" and it works. I will be filing this as a bug.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 06, 2017 Jun 06, 2017

Copy link to clipboard

Copied

You can also open Excel-generated CSVs in Text Edit and save (no changes, just open and press CMD+S). That removes any extraneous Excel encoding and makes the CSV fully InDesign Data Merge-compatible.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 21, 2017 Nov 21, 2017

Copy link to clipboard

Copied

Thank you for the tip - this worked for me!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 02, 2018 May 02, 2018

Copy link to clipboard

Copied

Worked perfectly! Thank you so much!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 26, 2023 Oct 26, 2023

Copy link to clipboard

Copied

This worked for me. Thank you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 09, 2023 Nov 09, 2023

Copy link to clipboard

Copied

LATEST

Legend, thank you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 02, 2018 May 02, 2018

Copy link to clipboard

Copied

My pleasure. I'm glad it helped.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 05, 2019 Feb 05, 2019

Copy link to clipboard

Copied

HI found this helpful! My issue was the Single Record selection couldn't be changed to Multiple records. It was just blanked out. Turns out if you have more than one page in the document it only reads as single record. So start with just one page and you will get the option to import multiple records.

If you can't even import the csv tab delimited document to begin with, try opening the document.csv in Notepad and re-save. This should remove all of excels garbage it tags on.

The link below goes into step by step detail. Important rule 1. was my issue. It's too bad indesign can't recognized when you're having issues and bring up important rules, or helpful tips automatically. No, you just try a hudnred different things  until something works. Or your forced to copy and paste. Aghh

https://gcostudios.com/designing-and-data-merging-with-multiple-records-in-indesign-cs6/

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 26, 2023 Sep 26, 2023

Copy link to clipboard

Copied

On PC, I found that saving out as the correct CSV type in Excel resolved the issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 26, 2023 Sep 26, 2023

Copy link to clipboard

Copied

I have to point out that you've found a fairly old discussion, but also I have to point out that of all the answers posted here, yours is probably the most correct. It's all too easy to forget (or to never know in the first place!) that a raw text file saved on a Mac is encoded differently from a raw text file on a Windows machine, and that CSV is actually a raw text file inside. I suspect that the original post (way back in 2017) was about an update to Mac Excel that caused default CSV file encoding to default to Windows text file encoding. 

 

Sometimes, however, that Unicode CSV that you've crossed out in your PNG actually is the correct encoding, if the values in your file need to be Unicode-encoded. That's typically whenever you are working with non-Latin characters, or extended Latin characters. So if I need to do a Chinese data merge (or Arabic, or Vietnamese, or anything that isn't plain-vanilla Western European) the probably the Unicode CSV choice is the correct choice.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines