• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Exporting to a PDF Without Hidden Layers

New Here ,
Dec 11, 2018 Dec 11, 2018

Copy link to clipboard

Copied

I'm trying to export an InDesign file to a PDF without hidden layers. Right now, whenever I export to a PDF, a bunch of extra invisible text is also exported and it messes with our searchability. The text is invisible in the PDF, but when you do a CTRL+F the hidden text shows up.

For example, we have a master InDesign file with all of our offices (50+) contact information in it. We then reference it in other InDesign files when we want to include our company contact information for that office. However, when the InDesign is exported, the invisible information is also included and the contact info for a bunch of other offices is still somewhere in the PDF.

Is there a way to export from InDesign into a PDF that would not include that other hidden information?

Views

4.8K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Dec 11, 2018 Dec 11, 2018

Hi Sjaani ,

I also tested this. Text will be still there if you export with Acrobat Layers enabled.

I assume our OP, connord78075528,  needs a layered PDF like that:

PDF-ExportSettings-PDF-X-4-AcrobatLayersEnabled.PNG

Note: If Acrobat Layers are enabled ALL layers are exported. Also the hidden ones. Even if you set property Export Layers to Visible Layers Only.

AcrobatLayers-Showing-1.PNG

To prevent that objects on the hidden layers are exported you have to set all objects on that layers to non-printing with InDesign.

You have to do that spread by spread in the InDesign document

...

Votes

Translate

Translate
Community Expert ,
Dec 11, 2018 Dec 11, 2018

Copy link to clipboard

Copied

Hi connord78075528 ,

select all objects on all layers you want to hide and make them non-printable.

Regards,
Uwe

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 11, 2018 Dec 11, 2018

Copy link to clipboard

Copied

Which version of InDesign are you using and what operating system are you on?

I've just done a quick test using Notes or Layers to hide text and neither is visible or searchable in a PDF.

Can you supply an InDesign screenshot showing how you have the hidden text set up in the layers.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 11, 2018 Dec 11, 2018

Copy link to clipboard

Copied

Hi Sjaani ,

I also tested this. Text will be still there if you export with Acrobat Layers enabled.

I assume our OP, connord78075528,  needs a layered PDF like that:

PDF-ExportSettings-PDF-X-4-AcrobatLayersEnabled.PNG

Note: If Acrobat Layers are enabled ALL layers are exported. Also the hidden ones. Even if you set property Export Layers to Visible Layers Only.

AcrobatLayers-Showing-1.PNG

To prevent that objects on the hidden layers are exported you have to set all objects on that layers to non-printing with InDesign.

You have to do that spread by spread in the InDesign document, because you cannot select all objects on a layer document wide if there is more than one spread. A script could help to automate that task.

Regards,
Uwe

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 12, 2018 Dec 12, 2018

Copy link to clipboard

Copied

Note to choose Enable Acrobat Layers, at the top of the dialog you need to choose Compatibility: Acrobat 7 or higher.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 12, 2018 Dec 12, 2018

Copy link to clipboard

Copied

Hi Laubender  I appreciate the response, and this looks like it could work, however, I was looking for something more simple and less labor intensive. It is not realistic for our team to manually hide all unnecessary objects on the layer document for the number of reports we do, then unhide one by one for the objects we want visible on export. The layer document is being linked to many, many other InDesigns and we can't edit the layer document each time for each one.

Is there really no, bullet proof Export option that will hide the hidden text? When you select "Export Layers: Visible Layers" it still includes text that is not visible in the InDesign.

Here are my export settings for reference:

Is there something we can do to the PDFs afterwards that will eliminate hidden text? A compression tool maybe? I would like the visible text to remain searchable, but remove any of the hidden text.

Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 12, 2018 Dec 12, 2018

Copy link to clipboard

Copied

connord78075528  wrote

…Is there really no, bullet proof Export option that will hide the hidden text? When you select "Export Layers: Visible Layers" it still includes text that is not visible in the InDesign. …

Hi,

unfortunately I see no other way. At least if you absolutely need the feature Create Acrobat Layers.

If you don't then all will be very easy. Why do you need layers in the exported PDF?

Regards,
Uwe

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 18, 2023 Dec 18, 2023

Copy link to clipboard

Copied

LATEST

And still people pay for this.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Dec 11, 2018 Dec 11, 2018

Copy link to clipboard

Copied

Hi

Are you opening the pdf with Acrobat or with the windows viewer?

Best

E

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines