• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
3

Extra Space Above the Last Line in a Paragraph?

New Here ,
Jan 06, 2018 Jan 06, 2018

Copy link to clipboard

Copied

Why would I be getting extra space above the last line in a paragraph? The problem isn't in the leading, space before or space after. Settings are the same for them through the whole paragraph, but the last line still gets set off a little too much. Is this a 2018 problem or am I missing something? Any suggestions for how to fix this?

Screen Shot 2018-01-06 at 3.34.46 PM.png

Views

59.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Jan 06, 2018 Jan 06, 2018

Work with paragraph and character styles and remove all overrides at the end.
Apply the paragraph style with holding the ALT key to remove overrides.

Never work without paragraph styles. Never.

The reason is that the return will have a different leading.

Votes

Translate

Translate
Community Expert , Jan 06, 2018 Jan 06, 2018

And to keep this from ever happening again, just enable Apply Leading to Entire Paragraph in Preferences > Type (off as a default).

Screenshot 2018-01-06 17.17.51.png

Votes

Translate

Translate
Enthusiast ,
Jan 06, 2018 Jan 06, 2018

Copy link to clipboard

Copied

Check that all the text has the same leading. The pilcrow (paragraph mark) will have a different leading to the rest of the text.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 06, 2018 Jan 06, 2018

Copy link to clipboard

Copied

Work with paragraph and character styles and remove all overrides at the end.
Apply the paragraph style with holding the ALT key to remove overrides.

Never work without paragraph styles. Never.

The reason is that the return will have a different leading.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 18, 2021 Nov 18, 2021

Copy link to clipboard

Copied

This worked for me, thanks so much!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 30, 2024 Jun 30, 2024

Copy link to clipboard

Copied

This doesn't work at all... what am ai missing?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 06, 2018 Jan 06, 2018

Copy link to clipboard

Copied

Select just the pilcrow. It has a different typesize from everything else and you have auto leading for the paragraph. The leading is in parenthesis because it is auto. You will not see this if the entire paragraph has a specific leading. Make the pilcow the same size as the text and the problem goes away.

There are three ways to select a paragraph:

  • Top to bottom: you may or may not include the pilcrow
  • Bottom to top: you will never include the pilcrow. If you have auto leading and choose a smaller type size you will have this problem. Always.
  • Click 4 times: you will have the pilcrow

Best practices:

  • Use styles
  • Don't use overrides
  • Don't use auto leading

Please ask if there is anything that is not clear.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 08, 2023 Sep 08, 2023

Copy link to clipboard

Copied

This method worked for me best, thank you! So simple.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 06, 2018 Jan 06, 2018

Copy link to clipboard

Copied

And to keep this from ever happening again, just enable Apply Leading to Entire Paragraph in Preferences > Type (off as a default).

Screenshot 2018-01-06 17.17.51.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 13, 2023 Dec 13, 2023

Copy link to clipboard

Copied

This is my biggest beef with Adobe. This program has one job--to correctly format--so why would I ever have to "tell" it to format something correctly?! I came looking for this answer because this has been repeatedly happening to one paragraph in an article, despite it having the proper paragraph style. Who would think you'd have to "prefer" that it follow the paragraph styles the whole program is based on? Maddening!

 

The worst is when Adobe "upgrades" something and automatically chooses the new thing in the update; then you have to spend an hour (on deadline) finding out what the new thing is and how to get it back to what you originally had. If I want to try out new updates I know how to find them, Adobe--let me add them on myself!

 

Luckily we have these forums so the problems are quick to fix. Thanks for this.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 15, 2023 Dec 15, 2023

Copy link to clipboard

Copied

Hi ,

 

Thank you for reaching out and sharing the feedback. I understand how frustrating this can be. For the paragraph styles issue, you can try the suggestions shared in this discussion. For the automatic updates, you can turn it off by following the steps shared here. Feel free to reach out if you need further assistance.

Thanks

Rishabh

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 15, 2023 Dec 15, 2023

Copy link to clipboard

Copied

 

quote

This is my biggest beef with Adobe. This program has one job--to correctly format--so why would I ever have to "tell" it to format something correctly?!

By @mailib84410345

 

What is "correct" for you may not be correct for someone else. If you think the default should be that leading should be a paragraph setting and that those who prefer it as a character setting should be the ones to change it, you can make a feature request for the engineers to consider and for others to upvote.

 

While most of the forums have moved Bugs and Ideas to the Adobe forums, the InDesign team is still using UserVoice for bugs and ideas, so you need to go here to make a feature request:

https://indesign.uservoice.com/

 

Jane

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 05, 2024 Jan 05, 2024

Copy link to clipboard

Copied

In my opinion there is no world in which adding random additional leading to the last line in a paragraph, with no obvious way to fix it, could possibly be considered "correct."

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 05, 2024 Jan 05, 2024

Copy link to clipboard

Copied

Also, of course it should be a paragraph setting. Leading only makes sense in the context of lines of text, not individual characters. Sorry, I don't mean to be snippy but I just spent far too long fixing this with the CEO of my client company virtually breathing down my neck. Have a nice weekend!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 07, 2018 Jan 07, 2018

Copy link to clipboard

Copied

Thanks to all of you. Problem solved. Changing the preferences was extremely helpful.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 07, 2018 Jan 07, 2018

Copy link to clipboard

Copied

btw ... I was logged in under my wife's ID. That's how my name changed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 09, 2020 Jun 09, 2020

Copy link to clipboard

Copied

Looks like the location for those settings changed. Can't find them anymore.  

 

49988710692_a26eae377e_h

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 09, 2020 Jun 09, 2020

Copy link to clipboard

Copied

Ben,  you are sharing a screenshot of Photoshop preferences. Photoshop does not offer the same level of type controls as InDesign. 

 

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 09, 2020 Jun 09, 2020

Copy link to clipboard

Copied

My apologies, that clears up my confusion. I assumed all Adobe software would have this feature especially Photoshop. Thank you very much. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 09, 2020 Jun 09, 2020

Copy link to clipboard

Copied

Hi Ben,

At it's core, Photoshop is an image editor. It has some text capabilities, but not nearly what InDesign has, which is one of many reasons PS should not be used for text formatting. Read my earlier post in this thread (06 Jan 2018). Most of that will work in Photoshop.

~ Jane

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 11, 2020 Aug 11, 2020

Copy link to clipboard

Copied

Genius! Thanks so much. I've been scratching my head for yonks on this one!

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 16, 2024 Apr 16, 2024

Copy link to clipboard

Copied

The short answer is there there is an aspect of the text set to a previous font size. 

The quick solution is to click 4 times on the text and then change the font size. 

(Of course, the long solution is to use paragraph styles, but we're not all superusers).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 29, 2024 Apr 29, 2024

Copy link to clipboard

Copied

Thank you so much.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 04, 2024 Jun 04, 2024

Copy link to clipboard

Copied

Thank you!!

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 30, 2024 Jun 30, 2024

Copy link to clipboard

Copied

LATEST

None of the solutions mentioned in here work at all. Just saying. How about Adobe just doesn't screw it up for everyone and we'll all be fine. Thank in advance. This is nonsensical

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines