• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Extraneous Formatting

Explorer ,
Dec 18, 2023 Dec 18, 2023

Copy link to clipboard

Copied

When importing a manuscript from Word, I get extraneous formatting of text following superscript footnote references. This is also happening with highlighted text from my editor to indicate a possible pull quote (red text). Is there a way to prevent this from happening in settings, or does the Word doc need to be formatted differently?

TOPICS
Bug , Import and export , Type

Views

234

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Dec 18, 2023 Dec 18, 2023

Not surprising. Both Bob and Barb's suggestions are spot-on, but footnotes from Word can be a maddening mess.

 

Try a technical fix on the Word file: save as RTF and either import from that file, or open the RTF in Word and re-save as a DOC (and/or DOCX) file. If one of those won't import properly, or at least with this issue resolved, you may just have to clean up the fault after import, which can be tedious.

Votes

Translate

Translate
Community Expert ,
Dec 18, 2023 Dec 18, 2023

Copy link to clipboard

Copied

Is this really a Word file or is a fake that was exported from a third party word processor? If it's a real Word document, did you have track changes enabled? If so, open it in Word, accept the changes and then resave it and try again.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 18, 2023 Dec 18, 2023

Copy link to clipboard

Copied

Bob, it is a genuine Word doc I'm importing. I did what you suggested and imported it again, but unfortunately it did not resolve the issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 18, 2023 Dec 18, 2023

Copy link to clipboard

Copied

Hi Mike:

 

From your screenshot, I would say that InDesign is assigning superscript to the paragraphs that follow one of the footnote numbers. I'm not sure what's happening to kick this in—I deal with a lot of footnotes, and don't have this specific issue —but let's see if this works:

 

  1. File > Save before you start (so that you can revert if it doesn't work).
  2. Check Type > Document Footnote Options to make sure that InDesign is assigning superscript to the note numbers.
    2023-12-18_08-29-06.png
  3. Right click Footnote Reference in the Character Styles panel > Delete Style. Replace with None and disable Preseve Formatting.
    2023-12-18_08-30-26.png
  4. Check the file over very carefully to make sure that InDesign has removed the superscript from the text. If you see a problem, you can use File > Revert to revert back to the last saved version and then come back and let us know.

 

Note: the red text in your screenshot is likely due to another override. I normally work with the style overrider turned on, so I can quickly locate overrides and remove them.

 

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 18, 2023 Dec 18, 2023

Copy link to clipboard

Copied

Thanks for your suggestions, Barb, but unfortunately they were ineffectual.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 18, 2023 Dec 18, 2023

Copy link to clipboard

Copied

Not surprising. Both Bob and Barb's suggestions are spot-on, but footnotes from Word can be a maddening mess.

 

Try a technical fix on the Word file: save as RTF and either import from that file, or open the RTF in Word and re-save as a DOC (and/or DOCX) file. If one of those won't import properly, or at least with this issue resolved, you may just have to clean up the fault after import, which can be tedious.


┋┊ InDesign to Kindle (& EPUB): A Professional Guide, v3.0 ┊ (Amazon) ┊┋

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 18, 2023 Dec 18, 2023

Copy link to clipboard

Copied

James,

 

Thanks for the suggestion. I saved the .docx file as a .doc file and the resolved the superscript formatting but still have the color issue going on, so I'm going to try saving as RTF to see if that solves the color and italics issue as well.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 18, 2023 Dec 18, 2023

Copy link to clipboard

Copied

James,

 

Saving as RTF worked! Thank you for saving me hours of tedium!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 18, 2023 Dec 18, 2023

Copy link to clipboard

Copied

Great!

 

As noted, import from Word can be a real minefield, for both reasons that are understood and avoidable ( == don't import directly from a Google Docs, Pages, or OpenOffice file; do a Save-As to a new file for import to clean up undo garbage and the like) and as mysterious as why you can't find your car keys.

 

But other than some specific fixes, such as what Barb suggested, the "big hammer" approach is:

  • Save-As the file from a real copy of Word; that ensures compatibility and some doc cleanup.
  • Place the file using the Import Options menu, and do as much style mapping and other orderly conversion as you can.
  • If you still have faults, export the Word file to RTF, re-open, save as DOC and DOCX, and repeat the import using each of those files (RTF is nearly always the most reliable but can lose some formatting elements.)
  • And if none of that works, save the import document, then save it to IDML, open that file, and save as a new INDD file. That does a huge cleanup and 'restucturing' at the InDesign level and often fixes stubbon structural and formating problems.
  • And in the end, just do whatever cleanup/fixup is needed once in InDesign. Unless the file is huge or complex or there are many of them, that tedious pass can be quicker, simpler and more effective than spending more hours trying to get a clean import.

 

And then there's end notes from Word, which can be even more of a hurdle. 😛


┋┊ InDesign to Kindle (& EPUB): A Professional Guide, v3.0 ┊ (Amazon) ┊┋

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 18, 2023 Dec 18, 2023

Copy link to clipboard

Copied

LATEST
I appreciate all the advice, and this community; I knew there was solution somewhere out there!


_________
Mike Riester
Manager of Creative Services
missionbooks.org<> | 719.460.3570

[cid:5641e999-ac3f-444f-9b3f-b17735922c5b]

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines