• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

Footnotes from a placed Word doc are separated into embedded text frames, which I can't thread

New Here ,
Nov 01, 2023 Nov 01, 2023

Copy link to clipboard

Copied

I placed the client's Word doc, which is footnote-heavy, into InDesign, and the footnotes were separated out into individual, embedded text frames at the bottom of each page, which I can't select to thread together, which means I can't get them to flow continuously. I can't apply a paragraph style with numbering to get continuous numbering, and I can't select all the footnote text together to make style edits. It's incredibly frustrating. I saw another similar post and osmone said to try saving the .docx file as a .doc file, and I tried that, but it didn't help. I already reported to the "request a feature". Does anyone have any other ideas for how to get around this issue?

TOPICS
Bug , Feature request , How to

Views

102

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 01, 2023 Nov 01, 2023

Copy link to clipboard

Copied

I believe that's simply how ID handles footnotes, structurally. They are neither part of the main text flow (except, I believe, by a form of redirection for things like search, spell check, etc.) and are independent text elements otherwise, not a block of text like end notes.

 

Your Footnote Preferences should allow you to assign styles to the various elements, and you can manage the layout and style adjustments from there.


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 01, 2023 Nov 01, 2023

Copy link to clipboard

Copied

Hi, @lauragillette ,

sorry, but I don't get what your problems are.

To me it seems your screenshot shows the correct handling of the footnotes.

 

"which I can't select to thread together, which means I can't get them to flow continuously"

What do you mean by this? Please explain, what do you want to achieve.

 

"I can't apply a paragraph style with numbering to get continuous numbering"

As your screenshot shows you have continuous numbering and afaik ID is applying a praragraph format automatically to imported footnotes.

Please explain, what do you want to achieve here.

 

" I can't select all the footnote text together to make style edits"

As footnotes have a paragraph format already (afaik) there is no need to select all the footnotes to make style changes.

Just change the settings of the used paragraph format, save the changes and the changes will be applied to your footnotes.

If you want to do something else please explain.

 

Regards

Stephan

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 01, 2023 Nov 01, 2023

Copy link to clipboard

Copied

Hi @lauragillette:

 

I work with footnote-heavy docs in InDesign. This is my life, so:

 

Your footnotes were imported correctly. This is what they're supposed to do. I rely on style mapping when I import Word docs, but unfortunately footnotes do not respond to the style mapping instructions. The way I format all of them at once is I begin by creating a footnote paragraph style and format the first one until it is perfect. I then rely on Find/Change to update the others.

 

In the clip below, you can see that I am searching for a tab character (because tabs don't appear elsewhere in the file)* and replace with an en space, and then I assign the Footnote style (it's in a style folder, which is why it shows Footnote (Footnote) and not just Footnote). If you do have tabs elsewhere, we can help you figure out how to isolate just the footnotes. I handle the first footnote separately, which was why it was ignored in this particular find change.

 

2023-11-01_10-12-17 (1).gif

 

I will assume that you have located the Footnote Options dialog box by now. If not, that is where you go to control the rest of the footnote formatting, for example, adding more space above the first footnote and the black line above it on each page. If you have additional questions, don't hesitate to reach out and ask.

 

~Barb

 

* Edit: It's actually a Tab Space, replaced with an en dash. The space isn't visible in the Find field, but it's there.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 01, 2023 Nov 01, 2023

Copy link to clipboard

Copied

I then rely on Find/Change to update the others.

 

Interesting. I am trying to remember the last time I imported a doc with footnotes, but I recall them having an assigned style that was easy enough to change up globally, without any need to search them out for updates. Have I been lucky, or am I missing something? 🙂


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 01, 2023 Nov 01, 2023

Copy link to clipboard

Copied

Hi James:

 

If you create a Footnote style, and assign it through Document Footnote Options, and then import the footnotes, they will come in with Footnote assigned (even without style mapping on import).

 

However, they also come in with overrides, and as Laura said in her question, there's no way to globally select all of the footnotes, so the remove override button at the bottom of the paragraph styles panel doesn't work unless you want to removed them one at a time. This workflow is effective for me. 

 

I should also point out that I do this as part of a FindChangeByList script, and in that script, I have already located everything in italics to assign an italic character style, same thing with small caps. In my little video, you can see I'm losing small caps and italics because I just showed the part that addresses Laura's question.

 

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 01, 2023 Nov 01, 2023

Copy link to clipboard

Copied

LATEST

Okay, thanks. That dovetails with my experience and I'm always careful to clean up and apply styles before import, so I don't usually need the secondary steps. But useful info all the same (of course!)


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines